summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlks2015-07-29 12:45:39 +0200
committerlks2015-07-29 12:45:39 +0200
commit427a3bfb01c18df870814f4a734db009d61a2797 (patch)
tree37db620f0bf0860664f231d0bb8c631f41f8e4d3
downloadaur-427a3bfb01c18df870814f4a734db009d61a2797.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD49
-rw-r--r--links.desktop7
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d5017c711e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = links-g-directfb
+ pkgdesc = A text WWW browser, similar to Lynx (with directfb, X and fb graphics)
+ pkgver = 2.9
+ pkgrel = 2
+ url = http://links.twibright.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libxt
+ depends = bzip2
+ depends = xz
+ depends = openssl
+ depends = gpm
+ depends = directfb
+ depends = libx11
+ depends = libtiff
+ depends = libpng
+ depends = libjpeg-turbo
+ provides = links
+ provides = links-g
+ conflicts = links
+ conflicts = links-g
+ replaces = links-g
+ source = http://links.twibright.com/download/links-2.9.tar.bz2
+ source = links.desktop
+ sha1sums = 1202f1ade1075fa4f62e343702e5a0a22cdc2b13
+ sha1sums = a2084166ef252175f14805f2e6a4467c45c51477
+
+pkgname = links-g-directfb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02737911691b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: lks <lukas dot graetz at web dot de>
+# Contributor: JokerBoy <jokerboy at punctweb dot ro>
+# Contributor: sqwishy <sqwishybon@gmail.com>
+# Contributor: Duologic
+
+
+_pkgname=links
+pkgname=links-g-directfb
+pkgver=2.9
+pkgrel=2
+pkgdesc="A text WWW browser, similar to Lynx (with directfb, X and fb graphics)"
+arch=('i686' 'x86_64')
+url="http://links.twibright.com/"
+license=('GPL')
+# 'libx11' 'libxt' packages are for the x11 backend
+# 'directfb' package is for the directfb backend
+depends=('bzip2' 'xz' 'openssl' 'gpm' 'directfb' 'libx11' 'libtiff' 'libpng' 'libjpeg-turbo')
+makedepends=('libxt')
+provides=('links' 'links-g')
+conflicts=('links' 'links-g')
+replaces=('links-g')
+source=(http://links.twibright.com/download/${_pkgname}-${pkgver}.tar.bz2 links.desktop)
+sha1sums=('1202f1ade1075fa4f62e343702e5a0a22cdc2b13'
+ 'a2084166ef252175f14805f2e6a4467c45c51477')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" configure
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ (cd intl; ./gen-intl; ./synclang)
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-javascript \
+ --enable-graphics --with-x --with-fb --with-directfb
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 "${srcdir}/links.desktop" "${pkgdir}/usr/share/applications/links.desktop"
+ install -d "${pkgdir}/usr/share/pixmaps"
+ install -m644 links_16x16_1.xpm links_16x16_2.xpm links_32x32.xpm "${pkgdir}/usr/share/pixmaps/"
+
+ install -d "${pkgdir}/usr/share/doc/links/calibration"
+ install -m644 doc/links_cal/* "${pkgdir}/usr/share/doc/links/calibration/"
+}
diff --git a/links.desktop b/links.desktop
new file mode 100644
index 000000000000..9c9b0d10d846
--- /dev/null
+++ b/links.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Links
+Exec=links -g
+Icon=links_32x32.xpm
+Type=Application
+Terminal=false
+Categories=Network;WebBrowser;