summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2021-03-05 09:13:15 +1300
committerMorgenstern2021-03-05 09:13:15 +1300
commitdac690cfd2fcd1016d942dba015104e7155776b1 (patch)
treec60ea023e94aa997a6440a838761bdd32a1b34fa
parent5df940b2b05434440f68d81eab5a4c0f8525403c (diff)
downloadaur-dac690cfd2fcd1016d942dba015104e7155776b1.tar.gz
Update to v4.0.0, new dependency python-future
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--linode-cli.install12
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1651f690fe3a..5d0562786f75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linode-cli
pkgdesc = Linode API wrapper
- pkgver = 3.3.1
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/linode/linode-cli
install = linode-cli.install
@@ -8,14 +8,15 @@ pkgbase = linode-cli
license = BSD
makedepends = python-wheel
depends = python-colorclass
+ depends = python-future
depends = python-terminaltables
depends = python-requests
depends = python-yaml
optdepends = python-boto: Object Storage plugin
replaces = linode-cli-dev
- source = linode-cli-3.3.1.tar.gz::https://github.com/linode/linode-cli/archive/3.3.1.tar.gz
+ source = linode-cli-4.0.0.tar.gz::https://github.com/linode/linode-cli/archive/4.0.0.tar.gz
source = no-python2.patch
- sha256sums = bf697cb36b885ce88c6565682ac3a575579022d52d0548bb50b70bb7e9514b81
+ sha256sums = f759d4f1ca7f486ffcba9544f9c6ba9abc7505e94ec1122354139c406056deb1
sha256sums = 7a3f1e454ffac21db74ad1e1b8575f4246566fb25966b89a2e30fa8215dd8c13
pkgname = linode-cli
diff --git a/PKGBUILD b/PKGBUILD
index 59473babf52c..608a70f32289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: Slithery <aur [at] slithery [dot] uk>
pkgname=linode-cli
-pkgver=3.3.1
+pkgver=4.0.0
pkgrel=1
pkgdesc="Linode API wrapper"
arch=('any')
url="https://github.com/${pkgname%%-cli}/${pkgname}"
license=('BSD')
-depends=('python-colorclass'
+depends=('python-colorclass'
+ 'python-future'
'python-terminaltables'
'python-requests'
'python-yaml')
@@ -18,7 +19,7 @@ replaces=('linode-cli-dev')
install="${pkgname}".install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname%%-cli}/${pkgname}/archive/${pkgver}.tar.gz"
no-python2.patch)
-sha256sums=('bf697cb36b885ce88c6565682ac3a575579022d52d0548bb50b70bb7e9514b81'
+sha256sums=('f759d4f1ca7f486ffcba9544f9c6ba9abc7505e94ec1122354139c406056deb1'
'7a3f1e454ffac21db74ad1e1b8575f4246566fb25966b89a2e30fa8215dd8c13')
prepare() {
diff --git a/linode-cli.install b/linode-cli.install
index 62100807026b..dfac28621f98 100644
--- a/linode-cli.install
+++ b/linode-cli.install
@@ -1,6 +1,10 @@
post_install() {
- echo
- echo "Run 'linode-cli configure' to configure the CLI with a token and optionally select some default values"
- echo "See https://www.linode.com/docs/platform/api/linode-cli/ for assistance"
- echo
+ echo
+ echo "The first time the CLI runs, it will prompt for configuration. The default is web-based configuration using OAuth."
+ echo "The CLI can also be manually configured or reconfigured using an API token by running the following:"
+ echo
+ echo "linode-cli configure --token"
+ echo
+ echo "See https://www.linode.com/docs/guides/linode-cli/ for assistance"
+ echo
}