summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2017-12-14 15:36:47 -0500
committergraysky2017-12-14 15:36:47 -0500
commit64b48e63a98040e5c502eac45d6935c39225257d (patch)
tree222347a221f15336e496711e0074560218bcfdc8
parent41e8e1bf39d31e4ff279eca67af6663eee72d022 (diff)
downloadaur-64b48e63a98040e5c502eac45d6935c39225257d.tar.gz
Update to 2018.0.006-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
-rw-r--r--linpack_runme_xeon64 (renamed from runme.template)8
3 files changed, 18 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7cbc0d9bc10..fb165421e7ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
# Generated by mksrcinfo v8
-# Wed Jul 12 21:02:44 UTC 2017
+# Thu Dec 14 20:36:46 UTC 2017
pkgbase = linpack
- pkgver = 2017.3.018
+ pkgver = 2018.0.006
pkgrel = 1
url = http://software.intel.com/en-us/articles/intel-math-kernel-library-linpack-download
- arch = i686
arch = x86_64
license = custom
- source = http://registrationcenter-download.intel.com/akdlm/irc_nas/9752/l_mklb_p_2017.3.018.tgz
+ source = http://registrationcenter-download.intel.com/akdlm/irc_nas/9752/l_mklb_p_2018.0.006.tgz
source = linpack.conf
- source = runme.template
- sha256sums = 68abeb11e2b1e38a5d2c214c4f82c6788156e1d205ed66254c04ccd7d37f4d29
+ source = linpack_runme_xeon64
+ sha256sums = 75eca690d91ef065748218f105c2c47b902f1e113b64a0c3f6a8075c80248b95
sha256sums = d7e31c8c7e2648c8fa3c4838d98dfc39b8fadf0f74bdaa4ca52cd38277ec8254
- sha256sums = 8bcd48bd97b3177590f15e922f8f7fb1ebfe6ea0608b4d63d8902ac2bd9b6a52
+ sha256sums = 369736f6074ab579a1df38ba09be4784547833be020f13d1b60374f64ca5d5f6
pkgname = linpack
pkgdesc = Benchmark based on linear algebra excellent app for stress testing.
diff --git a/PKGBUILD b/PKGBUILD
index bfa82d0be458..4cfe56ddc90d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,26 @@
# Contributor: graysky <graysky AT archlinux dot us>
pkgname=('linpack')
-pkgver=2017.3.018
-_math_kernel_lib=2017
+pkgver=2018.0.006
+_math_kernel_lib=2018
_url=9752
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('custom')
url="http://software.intel.com/en-us/articles/intel-math-kernel-library-linpack-download"
source=("http://registrationcenter-download.intel.com/akdlm/irc_nas/$_url/l_mklb_p_$pkgver.tgz"
-'linpack.conf' 'runme.template')
-sha256sums=('68abeb11e2b1e38a5d2c214c4f82c6788156e1d205ed66254c04ccd7d37f4d29'
+'linpack.conf' 'linpack_runme_xeon64')
+sha256sums=('75eca690d91ef065748218f105c2c47b902f1e113b64a0c3f6a8075c80248b95'
'd7e31c8c7e2648c8fa3c4838d98dfc39b8fadf0f74bdaa4ca52cd38277ec8254'
- '8bcd48bd97b3177590f15e922f8f7fb1ebfe6ea0608b4d63d8902ac2bd9b6a52')
-
-build() {
- [[ -z "$CARCH" ]] && echo "Cannot determine architecture of this system!" && exit 1
- [[ "$CARCH" = "x86_64" ]] && bit=64 || bit=32
- export bit
-}
+ '369736f6074ab579a1df38ba09be4784547833be020f13d1b60374f64ca5d5f6')
package_linpack() {
pkgdesc='Benchmark based on linear algebra excellent app for stress testing.'
backup=(etc/linpack.conf)
_base="$srcdir/l_mklb_p_$pkgver/benchmarks_$_math_kernel_lib"
_test="$_base/linux/mkl/benchmarks/linpack"
- # setup based on detected arch
- sed -e "s/@TARGET_BIT@/$bit/g" <runme.template >linpack_runme_xeon$bit
- install -Dm755 linpack_runme_xeon$bit "$pkgdir/usr/bin/linpack_runme_xeon$bit"
+ install -Dm755 linpack_runme_xeon64 "$pkgdir/usr/bin/linpack_runme_xeon64"
install -Dm644 linpack.conf "$pkgdir/usr/share/$pkgname/linpack.conf"
install -Dm644 "$_base/license.txt" "$pkgdir/usr/share/licenses/linpack/license.txt"
- install -Dm755 "$_test/xlinpack_xeon$bit" "$pkgdir/usr/bin/xlinpack_xeon$bit"
+ install -Dm755 "$_test/xlinpack_xeon64" "$pkgdir/usr/bin/xlinpack_xeon64"
}
diff --git a/runme.template b/linpack_runme_xeon64
index 19fa3193c659..b4b5b97e0644 100644
--- a/runme.template
+++ b/linpack_runme_xeon64
@@ -15,12 +15,12 @@ XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
echo -e "Edit \E[31m$XDG_CONFIG_HOME/linpack.conf\E[37m to adjust the amount of physical memory to consume."
echo
echo -e "Starting calculation.... hit ctrl+c to stop."
-echo -e "Consult \E[31m~/lin_xeon@TARGET_BIT@.txt\E[37m for results as they are caculated."
+echo -e "Consult \E[31m~/lin_xeon64.txt\E[37m for results as they are caculated."
date
-date >> ~/lin_xeon@TARGET_BIT@.txt
+date >> ~/lin_xeon64.txt
-/usr/bin/xlinpack_xeon@TARGET_BIT@ $XDG_CONFIG_HOME/linpack.conf >> ~/lin_xeon@TARGET_BIT@.txt
-date >> ~/lin_xeon@TARGET_BIT@.txt
+/usr/bin/xlinpack_xeon64 $XDG_CONFIG_HOME/linpack.conf >> ~/lin_xeon64.txt
+date >> ~/lin_xeon64.txt
echo -n "Done: "
date