summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2016-02-07 08:23:53 -0500
committergraysky2016-02-07 08:23:53 -0500
commite9eec2417971d902faac35b9970a0663f1640904 (patch)
treecd9c294b33120145e50280d6a78b9b1dd535577a
parent4bd7ba2021625cb36ddd428915e13031637e83ad (diff)
downloadaur-e9eec2417971d902faac35b9970a0663f1640904.tar.gz
Update to 11.3.1.002-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31c6b2ce0522..6173712af87d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 13:23:53 UTC 2016
pkgbase = linpack
- pkgver = 11.3.0.006
+ pkgver = 11.3.1.002
pkgrel = 1
url = http://software.intel.com/en-us/articles/intel-math-kernel-library-linpack-download
arch = i686
arch = x86_64
license = custom
- source = http://registrationcenter.intel.com/irc_nas/7963/l_lpk_p_11.3.0.006.tgz
+ source = http://registrationcenter.intel.com/irc_nas/8305/l_mklb_p_11.3.1.002.tgz
source = linpack.conf
source = runme.template
- sha256sums = bbabed3cd3686ead35d8bf59df5c7b6608f7c1919be29f01dda6363ded4c250c
+ sha256sums = aac34c9960a394130bc5b77060dc3e2066d36a8b020465f0ec16d5a30551ed1b
sha256sums = d7e31c8c7e2648c8fa3c4838d98dfc39b8fadf0f74bdaa4ca52cd38277ec8254
sha256sums = 8c880adeee3de6c0e6005e210cea0e01b471219c590e25e824298a25ab0eef31
diff --git a/PKGBUILD b/PKGBUILD
index 057dc8c9c6f0..ecc8395fb417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Contributor: graysky <graysky AT archlinux dot us>
pkgname=('linpack')
-pkgver=11.3.0.006
-_pkgvershort=11.3
-_stupid_number=7963
+pkgver=11.3.1.002
+_math_kernel_lib=11.3.1
+_url=8305
pkgrel=1
arch=('i686' 'x86_64')
license=('custom')
url="http://software.intel.com/en-us/articles/intel-math-kernel-library-linpack-download"
-source=("http://registrationcenter.intel.com/irc_nas/$_stupid_number/l_lpk_p_$pkgver.tgz"
+source=("http://registrationcenter.intel.com/irc_nas/$_url/l_mklb_p_$pkgver.tgz"
'linpack.conf' 'runme.template')
-sha256sums=('bbabed3cd3686ead35d8bf59df5c7b6608f7c1919be29f01dda6363ded4c250c'
+sha256sums=('aac34c9960a394130bc5b77060dc3e2066d36a8b020465f0ec16d5a30551ed1b'
'd7e31c8c7e2648c8fa3c4838d98dfc39b8fadf0f74bdaa4ca52cd38277ec8254'
'8c880adeee3de6c0e6005e210cea0e01b471219c590e25e824298a25ab0eef31')
@@ -24,18 +24,16 @@ package_linpack() {
pkgdesc='Benchmark based on linear algebra excellent app for stress testing.'
install=readme.install
backup=(etc/linpack.conf)
- _path="l_lpk_p_$pkgver/linpack_$_pkgvershort"
- _binpath="$_path/linux/mkl/benchmarks/linpack"
- _docpath="$_path/documentation_2016/en/mkl/common/mkl_userguide"
-
+ _base="$srcdir/l_mklb_p_$pkgver/benchmarks_$_math_kernel_lib"
+ _test="$_base/linux/mkl/benchmarks/linpack"
# setup based on detected arch
sed -e "s/@TARGET_BIT@/$bit/g" <runme.template >linpack_runme_xeon$bit
install -Dm755 linpack_runme_xeon$bit "$pkgdir/usr/bin/linpack_runme_xeon$bit"
install -Dm644 linpack.conf "$pkgdir/etc/linpack.conf"
- install -Dm644 "$srcdir/$_path/lpkEULA.txt" "$pkgdir/usr/share/licenses/linpack/lpkEULA.txt"
- install -Dm644 "$srcdir/$_path/lpksupport.txt" "$pkgdir/usr/share/doc/linpack/lpksupport.txt"
- install -Dm755 "$srcdir/$_binpath/xlinpack_xeon$bit" "$pkgdir/usr/bin/xlinpack_xeon$bit"
- install -Dm644 "$srcdir/$_binpath/xhelp.lpk" "$pkgdir/usr/share/doc/${pkgname}/xhelp.lpk"
- cp -r "$srcdir/$_docpath" "$pkgdir/usr/share/doc/linpack"
+ install -Dm644 "$_base/license.txt" "$pkgdir/usr/share/licenses/linpack/license.txt"
+ install -Dm644 "$_base/support.txt" "$pkgdir/usr/share/doc/linpack/support.txt"
+ install -Dm755 "$_test/xlinpack_xeon$bit" "$pkgdir/usr/bin/xlinpack_xeon$bit"
+ #install -Dm644 "$srcdir/$_binpath/xhelp.lpk" "$pkgdir/usr/share/doc/${pkgname}/xhelp.lpk"
+ #cp -r "$srcdir/$_docpath" "$pkgdir/usr/share/doc/linpack"
}