summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-02-10 23:51:39 -0800
committerBuildTools2016-02-10 23:51:39 -0800
commit12480cda653d670443fbfbd2fb8469c8d6f0febd (patch)
tree3c81d4a36b354d7e79d059c55083a975d1c4f74c
downloadaur-12480cda653d670443fbfbd2fb8469c8d6f0febd.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
-rw-r--r--linpal.desktop8
-rw-r--r--missing-declarations.patch47
5 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac774b4daefb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Feb 11 07:51:22 UTC 2016
+pkgbase = linpal
+ pkgdesc = This software is a Linux based client for various Palace servers.
+ pkgver = 0.5_fixed
+ pkgrel = 1
+ url = http://sourceforge.net/projects/linpal
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libglade
+ depends = curl
+ depends = openssl
+ depends = gtkmm
+ source = http://downloads.sourceforge.net/linpal/linpal-0.5-fixed.tar.bz2
+ source = missing-declarations.patch
+ source = linpal.desktop
+ md5sums = faee16137da59a03dad3aba6e0a50f73
+ md5sums = b9719a895e02b70fc06cf168afd89147
+ md5sums = 2a36cccc1e09f609dbad6c745599498b
+
+pkgname = linpal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..79ffea0ccae6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.bz2
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27f6938b1208
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=linpal
+pkgver=0.5_fixed
+pkgrel=1
+pkgdesc="This software is a Linux based client for various Palace servers."
+arch=(i686 x86_64)
+url="http://sourceforge.net/projects/linpal"
+license=("GPL")
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-${pkgver//_/-}.tar.bz2"
+"missing-declarations.patch"
+"$pkgname.desktop")
+depends=(libglade curl openssl gtkmm)
+md5sums=('faee16137da59a03dad3aba6e0a50f73'
+ 'b9719a895e02b70fc06cf168afd89147'
+ '2a36cccc1e09f609dbad6c745599498b')
+
+build() {
+ cd "$srcdir/$pkgname-${pkgver%_*}"
+ patch -i ../missing-declarations.patch
+ make
+}
+
+
+package() {
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/icons/"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ cd "$srcdir/$pkgname-${pkgver%_*}"
+ install -Dm755 $pkgname "$pkgdir/usr/share/$pkgname/$pkgname"
+ install -m644 default.png "$pkgdir/usr/share/$pkgname/"
+ install -m644 trans.png "$pkgdir/usr/share/$pkgname/"
+ install -m644 world.svg "$pkgdir/usr/share/$pkgname/"
+ install -m644 world48.png "$pkgdir/usr/share/$pkgname/"
+ install -m644 $pkgname.glade "$pkgdir/usr/share/$pkgname/"
+ cp -rf {colors,faces} "$pkgdir/usr/share/$pkgname"
+ ln -s /usr/share/$pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ ln -s /usr/share/$pkgname/world.svg "$pkgdir/usr/share/icons/$pkgname.svg"
+}
diff --git a/linpal.desktop b/linpal.desktop
new file mode 100644
index 000000000000..0b3ec07349c5
--- /dev/null
+++ b/linpal.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=LinPal
+Categories=Network;Games
+GenericName=Palace Client
+Comment=
+Exec=/usr/share/linpal/linpal
+Icon=/usr/share/icons/linpal.svg
diff --git a/missing-declarations.patch b/missing-declarations.patch
new file mode 100644
index 000000000000..3d918e2ddb5a
--- /dev/null
+++ b/missing-declarations.patch
@@ -0,0 +1,47 @@
+Common subdirectories: a/colors and b/colors
+Common subdirectories: a/faces and b/faces
+diff -u a/gtkasset.cpp b/gtkasset.cpp
+--- a/gtkasset.cpp 2004-06-04 03:26:55.000000000 -0700
++++ b/gtkasset.cpp 2012-04-21 22:14:53.537082591 -0700
+@@ -21,6 +21,7 @@
+
+ #include <glib.h>
+ #include <stdio.h>
++#include <cstring>
+
+ #include "gtkmain.h"
+ #include "gtkasset.h"
+diff -u a/gtkbigpage.cpp b/gtkbigpage.cpp
+--- a/gtkbigpage.cpp 2004-06-04 03:26:55.000000000 -0700
++++ b/gtkbigpage.cpp 2012-04-21 22:26:34.480395350 -0700
+@@ -22,6 +22,7 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <cstring>
+
+ #include "gtkbigpage.h"
+ #include "gtkmain.h"
+diff -u a/gtkbigpage.h b/gtkbigpage.h
+--- a/gtkbigpage.h 2004-06-04 03:26:55.000000000 -0700
++++ b/gtkbigpage.h 2012-04-21 22:18:20.940409836 -0700
+@@ -33,6 +33,8 @@
+ gpointer BubbleWatcher(gpointer local);
+ gpointer DLWatcher(gpointer local);
+
++class GtkBubble;
++
+ class BigPage : PalCallback{
+ public:
+ BigPage(GtkWidget * Notebook, GtkWidget * LogNotebook);
+diff -u a/gtkbubble.cpp b/gtkbubble.cpp
+--- a/gtkbubble.cpp 2004-06-04 03:26:55.000000000 -0700
++++ b/gtkbubble.cpp 2012-04-21 22:23:50.803733488 -0700
+@@ -19,6 +19,7 @@
+
+ #include "gtkbubble.h"
+ #include "gtkmain.h"
++#include <cstring>
+
+ GtkBubble::GtkBubble(BigPage * owner){
+ this->owner = owner;