summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 18:31:39 +0100
committerBartłomiej Piotrowski2018-01-07 18:31:39 +0100
commite72926b5476071b47d87c3114a48bb60aa49da88 (patch)
tree504c410cf8589eec5c282de6a77ec748b52a9306
downloadaur-e72926b5476071b47d87c3114a48bb60aa49da88.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO37
-rw-r--r--ChangeLog33
-rw-r--r--PKGBUILD41
-rw-r--r--linphone.install8
4 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0456c8dfe796
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = linphone
+ pkgdesc = A Voice-over-IP phone
+ pkgver = 3.12.0
+ pkgrel = 1
+ url = http://www.linphone.org
+ install = linphone.install
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = perl-xml-parser
+ makedepends = intltool
+ makedepends = sgml-common
+ makedepends = bcunit
+ depends = alsa-lib
+ depends = ffmpeg
+ depends = gtk2
+ depends = speex
+ depends = libv4l
+ depends = libglade
+ depends = v4l-utils
+ depends = libpulse
+ depends = libxv
+ depends = mediastreamer
+ depends = ortp
+ depends = bzrtp
+ depends = bcg729
+ depends = libsoup
+ depends = belle-sip
+ depends = libnotify
+ depends = libldap
+ optdepends = pulseaudio
+ options = !emptydirs
+ source = linphone-3.12.0.tar.gz::https://github.com/BelledonneCommunications/linphone/archive/3.12.0.tar.gz
+ sha256sums = 60fb1e5d25823fecc7ce1955ce7e886e013118a184df1965d1877ffe6cc171b7
+
+pkgname = linphone
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..d876285053fd
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,33 @@
+2008-10-16 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+* v3.0.0 build for x86_64
+
+2008-08-23 Darwin Bautista <djclue917@gmail.com>
+* linphone 2.1.1-3
+* Fixed build against ffmpeg 20080715
+
+2008-04-20 Darwin Bautista <djclue917@gmail.com>
+* linphone 2.1.1-2
+* Fixed md5sums
+
+2008-02-24 Darwin Bautista <djclue917@gmail.com>
+* linphone 2.1.1-1
+* New upstream release
+* makedeps: added 'perlxml'
+* Use internal ortp
+
+2007-12-02 Darwin Bautista <djclue917@gmail.com>
+* linphone 2.0.1-1
+* New upstream release
+
+2007-11-21 Darwin Bautista <djclue917@gmail.com>
+* linphone 2.0.0-1
+* New upstream release
+* depends=(): added 'libexosip2', remove 'libosip2'
+* Bumped minimum required version of dependencies
+
+2007-11-16 Darwin Bautista <djclue917@gmail.com>
+* linphone 1.7.1-1
+* New upstream release
+* Revamped PKGBUILD
+* Fixed dependencies
+* Use external ortp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abc60344afd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+# Contributor: Mark Lee <mark@markelee.com>
+
+pkgname=linphone
+pkgver=3.12.0
+pkgrel=1
+pkgdesc="A Voice-over-IP phone"
+arch=('x86_64')
+url="http://www.linphone.org"
+license=('GPL')
+depends=('alsa-lib' 'ffmpeg' 'gtk2' 'speex' 'libv4l' 'libglade' 'v4l-utils'
+ 'libpulse' 'libxv' 'mediastreamer' 'ortp' 'bzrtp' 'bcg729' 'libsoup'
+ 'belle-sip' 'libnotify' 'libldap')
+makedepends=('pkg-config' 'perl-xml-parser' 'intltool' 'sgml-common' 'bcunit')
+optdepends=('pulseaudio')
+options=('!emptydirs')
+install=linphone.install
+source=("$pkgname-$pkgver.tar.gz::https://github.com/BelledonneCommunications/linphone/archive/$pkgver.tar.gz")
+sha256sums=('60fb1e5d25823fecc7ce1955ce7e886e013118a184df1965d1877ffe6cc171b7')
+
+build() {
+ cd $pkgname-$pkgver
+ export CFLAGS="$CFLAGS -DMS2_GIT_VERSION="'"unknown"'
+ touch coreapi/gitversion.h
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-static --enable-ipv6 --enable-video \
+ --enable-alsa --enable-pulseaudio --disable-artsc --disable-strict \
+ --libexecdir=/usr/lib/$pkgname \
+ --enable-external-mediastreamer \
+ --enable-external-ortp \
+ --enable-zrtp \
+ --enable-ldap
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/linphone.install b/linphone.install
new file mode 100644
index 000000000000..0470a3842e47
--- /dev/null
+++ b/linphone.install
@@ -0,0 +1,8 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ echo "-- Probably you need notification daemon running"
+ echo "-- See https://wiki.archlinux.org/index.php/Desktop_notifications"
+}