summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2019-07-20 13:11:22 -0500
committerfrealgagu2019-07-20 13:11:22 -0500
commitad4a6b3b7e7f8d1e55c0ca879757fa6f340d080e (patch)
tree00970df887602edca748af7816d516dbec4907c2
parenta59972d0778d935110bd4106dd9f5381073e0754 (diff)
downloadaur-ad4a6b3b7e7f8d1e55c0ca879757fa6f340d080e.tar.gz
Fixing issue with gcc9 in belle-sip module. Adding include(CheckSymbolExists) in CMakeLists.txt in ortp module.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--belle-sip.patch32
-rw-r--r--ortp.patch12
4 files changed, 62 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ac826ca173a..bdd16891575d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linphone-desktop-all-git
pkgdesc = A free VoIP and video softphone based on the SIP protocol (Installed in /opt with all deps included).
- pkgver = 4.1.1.r655.95245907
+ pkgver = 4.1.1.r663.4a43f00e
pkgrel = 1
url = https://www.linphone.org/
arch = x86_64
@@ -80,6 +80,8 @@ pkgbase = linphone-desktop-all-git
source = linphone.desktop
source = linphone-desktop.patch
source = linphone.patch
+ source = belle-sip.patch
+ source = ortp.patch
source = soci.patch
sha256sums = SKIP
sha256sums = SKIP
@@ -128,6 +130,8 @@ pkgbase = linphone-desktop-all-git
sha256sums = 346d983f503873811b3a4f72772e5afe4990275526c9e15c1b5cde2ad69a0544
sha256sums = e7574cdb0a5f8d334b1ed1d938fd6c7639e5785b80f01d39e81a682595af4171
sha256sums = c1f54c0634c2d42d091890ed5a73bcecf8c7c2d0c7f052a0014840ab36c64a01
+ sha256sums = 093fa135a00916f171e96f53695de5fb03b2306e2f54b17dc693cb1527591e15
+ sha256sums = 502564a8be79920604abf41b5d5bd2dde12c8c42adb3d92bcd23dcbab8eaf5fb
sha256sums = 61a9a107267658971348343433a0709af7e1160d4227867faa8decd255f0289c
pkgname = linphone-desktop-all-git
diff --git a/PKGBUILD b/PKGBUILD
index 3895e62994d5..4ffce84ba468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=linphone-desktop-all-git
-pkgver=4.1.1.r655.95245907
+pkgver=4.1.1.r663.4a43f00e
pkgrel=1
pkgdesc="A free VoIP and video softphone based on the SIP protocol (Installed in /opt with all deps included)."
arch=("x86_64")
@@ -59,6 +59,8 @@ source=(
"${pkgname%-desktop-all-git}.desktop"
"${pkgname%-all-git}.patch"
"${pkgname%-desktop-all-git}.patch"
+ "belle-sip.patch"
+ "ortp.patch"
"soci.patch"
)
sha256sums=(
@@ -69,6 +71,8 @@ sha256sums=(
"346d983f503873811b3a4f72772e5afe4990275526c9e15c1b5cde2ad69a0544"
"e7574cdb0a5f8d334b1ed1d938fd6c7639e5785b80f01d39e81a682595af4171"
"c1f54c0634c2d42d091890ed5a73bcecf8c7c2d0c7f052a0014840ab36c64a01"
+ "093fa135a00916f171e96f53695de5fb03b2306e2f54b17dc693cb1527591e15"
+ "502564a8be79920604abf41b5d5bd2dde12c8c42adb3d92bcd23dcbab8eaf5fb"
"61a9a107267658971348343433a0709af7e1160d4227867faa8decd255f0289c"
)
@@ -134,6 +138,14 @@ prepare() {
patch -Np1 -i "${srcdir}/${pkgname%-desktop-all-git}.patch"
+ cd "${srcdir}/${pkgname%-all-git}/${pkgname%-desktop-all-git}-sdk/belle-sip"
+
+ patch -Np1 -i "${srcdir}/belle-sip.patch"
+
+ cd "${srcdir}/${pkgname%-all-git}/${pkgname%-desktop-all-git}-sdk/ortp"
+
+ patch -Np1 -i "${srcdir}/ortp.patch"
+
cd "${srcdir}/${pkgname%-all-git}/${pkgname%-desktop-all-git}-sdk/external/soci"
patch -Np1 -i "${srcdir}/soci.patch"
diff --git a/belle-sip.patch b/belle-sip.patch
new file mode 100644
index 000000000000..3242db7326e0
--- /dev/null
+++ b/belle-sip.patch
@@ -0,0 +1,32 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1a77461..fad0227 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -37,7 +37,7 @@ set(VERSION "${PACKAGE_VERSION}")
+ option(ENABLE_SHARED "Build shared library." YES)
+ option(ENABLE_STATIC "Build static library." YES)
+ option(ENABLE_RTP_MAP_ALWAYS_IN_SDP "Always include rtpmap in SDP." OFF)
+-option(ENABLE_STRICT "Build with strict compile options." YES)
++option(ENABLE_STRICT "Build with strict compile options." NO)
+ option(ENABLE_TUNNEL "Enable tunnel support" OFF)
+ option(ENABLE_TESTS "Enable compilation of tests" ON)
+ option(ENABLE_MDNS "Enable multicast DNS" OFF)
+diff --git a/src/dns.h b/src/dns.h
+index ac390ae..33d99de 100644
+--- a/src/dns.h
++++ b/src/dns.h
+@@ -158,14 +158,6 @@ DNS_PUBLIC int *dns_debug_p(void);
+
+ #define dns_quietinit(...) \
+ DNS_PRAGMA_PUSH DNS_PRAGMA_QUIET __VA_ARGS__ DNS_PRAGMA_POP
+-#elif (__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4
+-#define DNS_PRAGMA_PUSH _Pragma("GCC diagnostic push")
+-#define DNS_PRAGMA_QUIET _Pragma("GCC diagnostic ignored \"-Woverride-init\"")
+-#define DNS_PRAGMA_POP _Pragma("GCC diagnostic pop")
+-
+-/* GCC parses the _Pragma operator less elegantly than clang. */
+-#define dns_quietinit(...) \
+- __extension__ ({ DNS_PRAGMA_PUSH DNS_PRAGMA_QUIET __VA_ARGS__; DNS_PRAGMA_POP })
+ #else
+ #define DNS_PRAGMA_PUSH
+ #define DNS_PRAGMA_QUIET
diff --git a/ortp.patch b/ortp.patch
new file mode 100644
index 000000000000..a271fd74ff13
--- /dev/null
+++ b/ortp.patch
@@ -0,0 +1,12 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8a12492..044989a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -46,6 +46,7 @@ include(CheckIncludeFile)
+ include(CheckFunctionExists)
+ include(GNUInstallDirs)
+ include(CheckCSourceCompiles)
++include(CheckSymbolExists)
+
+ if(NOT CMAKE_INSTALL_RPATH AND CMAKE_INSTALL_PREFIX)
+ set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR})