summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-09-26 23:06:36 -0500
committerfrealgagu2018-09-26 23:06:36 -0500
commitecffa2f0aa1b6b68d898e7273b71c838812c38c6 (patch)
tree6879b12b089f4f53ae78b44b617962353845b302
parent477517d3d62ed7b77bf81d8f121aba63ee5f72a0 (diff)
downloadaur-ecffa2f0aa1b6b68d898e7273b71c838812c38c6.tar.gz
Patching soci to avoid -Werror flag. Adding -Wl,--no-as-needed -ldl to LDFLAGS
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--linphone-desktop-submodules.patch326
3 files changed, 16 insertions, 321 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b49296e0dd30..7e3d61f468ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linphone-desktop-all-git
pkgdesc = A free VoIP and video softphone based on the SIP protocol (Installed in /opt with all deps included).
- pkgver = 4.1.1.r525.b717d2ed
- pkgrel = 2
+ pkgver = 4.1.1.r571.da77d41e
+ pkgrel = 1
url = https://www.linphone.org/
arch = x86_64
license = GPL2
@@ -98,7 +98,7 @@ pkgbase = linphone-desktop-all-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 346d983f503873811b3a4f72772e5afe4990275526c9e15c1b5cde2ad69a0544
- sha256sums = 93f80626cb626c25a5608d9fa53ad5ffcc7aed6b91ef3fc766ddd820e79737d3
+ sha256sums = ba70b6fc29dfea030828eb3011d4caa271737001f808b97d534feffb0d4558ad
pkgname = linphone-desktop-all-git
diff --git a/PKGBUILD b/PKGBUILD
index 9ee6d4b2265f..8864f996f63c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=linphone-desktop-all-git
-pkgver=4.1.1.r571.da77d41e
+pkgver=4.1.1.r590.38a09dc3
pkgrel=1
pkgdesc="A free VoIP and video softphone based on the SIP protocol (Installed in /opt with all deps included)."
arch=("x86_64")
@@ -57,7 +57,7 @@ sha256sums=("SKIP"
"SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
"SKIP"
"346d983f503873811b3a4f72772e5afe4990275526c9e15c1b5cde2ad69a0544"
- "93f80626cb626c25a5608d9fa53ad5ffcc7aed6b91ef3fc766ddd820e79737d3")
+ "ba70b6fc29dfea030828eb3011d4caa271737001f808b97d534feffb0d4558ad")
prepare() {
cd "${srcdir}/${pkgname%-all-git}"
@@ -127,6 +127,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-all-git}"
+ export LDFLAGS="-Wl,--no-as-needed -ldl"
./prepare.py -c
./prepare.py --all-codecs
make
diff --git a/linphone-desktop-submodules.patch b/linphone-desktop-submodules.patch
index 5d2d5b488578..43eb4a743878 100644
--- a/linphone-desktop-submodules.patch
+++ b/linphone-desktop-submodules.patch
@@ -12,322 +12,16 @@ index b9d0501d..efda8f09 100644
# ------------------------------------------------------------------------------
set(TARGET_NAME linphone-qt)
-diff --git a/submodules/bcg729/CMakeLists.txt b/submodules/bcg729/CMakeLists.txt
-index cc9116d..2b6fa2b 100644
---- a/submodules/bcg729/CMakeLists.txt
-+++ b/submodules/bcg729/CMakeLists.txt
-@@ -34,8 +34,8 @@ set(PACKAGE_URL "")
- set(VERSION "${PACKAGE_VERSION}")
+diff --git a/submodules/externals/soci/cmake/SociConfig.cmake b/submodules/externals/soci/cmake/SociConfig.cmake
+index 5ac4ce06..8e936a68 100644
+--- a/submodules/externals/soci/cmake/SociConfig.cmake
++++ b/submodules/externals/soci/cmake/SociConfig.cmake
+@@ -51,7 +51,7 @@ if (MSVC)
+ else()
+ set(SOCI_GCC_CLANG_COMMON_FLAGS
+- "-pedantic -Werror -Wno-error=parentheses -Wall -Wextra -Wpointer-arith -Wcast-align -Wcast-qual -Wfloat-equal -Woverloaded-virtual -Wredundant-decls -Wno-long-long")
++ "-pedantic -Wno-error=parentheses -Wall -Wextra -Wpointer-arith -Wcast-align -Wcast-qual -Wfloat-equal -Woverloaded-virtual -Wredundant-decls -Wno-long-long")
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_TESTS "Enable compilation of the tests." NO)
+ set(SOCI_CXX_VERSION_FLAGS "-std=c++11")
- include(GNUInstallDirs)
-diff --git a/submodules/bcmatroska2/CMakeLists.txt b/submodules/bcmatroska2/CMakeLists.txt
-index 2bb6086..d6729f8 100644
---- a/submodules/bcmatroska2/CMakeLists.txt
-+++ b/submodules/bcmatroska2/CMakeLists.txt
-@@ -27,8 +27,8 @@ project(bcmatroska2
- LANGUAGES C
- )
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(CONFIG_EBML_WRITING "Enable EBML file writing support" ON)
- option(CONFIG_EBML_UNICODE "Enable Unicode support" ON)
- option(CONFIG_DEBUGCHECKS "Enable internal checks" ON)
-diff --git a/submodules/bctoolbox/CMakeLists.txt b/submodules/bctoolbox/CMakeLists.txt
-index ee2df9d..5c7e483 100644
---- a/submodules/bctoolbox/CMakeLists.txt
-+++ b/submodules/bctoolbox/CMakeLists.txt
-@@ -39,12 +39,12 @@ set(PROJECT_VERSION_PATCH ${BCTOOLBOX_VERSION_PATCH})
- set(PROJECT_VERSION "${BCTOOLBOX_VERSION}")
-
-
--option(ENABLE_SHARED "Build shared library." ON)
--option(ENABLE_STATIC "Build static library." ON)
-+option(ENABLE_SHARED "Build shared library." OFF)
-+option(ENABLE_STATIC "Build static library." OFF)
- option(ENABLE_POLARSSL "Enable polarssl support" ON)
- option(ENABLE_MBEDTLS "Enable mabedtls support" ON)
- option(ENABLE_DECAF "Enable Elliptic Curve Cryptography support" ON)
--option(ENABLE_STRICT "Pass strict flags to the compiler" ON)
-+option(ENABLE_STRICT "Pass strict flags to the compiler" OFF)
- option(ENABLE_TESTS_COMPONENT "Enable compilation of tests helper library" ON)
- option(ENABLE_TESTS "Enable compilation of tests" ON)
-
-diff --git a/submodules/bcunit/CMakeLists.txt b/submodules/bcunit/CMakeLists.txt
-index da0f295..756dc04 100644
---- a/submodules/bcunit/CMakeLists.txt
-+++ b/submodules/bcunit/CMakeLists.txt
-@@ -39,8 +39,8 @@ set(PACKAGE_TARNAME "bcunit")
- set(PACKAGE_URL "")
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
-
- option(ENABLE_AUTOMATED "Compile BCUnit automated interface" ON)
- option(ENABLE_BASIC "Compile BCUnit basic interface" ON)
-diff --git a/submodules/belcard/CMakeLists.txt b/submodules/belcard/CMakeLists.txt
-index 7da4c98..66056f9 100644
---- a/submodules/belcard/CMakeLists.txt
-+++ b/submodules/belcard/CMakeLists.txt
-@@ -26,9 +26,9 @@ project(BELCARD VERSION 1.0.2 LANGUAGES C CXX)
-
- set(BELCARD_SO_VERSION "1")
-
--option(ENABLE_SHARED "Build shared library." ON)
--option(ENABLE_STATIC "Build static library." ON)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_SHARED "Build shared library." OFF)
-+option(ENABLE_STATIC "Build static library." OFF)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
- option(ENABLE_TOOLS "Enable compilation of tools." YES)
- option(ENABLE_UNIT_TESTS "Enable compilation of unit tests." YES)
-
-diff --git a/submodules/belle-msrp/CMakeLists.txt b/submodules/belle-msrp/CMakeLists.txt
-index d28d927..9884374 100644
---- a/submodules/belle-msrp/CMakeLists.txt
-+++ b/submodules/belle-msrp/CMakeLists.txt
-@@ -30,9 +30,9 @@ set(BELMSRP_MICRO_VERSION "0")
- set(BELMSRP_VERSION "${BELMSRP_MAJOR_VERSION}.${BELMSRP_MINOR_VERSION}.${BELMSRP_MICRO_VERSION}")
- set(BELMSRP_SO_VERSION "1")
-
--option(ENABLE_SHARED "Build shared library." ON)
--option(ENABLE_STATIC "Build static library." ON)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_SHARED "Build shared library." OFF)
-+option(ENABLE_STATIC "Build static library." OFF)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
- option(ENABLE_UNIT_TESTS "Enable compilation of unit tests." YES)
-
- macro(apply_compile_flags SOURCE_FILES)
-diff --git a/submodules/belle-sip/CMakeLists.txt b/submodules/belle-sip/CMakeLists.txt
-index 1a77461..6ff7d1a 100644
---- a/submodules/belle-sip/CMakeLists.txt
-+++ b/submodules/belle-sip/CMakeLists.txt
-@@ -34,10 +34,10 @@ set(PACKAGE_URL "")
- set(VERSION "${PACKAGE_VERSION}")
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_RTP_MAP_ALWAYS_IN_SDP "Always include rtpmap in SDP." OFF)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
- option(ENABLE_TUNNEL "Enable tunnel support" OFF)
- option(ENABLE_TESTS "Enable compilation of tests" ON)
- option(ENABLE_MDNS "Enable multicast DNS" OFF)
-diff --git a/submodules/belr/CMakeLists.txt b/submodules/belr/CMakeLists.txt
-index 38567dd..33762f7 100644
---- a/submodules/belr/CMakeLists.txt
-+++ b/submodules/belr/CMakeLists.txt
-@@ -25,9 +25,9 @@ project(BELR VERSION 0.1.3 LANGUAGES C CXX)
-
- set(BELR_SO_VERSION "1")
-
--option(ENABLE_SHARED "Build shared library." ON)
--option(ENABLE_STATIC "Build static library." ON)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_SHARED "Build shared library." OFF)
-+option(ENABLE_STATIC "Build static library." OFF)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
- option(ENABLE_TOOLS "Turn on or off compilation of tools." YES)
- option(ENABLE_TESTS "Enable compilation of unit tests." YES)
-
-diff --git a/submodules/bzrtp/CMakeLists.txt b/submodules/bzrtp/CMakeLists.txt
-index 4a894e6..81917b7 100644
---- a/submodules/bzrtp/CMakeLists.txt
-+++ b/submodules/bzrtp/CMakeLists.txt
-@@ -25,10 +25,10 @@ cmake_minimum_required(VERSION 3.0)
- project(bzrtp VERSION 1.0.6 LANGUAGES C CXX)
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_ZIDCACHE "Turn on compilation of ZID cache, request sqlite" YES)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
- option(ENABLE_TESTS "Enable compilation of unit tests." NO)
-
-
-diff --git a/submodules/linphone/CMakeLists.txt b/submodules/linphone/CMakeLists.txt
-index fee1f725e..7d88cf786 100644
---- a/submodules/linphone/CMakeLists.txt
-+++ b/submodules/linphone/CMakeLists.txt
-@@ -37,10 +37,10 @@ string(REPLACE ";" " " LINPHONE_ALL_LANGS "${LINPHONE_ALL_LANGS_LIST}")
- include(CMakeDependentOption)
- include(cmake/Tools.cmake)
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
-
--option(ENABLE_CONSOLE_UI "Turn on or off compilation of console interface." YES)
-+option(ENABLE_CONSOLE_UI "Turn on or off compilation of console interface." NO)
- option(ENABLE_CSHARP_WRAPPER "Build the C# wrapper for Liblinphone." OFF)
- option(ENABLE_JAVA_WRAPPER "Build the Java wrapper for Liblinphone." OFF)
- option(ENABLE_CXX_WRAPPER "Build the C++ wrapper for Liblinphone." YES)
-@@ -50,10 +50,10 @@ option(ENABLE_DEBUG_LOGS "Turn on or off debug level logs." NO)
- option(ENABLE_DOC "Enable API documentation generation." NO)
- option(ENABLE_JAVADOC "Add a target to generate documentation for Java API" NO)
- option(ENABLE_LDAP "Enable LDAP support." NO)
--option(ENABLE_RELATIVE_PREFIX "Find resources relatively to the installation directory." NO)
-+option(ENABLE_RELATIVE_PREFIX "Find resources relatively to the installation directory." YES)
- option(ENABLE_ROOTCA_DOWNLOAD "Download rootca.pem at build time." YES)
- option(ENABLE_SQLITE_STORAGE "Turn on compilation sqlite storage, for messages, contacts, history" YES)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
- option(ENABLE_TOOLS "Turn on or off compilation of tools." YES)
- option(ENABLE_TUNNEL "Turn on compilation of tunnel support." NO)
- option(ENABLE_TUTORIALS "Enable compilation of tutorials." YES)
-diff --git a/submodules/mediastreamer2/CMakeLists.txt b/submodules/mediastreamer2/CMakeLists.txt
-index 5f22a1cd..c7960efb 100644
---- a/submodules/mediastreamer2/CMakeLists.txt
-+++ b/submodules/mediastreamer2/CMakeLists.txt
-@@ -57,15 +57,15 @@ endif()
-
- include(CMakeDependentOption)
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_DEBUG_LOGS "Enable the display of traces showing the execution of the library." NO)
- option(ENABLE_DOC "Enable documentation generation with Doxygen." YES)
- option(ENABLE_FIXED_POINT "Turn on fixed point computations." ${ENABLE_FIXED_POINT_DEFAULT_VALUE})
- option(ENABLE_NON_FREE_CODECS "Allow inclusion of non-free codecs in the build." NO)
- option(ENABLE_PCAP "Enable PCAP support." NO)
--option(ENABLE_STRICT "Build with strict compile options." YES)
--option(ENABLE_RELATIVE_PREFIX "Find resources relatively to the installation directory." NO)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
-+option(ENABLE_RELATIVE_PREFIX "Find resources relatively to the installation directory." YES)
- option(ENABLE_TOOLS "Turn on or off compilation of tools." YES)
- option(ENABLE_UNIT_TESTS "Enable compilation of unit tests." YES)
-
-diff --git a/submodules/msamr/CMakeLists.txt b/submodules/msamr/CMakeLists.txt
-index ffe27cf..9e41763 100644
---- a/submodules/msamr/CMakeLists.txt
-+++ b/submodules/msamr/CMakeLists.txt
-@@ -34,8 +34,8 @@ set(PACKAGE_URL "")
- set(VERSION "${PACKAGE_VERSION}")
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_NARROWBAND "Enable AMR narrowband." YES)
- option(ENABLE_WIDEBAND "Enable AMR wideband." NO)
-
-diff --git a/submodules/msopenh264/CMakeLists.txt b/submodules/msopenh264/CMakeLists.txt
-index 479fb2d..7b54fe5 100644
---- a/submodules/msopenh264/CMakeLists.txt
-+++ b/submodules/msopenh264/CMakeLists.txt
-@@ -34,8 +34,8 @@ set(PACKAGE_URL "")
- set(VERSION "${PACKAGE_VERSION}")
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_DECODER "Enable the openh264 decoder" Yes)
-
- include(GNUInstallDirs)
-diff --git a/submodules/mssilk/CMakeLists.txt b/submodules/mssilk/CMakeLists.txt
-index 69fd638..af32f0f 100644
---- a/submodules/mssilk/CMakeLists.txt
-+++ b/submodules/mssilk/CMakeLists.txt
-@@ -24,8 +24,8 @@ cmake_minimum_required(VERSION 3.0)
- project(mssilk VERSION 1.1.1 LANGUAGES C)
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
-
-
- include(GNUInstallDirs)
-diff --git a/submodules/mswasapi/CMakeLists.txt b/submodules/mswasapi/CMakeLists.txt
-index fd5fa92..a08810a 100644
---- a/submodules/mswasapi/CMakeLists.txt
-+++ b/submodules/mswasapi/CMakeLists.txt
-@@ -30,9 +30,9 @@ set(MSWASAPI_MICRO_VERSION "0")
- set(MSWASAPI_VERSION "${MSWASAPI_MAJOR_VERSION}.${MSWASAPI_MINOR_VERSION}.${MSWASAPI_MICRO_VERSION}")
- set(MSWASAPI_SO_VERSION "0")
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
-
-
- macro(apply_compile_flags SOURCE_FILES)
-diff --git a/submodules/mswebrtc/CMakeLists.txt b/submodules/mswebrtc/CMakeLists.txt
-index e18a9b5..a2dd8bd 100644
---- a/submodules/mswebrtc/CMakeLists.txt
-+++ b/submodules/mswebrtc/CMakeLists.txt
-@@ -34,8 +34,8 @@ set(PACKAGE_URL "")
- set(VERSION "${PACKAGE_VERSION}")
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_AEC "Enable the WebRTC echo canceller support." YES)
- option(ENABLE_AECM "Enable the WebRTC echo canceller for mobile support." YES)
- option(ENABLE_ISAC "Enable the ISAC audio codec support." YES)
-diff --git a/submodules/msx264/CMakeLists.txt b/submodules/msx264/CMakeLists.txt
-index ba97d92..bb2df76 100644
---- a/submodules/msx264/CMakeLists.txt
-+++ b/submodules/msx264/CMakeLists.txt
-@@ -34,8 +34,8 @@ set(PACKAGE_URL "")
- set(VERSION "${PACKAGE_VERSION}")
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
-
-
- include(GNUInstallDirs)
-diff --git a/submodules/ortp/CMakeLists.txt b/submodules/ortp/CMakeLists.txt
-index 13c9718..ab7313c 100644
---- a/submodules/ortp/CMakeLists.txt
-+++ b/submodules/ortp/CMakeLists.txt
-@@ -31,12 +31,12 @@ set(ORTP_VERSION ${PROJECT_VERSION})
- set(ORTP_SO_VERSION "13") # incremented on January 10, 2017
-
-
--option(ENABLE_SHARED "Build shared library." YES)
--option(ENABLE_STATIC "Build static library." YES)
-+option(ENABLE_SHARED "Build shared library." NO)
-+option(ENABLE_STATIC "Build static library." NO)
- option(ENABLE_DOC "Enable documentation generation with Doxygen." YES)
- option(ENABLE_NTP_TIMESTAMP "Turn on NTP timestamping on packet reception." NO)
- option(ENABLE_PERF "Disable costly features to reduce cpu consumtion and increase performance." NO)
--option(ENABLE_STRICT "Build with strict compile options." YES)
-+option(ENABLE_STRICT "Build with strict compile options." NO)
- option(ENABLE_TESTS "Enable compilation of test programs." NO)
- option(ENABLE_DEBUG_LOGS "Turn on or off debug level logs." NO)
- set(WITH_THREAD_STACK_SIZE "0" CACHE STRING "Set thread stack size (0 is the OS default).")