summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-12-16 21:02:10 -0500
committerGuillaume Horel2019-12-16 21:02:10 -0500
commit9179f38ab26369a48bff1488e6ed95b9d51a32f2 (patch)
treebe993785cac7d416426647c981090e19ba11e5af
parent8ad52c641a21d2b6fdc36c74e4b09420ec123d87 (diff)
downloadaur-9179f38ab26369a48bff1488e6ed95b9d51a32f2.tar.gz
fix dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
-rw-r--r--cmake.patch25
-rw-r--r--deprecated.patch79
-rw-r--r--find_minizip2.patch13
-rw-r--r--linker.patch12
6 files changed, 140 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b9c7af4bb5d..a243c924f820 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,6 @@ pkgbase = linphone-desktop-git
license = GPL
makedepends = cmake
makedepends = git
- makedepends = pkg-config
makedepends = python-pystache
makedepends = qt5-tools
depends = bcg729-git
@@ -19,22 +18,26 @@ pkgbase = linphone-desktop-git
depends = libpulse
depends = libxv
depends = mediastreamer-git
- depends = minizip2-2.3.3
+ depends = minizip-git
depends = ortp-git
depends = libsoup
depends = libnotify
depends = qt5-svg
- depends = qt5-graphicaleffects
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
+ depends = qt5-graphicaleffects
optdepends = pulseaudio
provides = linphone-desktop
conflicts = linphone-desktop
options = !emptydirs
source = git+https://github.com/BelledonneCommunications/linphone-desktop.git
- source = linker.patch
+ source = cmake.patch
+ source = deprecated.patch
+ source = find_minizip2.patch
sha256sums = SKIP
- sha256sums = 02c3d9dd31f7369cdbb2871c11cc46c7c86867b2b220c6ca1390ead320b6dcd0
+ sha256sums = f251ef179dc6c3fb22449f2a0bd2014c082642747e201a992b3eaf2db6e50544
+ sha256sums = 93170eda1b55987c61171e18afb94182672302b03f34658b817fe8b46f1af545
+ sha256sums = c2dbf6e11105c010fdcc2cc90b0087ded595c05ba9a3324e1f57cc04383e8180
pkgname = linphone-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index 06eaf1238d09..7a02a9151637 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,22 @@ arch=('x86_64')
url="http://www.linphone.org"
license=('GPL')
depends=('bcg729-git' 'belcard-git' 'belle-sip-git' 'belr-git' 'bzrtp-git'
- 'linphone-git' 'libpulse' 'libxv' 'mediastreamer-git' 'minizip2-2.3.3'
- 'ortp-git' 'libsoup' 'libnotify' 'qt5-svg' 'qt5-graphicaleffects'
- 'qt5-quickcontrols' 'qt5-quickcontrols2')
-makedepends=('cmake' 'git' 'pkg-config' 'python-pystache' 'qt5-tools')
+ 'linphone-git' 'libpulse' 'libxv' 'mediastreamer-git' 'minizip-git'
+ 'ortp-git' 'libsoup' 'libnotify' 'qt5-svg' 'qt5-quickcontrols'
+ 'qt5-quickcontrols2' 'qt5-graphicaleffects')
+makedepends=('cmake' 'git' 'python-pystache' 'qt5-tools')
optdepends=('pulseaudio')
options=('!emptydirs')
provides=('linphone-desktop')
conflicts=('linphone-desktop')
-source=("git+https://github.com/BelledonneCommunications/linphone-desktop.git"
- "linker.patch")
+source=('git+https://github.com/BelledonneCommunications/linphone-desktop.git'
+ 'cmake.patch'
+ 'deprecated.patch'
+ 'find_minizip2.patch')
sha256sums=('SKIP'
- '02c3d9dd31f7369cdbb2871c11cc46c7c86867b2b220c6ca1390ead320b6dcd0')
+ 'f251ef179dc6c3fb22449f2a0bd2014c082642747e201a992b3eaf2db6e50544'
+ '93170eda1b55987c61171e18afb94182672302b03f34658b817fe8b46f1af545'
+ 'c2dbf6e11105c010fdcc2cc90b0087ded595c05ba9a3324e1f57cc04383e8180')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -29,15 +33,15 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- patch -p1 < ../linker.patch
+ patch -p1 < ../cmake.patch
+ patch -p1 < ../deprecated.patch
+ patch -p1 < ../find_minizip2.patch
}
build() {
cd $_pkgname
cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DMINIZIP_INCLUDE_DIRS=/usr/include/minizip2 \
- -DMINIZIP_LIBRARIES=/usr/lib/minizip2/libminizip.so .
+ -DCMAKE_PREFIX_PATH=/usr .
make
}
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..3c8ec1460394
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,25 @@
+diff -urN linphone-desktop-orig/CMakeLists.txt linphone-desktop/CMakeLists.txt
+--- linphone-desktop-orig/CMakeLists.txt 2019-12-11 15:09:50.860066429 -0500
++++ linphone-desktop/CMakeLists.txt 2019-12-11 15:19:48.657454271 -0500
+@@ -97,17 +97,10 @@
+
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+
+-if (LINPHONE_BUILDER_GROUP_EXTERNAL_SOURCE_PATH_BUILDERS)
+- include("${EP_linphone_CONFIG_DIR}/wrappers/cpp/LinphoneCxxConfig.cmake")
+- include("${EP_bctoolbox_CONFIG_DIR}/BcToolboxConfig.cmake")
+- include("${EP_belcard_CONFIG_DIR}/BelcardConfig.cmake")
+- include("${EP_ms2_CONFIG_DIR}/Mediastreamer2Config.cmake")
+-else ()
+- find_package(LinphoneCxx REQUIRED)
+- find_package(BcToolbox REQUIRED)
+- find_package(Belcard REQUIRED)
+- find_package(Mediastreamer2 REQUIRED)
+-endif ()
++find_package(LinphoneCxx REQUIRED CONFIG)
++find_package(bctoolbox REQUIRED)
++find_package(belcard REQUIRED CONFIG)
++find_package(Mediastreamer2 REQUIRED CONFIG)
+ find_package(Minizip REQUIRED)
+
+ set(SOURCES
diff --git a/deprecated.patch b/deprecated.patch
new file mode 100644
index 000000000000..0b4bbac59eca
--- /dev/null
+++ b/deprecated.patch
@@ -0,0 +1,79 @@
+diff --git a/src/app/logger/Logger.cpp b/src/app/logger/Logger.cpp
+index c7146342..09206551 100644
+--- a/src/app/logger/Logger.cpp
++++ b/src/app/logger/Logger.cpp
+@@ -202,7 +202,7 @@ void Logger::init (const shared_ptr<linphone::Config> &config) {
+ {
+ shared_ptr<linphone::LoggingService> loggingService = mInstance->mLoggingService = linphone::LoggingService::get();
+ loggingService->setLogLevel(linphone::LogLevel::Message);
+- loggingService->setListener(make_shared<LinphoneLogger>(mInstance));
++ loggingService->addListener(make_shared<LinphoneLogger>(mInstance));
+ }
+
+ linphone::Core::setLogCollectionPath(Utils::appStringToCoreString(folder));
+diff --git a/src/components/assistant/AssistantModel.cpp b/src/components/assistant/AssistantModel.cpp
+index 9bb8f3e1..918e31e5 100644
+--- a/src/components/assistant/AssistantModel.cpp
++++ b/src/components/assistant/AssistantModel.cpp
+@@ -150,7 +150,7 @@ AssistantModel::AssistantModel (QObject *parent) : QObject(parent) {
+ mAccountCreator = core->createAccountCreator(
+ core->getConfig()->getString("assistant", "xmlrpc_url", DefaultXmlrpcUri)
+ );
+- mAccountCreator->setListener(mHandlers);
++ mAccountCreator->addListener(mHandlers);
+ }
+
+ // -----------------------------------------------------------------------------
+diff --git a/src/components/chat/ChatModel.cpp b/src/components/chat/ChatModel.cpp
+index ebba5d24..78f7a55c 100644
+--- a/src/components/chat/ChatModel.cpp
++++ b/src/components/chat/ChatModel.cpp
+@@ -409,7 +409,7 @@ void ChatModel::removeAllEntries () {
+
+ void ChatModel::sendMessage (const QString &message) {
+ shared_ptr<linphone::ChatMessage> _message = mChatRoom->createMessage(Utils::appStringToCoreString(message));
+- _message->setListener(mMessageHandlers);
++ _message->addListener(mMessageHandlers);
+
+ insertMessageAtEnd(_message);
+ mChatRoom->sendChatMessage(_message);
+@@ -435,7 +435,7 @@ void ChatModel::resendMessage (int id) {
+ case MessageStatusFileTransferError:
+ case MessageStatusNotDelivered: {
+ shared_ptr<linphone::ChatMessage> message = static_pointer_cast<linphone::ChatMessage>(entry.second);
+- message->setListener(mMessageHandlers);
++ message->addListener(mMessageHandlers);
+ message->resend();
+
+ break;
+@@ -473,7 +473,7 @@ void ChatModel::sendFileMessage (const QString &path) {
+
+ shared_ptr<linphone::ChatMessage> message = mChatRoom->createFileTransferMessage(content);
+ message->setFileTransferFilepath(Utils::appStringToCoreString(path));
+- message->setListener(mMessageHandlers);
++ message->addListener(mMessageHandlers);
+
+ createThumbnail(message);
+
+@@ -518,7 +518,7 @@ void ChatModel::downloadFile (int id) {
+ }
+
+ message->setFileTransferFilepath(Utils::appStringToCoreString(safeFilePath));
+- message->setListener(mMessageHandlers);
++ message->addListener(mMessageHandlers);
+
+ if (!message->downloadFile())
+ qWarning() << QStringLiteral("Unable to download file of entry %1.").arg(id);
+diff --git a/src/components/sound-player/SoundPlayer.cpp b/src/components/sound-player/SoundPlayer.cpp
+index 7c02401a..2c2d4762 100644
+--- a/src/components/sound-player/SoundPlayer.cpp
++++ b/src/components/sound-player/SoundPlayer.cpp
+@@ -143,7 +143,7 @@ void SoundPlayer::buildInternalPlayer () {
+ mInternalPlayer = coreManager->getCore()->createLocalPlayer(
+ Utils::appStringToCoreString(settingsModel->getRingerDevice()), "", nullptr
+ );
+- mInternalPlayer->setListener(mHandlers);
++ mInternalPlayer->addListener(mHandlers);
+
+ QObject::connect(settingsModel, &SettingsModel::ringerDeviceChanged, this, [this] {
+ rebuildInternalPlayer();
diff --git a/find_minizip2.patch b/find_minizip2.patch
new file mode 100644
index 000000000000..23a6a5971dc9
--- /dev/null
+++ b/find_minizip2.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/FindMinizip.cmake b/cmake/FindMinizip.cmake
+index 131bd051..c30ef9fd 100644
+--- a/cmake/FindMinizip.cmake
++++ b/cmake/FindMinizip.cmake
+@@ -36,7 +36,7 @@ if(MINIZIP_INCLUDE_DIRS)
+ endif()
+
+ find_library(MINIZIP_LIBRARIES
+- NAMES minizip minizipd
++ NAMES minizip2
+ )
+
+ include(FindPackageHandleStandardArgs)
diff --git a/linker.patch b/linker.patch
deleted file mode 100644
index 543b00f382f6..000000000000
--- a/linker.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b9d0501d..ac919122 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -77,6 +77,7 @@ endif ()
- set(CUSTOM_FLAGS "${CUSTOM_FLAGS} -DQT_NO_EXCEPTIONS")
-
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${CUSTOM_FLAGS}")
-+set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
- # See: http://stackoverflow.com/a/1372836
- if (WIN32)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_WINSOCKAPI_")