summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-12-16 22:46:21 -0500
committerGuillaume Horel2019-12-16 22:46:21 -0500
commit1f44b5227852c4ab9e9fe41e1c3b33b262c40cf1 (patch)
tree115972dc862cc3c2acdf13a7458d77f422ba656e
parent3df809ae88698ae032da7525b299e2a91bf81e9c (diff)
downloadaur-1f44b5227852c4ab9e9fe41e1c3b33b262c40cf1.tar.gz
version bump
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD14
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 094ce03aebbe..feb571787019 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linphone-git
pkgdesc = A Voice-over-IP phone library and CLI
- pkgver = 4.3.0.alpha.r14.g2724e7bcf
+ pkgver = 4.4.0.alpha.r6.g0039298ee
pkgrel = 1
url = http://www.linphone.org
install = linphone.install
@@ -10,29 +10,27 @@ pkgbase = linphone-git
makedepends = doxygen
makedepends = git
makedepends = graphviz
- makedepends = pkg-config
makedepends = python-pystache
+ makedepends = xsd
depends = alsa-lib
- depends = bctoolbox-git
- depends = belcard-git
- depends = belle-sip-git
- depends = belr-git
- depends = bzrtp-git
+ depends = bctoolbox>=4.3
+ depends = belcard>=4.3
+ depends = belle-sip>=4.3
+ depends = belr>=4.3
+ depends = bzrtp>=4.3
depends = ffmpeg
- depends = lime-git
- depends = libnotify
+ depends = lime>=4.3
depends = libpulse
- depends = libsoup
depends = libv4l
depends = libxv
- depends = mediastreamer-git
- depends = ortp-git
- depends = soci-git
+ depends = mediastreamer>=4.3
+ depends = ortp>=4.3
+ depends = soci>=4.0
depends = speex
depends = v4l-utils
- depends = xsd
+ depends = xerces-c
optdepends = pulseaudio
- provides = linphone
+ provides = linphone=4.4.0.alpha.r6.g0039298ee
conflicts = linphone
options = !emptydirs
source = git+https://github.com/BelledonneCommunications/linphone.git
diff --git a/PKGBUILD b/PKGBUILD
index bb1f8d79a85f..a27ca729118c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,19 @@
pkgname=linphone-git
_pkgname=linphone
-pkgver=4.3.0.alpha.r14.g2724e7bcf
+pkgver=4.4.0.alpha.r6.g0039298ee
pkgrel=1
pkgdesc="A Voice-over-IP phone library and CLI"
arch=('x86_64')
url="http://www.linphone.org"
license=('GPL')
-depends=('alsa-lib' 'bctoolbox-git' 'belcard-git' 'belle-sip-git' 'belr-git'
- 'bzrtp-git' 'ffmpeg' 'lime-git' 'libnotify' 'libpulse' 'libsoup' 'libv4l'
- 'libxv' 'mediastreamer-git' 'ortp-git' 'soci-git' 'speex' 'v4l-utils' 'xsd')
-makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'pkg-config' 'python-pystache')
+depends=('alsa-lib' 'bctoolbox>=4.3' 'belcard>=4.3' 'belle-sip>=4.3' 'belr>=4.3'
+ 'bzrtp>=4.3' 'ffmpeg' 'lime>=4.3' 'libpulse' 'libv4l'
+ 'libxv' 'mediastreamer>=4.3' 'ortp>=4.3' 'soci>=4.0' 'speex' 'v4l-utils' 'xerces-c')
+makedepends=('cmake' 'doxygen' 'git' 'graphviz' 'python-pystache' 'xsd')
optdepends=('pulseaudio')
options=('!emptydirs')
-provides=('linphone')
+provides=("linphone=$pkgver")
conflicts=('linphone')
install=linphone.install
source=("git+https://github.com/BelledonneCommunications/linphone.git")
@@ -32,11 +32,9 @@ build() {
cd $_pkgname
CXXFLAGS="$CXXFLAGS -Wno-deprecated -Wimplicit-fallthrough=0 -Wno-unused-function"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_STATIC=NO \
-DENABLE_CXX_WRAPPER=YES \
-DENABLE_DOC=NO \
- -DENABLE_ROOTCA_DOWNLOAD=NO \
-DENABLE_LIME=YES \
-DENABLE_UNIT_TESTS=NO \
-DENABLE_STRICT=NO \