summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-02-04 20:55:40 -0500
committerGuillaume Horel2019-02-04 20:55:40 -0500
commit285478d0bc99e5ae4437fe84963703c178987b3c (patch)
tree2e7ddbb577f8e2c9cf419c097f78c36fda24e021
downloadaur-285478d0bc99e5ae4437fe84963703c178987b3c.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b001582bf5e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = linphone-plugin-msamr
+ pkgdesc = Mediastreamer2 plugin for AMR codec
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = http://www.linphone.org/
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = opencore-amr
+ source = https://gitlab.linphone.org/BC/public/msamr/-/archive/1.1.3/msamr-1.1.3.tar.gz
+ sha256sums = 08e67986389a03246d0891715e354778986275c675012947526e8029e7454b32
+
+pkgname = linphone-plugin-msamr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecc11551eb7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=linphone-plugin-msamr
+_pkgname=msamr
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="Mediastreamer2 plugin for AMR codec"
+arch=('x86_64')
+url="http://www.linphone.org/"
+license=('GPL3')
+depends=('opencore-amr')
+makedepends=('cmake')
+source=("https://gitlab.linphone.org/BC/public/msamr/-/archive/$pkgver/msamr-$pkgver.tar.gz")
+sha256sums=('08e67986389a03246d0891715e354778986275c675012947526e8029e7454b32')
+
+build() {
+ cd "${srcdir}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_PREFIX_PATH="/usr" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC="NO" "../$_pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}