summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Nyolt2015-12-22 14:16:35 +0100
committerMartin Nyolt2015-12-22 14:16:35 +0100
commitbc0a132741329bec76ec80e1418dbb32a1796c37 (patch)
tree3c67163c669b3a6720e142e495da2e04791a0e0b
downloadaur-bc0a132741329bec76ec80e1418dbb32a1796c37.tar.gz
Initial package of mssilk 1.0.2.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1387077f9558
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Dec 22 13:09:12 UTC 2015
+pkgbase = linphone-plugin-mssilk
+ pkgdesc = Linphone / mediastreamer plugin that enables Skype's SILK audio codec
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://www.linphone.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = mediastreamer
+ source = http://download-mirror.savannah.gnu.org/releases/linphone/plugins/sources/mssilk-1.0.2.tar.gz
+ md5sums = f1df83849b8e355e4c6a4c29c44250cb
+
+pkgname = linphone-plugin-mssilk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe29ea1d947e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Martin Nyolt <8e3b3cde: google>
+pkgname=linphone-plugin-mssilk
+_pkgname=mssilk
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Linphone / mediastreamer plugin that enables Skype's SILK audio codec"
+url="http://www.linphone.org/"
+arch=('i686' 'x86_64')
+license=('GPL')
+source=(http://download-mirror.savannah.gnu.org/releases/linphone/plugins/sources/$_pkgname-$pkgver.tar.gz)
+depends=('mediastreamer')
+md5sums=('f1df83849b8e355e4c6a4c29c44250cb')
+
+build() {
+
+cd "$srcdir/$_pkgname-$pkgver"
+
+autoreconf --force --install
+./configure --prefix=/usr
+
+make
+}
+
+package() {
+
+cd "$srcdir/$_pkgname-$pkgver"
+
+make PACKAGE_PLUGINS_DIR=\$\(libdir\)/liblinphone/plugins DESTDIR="$pkgdir" install
+}