summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormmustermann2022-10-04 21:28:21 +0200
committermmustermann2022-10-04 21:28:21 +0200
commitbd81025e8702b26494df1a21c3fd7652a55afbfe (patch)
tree7c21f6142c676d897745b888ab23be430ddff570
parenta6048b84a0155c6705128c59276de82152c29dab (diff)
downloadaur-bd81025e8702b26494df1a21c3fd7652a55afbfe.tar.gz
Fix incorrect pkgdesc
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
2 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7c5267ce091..50d86a1af046 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -47,5 +47,21 @@ pkgbase = linux-aarch64-rockpro64
md5sums = 7bf9d397ebd8b10b0e254bb1cda80d88
pkgname = linux-aarch64-rockpro64
+ pkgdesc = The Linux Kernel and modules - AArch64 with patches for PINE64's ROCKPro64
+ install = linux-aarch64-rockpro64.install
+ depends = coreutils
+ depends = linux-firmware
+ depends = kmod
+ depends = mkinitcpio>=0.7
+ optdepends = wireless-regdb: to set the correct wireless channels of your country
+ provides = linux=5.19.13
+ provides = WIREGUARD-MODULE
+ conflicts = linux
+ conflicts = linux-aarch64
+ backup = etc/mkinitcpio.d/linux-aarch64-rockpro64.preset
pkgname = linux-aarch64-rockpro64-headers
+ pkgdesc = Header files and scripts for building modules for linux kernel - AArch64 with patches for PINE64's ROCKPro64
+ provides = linux-headers=5.19.13
+ conflicts = linux-headers
+ conflicts = linux-aarch64-headers
diff --git a/PKGBUILD b/PKGBUILD
index 9f75fa79958d..7608025db019 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,7 @@ buildarch=8
pkgbase=linux-aarch64-rockpro64
_srcname=linux-5.19
_kernelname=${pkgbase#linux}
-_desc="AArch64 with patches for PINE64's ROCKPro64"
-pkgdesc=${_desc}
+pkgdesc="AArch64 with patches for PINE64's ROCKPro64"
pkgver=5.19.13
pkgrel=1
arch=('aarch64')
@@ -94,7 +93,7 @@ build() {
}
_package() {
- pkgdesc="The Linux Kernel and modules - ${_desc}"
+ pkgdesc="The Linux Kernel and modules - $pkgdesc"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('wireless-regdb: to set the correct wireless channels of your country')
provides=("linux=${pkgver}" "WIREGUARD-MODULE")
@@ -134,7 +133,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for linux kernel - ${_desc}"
+ pkgdesc="Header files and scripts for building modules for linux kernel - $pkgdesc"
provides=("linux-headers=${pkgver}")
conflicts=('linux-headers' 'linux-aarch64-headers')
@@ -213,8 +212,9 @@ _package-headers() {
}
pkgname=("${pkgbase}" "${pkgbase}-headers")
-for _p in ${pkgname[@]}; do
- eval "package_${_p}() {
- _package${_p#${pkgbase}}
+for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
}"
done