summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeny Myandin2022-09-01 12:34:01 +0300
committerEvgeny Myandin2022-09-01 12:34:01 +0300
commit639b95bdfc9f608ddaec0c2a86618d1b64847d0b (patch)
tree938988a98ef828b97a80b1bef70e2df7c012cb19
parentccdf1dffc67cc5e1d3d9183005dae9bf3cd4215d (diff)
downloadaur-639b95bdfc9f608ddaec0c2a86618d1b64847d0b.tar.gz
release kernel 5.19.6
-rw-r--r--.SRCINFO10
-rw-r--r--0303-revert-fbcon-remove-soft-scrollback-code.patch46
-rw-r--r--PKGBUILD8
-rw-r--r--config2
4 files changed, 33 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4a8cf9492bd..c96db1e17d1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-acs-manjaro
- pkgver = 5.19.5
+ pkgver = 5.19.6
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = linux-acs-manjaro
makedepends = xz
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.19.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v5.x/patch-5.19.5.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/patch-5.19.6.xz
source = config
source = 0101-ZEN_Add_sysctl_and_CONFIG_to_disallow_unprivileged_CLONE_NEWUSER.patch
source = 0102-drm_i915_psr_Use_full_update_In_case_of_area_calculation_fails.patch
@@ -43,8 +43,8 @@ pkgbase = linux-acs-manjaro
source = 0413-bootsplash.gitpatch
source = 0999-acs.gitpatch
sha256sums = ff240c579b9ee1affc318917de07394fc1c3bb49dac25ec1287370c2e15005a8
- sha256sums = ea4f4be61b0635d8b2cb58c373b670e78250dac9d0f2432222052789974c09d7
- sha256sums = de7de1f5dd66d6539c22421f5addfb61549f7560e65e4a26b1589c9431e7f608
+ sha256sums = 529ef98eb4463c48e276240de679c3dd37093a61cd7b55ae3fe4ba052045f844
+ sha256sums = b85e50683dbee63cf1ac3526985f9ccb11034f5ad0b4bbf1546be157f59a7dd5
sha256sums = 05f04019d4a2ee072238c32860fa80d673687d84d78ef436ae9332b6fb788467
sha256sums = c0a9c427b55bd1c13ccebbb503926c4ce30823fcec6d1a949fec981a4ec3a367
sha256sums = b8701a6316fb286b44adb703528462303f361d9c7af9667fb19553c4ac90816c
@@ -52,7 +52,7 @@ pkgbase = linux-acs-manjaro
sha256sums = e96f2ac9e9f880451875a3aecbc10268ee8268494a8c9dce49291426d7896253
sha256sums = 2b11905b63b05b25807dd64757c779da74dd4c37e36d3f7a46485b1ee5a9d326
sha256sums = 94a8538251ad148f1025cc3de446ce64f73dc32b01815426fb159c722e8fa5bc
- sha256sums = 2e8a9c21fbd0f50cc450df7a2823ad670d0b3c2ffa0f613a729cb2caaf02cb9f
+ sha256sums = 8e5c147591d14300a59ed8354a9d0746cf78650256558b45f964ca76eaed9a9f
sha256sums = 57ce3e0ba6bf400d36358a9d30589905f6e51bc037d7165f5a2658b6bdc86793
sha256sums = a26b3abaec1cd5731bc8431fecb8b3eb0ba47c1992e614643320df14ff859556
sha256sums = 8c1c880f2caa9c7ae43281a35410203887ea8eae750fe8d360d0c8bf80fcc6e0
diff --git a/0303-revert-fbcon-remove-soft-scrollback-code.patch b/0303-revert-fbcon-remove-soft-scrollback-code.patch
index eebf8182f21e..c11a97198ff2 100644
--- a/0303-revert-fbcon-remove-soft-scrollback-code.patch
+++ b/0303-revert-fbcon-remove-soft-scrollback-code.patch
@@ -11,8 +11,8 @@
+static unsigned long softback_top, softback_end;
+static int softback_lines;
/* console mappings */
- static int first_fb_vc;
- static int last_fb_vc = MAX_NR_CONSOLES - 1;
+ static unsigned int first_fb_vc;
+ static unsigned int last_fb_vc = MAX_NR_CONSOLES - 1;
@@ -163,6 +169,8 @@ static int margin_color;
static const struct consw fb_con;
@@ -65,7 +65,7 @@
continue;
}
-@@ -957,6 +983,31 @@ static const char *fbcon_startup(void)
+@@ -959,6 +985,31 @@ static const char *fbcon_startup(void)
set_blitting_type(vc, info);
@@ -97,7 +97,7 @@
/* Setup default font */
if (!p->fontdata && !vc->vc_font.data) {
if (!fontname[0] || !(font = find_font(fontname)))
-@@ -1127,6 +1178,9 @@ static void fbcon_init(struct vc_data *v
+@@ -1129,6 +1180,9 @@ static void fbcon_init(struct vc_data *v
if (logo)
fbcon_prepare_logo(vc, info, cols, rows, new_cols, new_rows);
@@ -107,7 +107,7 @@
if (ops->rotate_font && ops->rotate_font(info, vc)) {
ops->rotate = FB_ROTATE_UR;
set_blitting_type(vc, info);
-@@ -1150,6 +1204,9 @@ static void fbcon_release_all(void)
+@@ -1152,6 +1206,9 @@ static void fbcon_release_all(void)
struct fb_info *info;
int i, j, mapped;
@@ -117,7 +117,7 @@
fbcon_for_each_registered_fb(i) {
mapped = 0;
info = fbcon_registered_fb[i];
-@@ -1310,6 +1367,7 @@ static void fbcon_cursor(struct vc_data
+@@ -1312,6 +1369,7 @@ static void fbcon_cursor(struct vc_data
{
struct fb_info *info = fbcon_info_from_console(vc->vc_num);
struct fbcon_ops *ops = info->fbcon_par;
@@ -125,7 +125,7 @@
int c = scr_readw((u16 *) vc->vc_pos);
ops->cur_blink_jiffies = msecs_to_jiffies(vc->vc_cur_blink_ms);
-@@ -1323,11 +1381,19 @@ static void fbcon_cursor(struct vc_data
+@@ -1325,11 +1383,19 @@ static void fbcon_cursor(struct vc_data
fbcon_add_cursor_work(info);
ops->cursor_flash = (mode == CM_ERASE) ? 0 : 1;
@@ -146,7 +146,7 @@
get_color(vc, info, c, 0));
}
-@@ -1397,6 +1463,8 @@ static void fbcon_set_disp(struct fb_inf
+@@ -1399,6 +1465,8 @@ static void fbcon_set_disp(struct fb_inf
if (con_is_visible(vc)) {
update_screen(vc);
@@ -155,7 +155,7 @@
}
}
-@@ -1534,6 +1602,99 @@ static __inline__ void ypan_down_redraw(
+@@ -1536,6 +1604,99 @@ static __inline__ void ypan_down_redraw(
scrollback_current = 0;
}
@@ -255,7 +255,7 @@
static void fbcon_redraw_move(struct vc_data *vc, struct fbcon_display *p,
int line, int count, int dy)
{
-@@ -1738,6 +1899,31 @@ static void fbcon_bmove(struct vc_data *
+@@ -1740,6 +1901,31 @@ static void fbcon_bmove(struct vc_data *
p->vrows - p->yscroll);
}
@@ -287,7 +287,7 @@
static bool fbcon_scroll(struct vc_data *vc, unsigned int t, unsigned int b,
enum con_scroll dir, unsigned int count)
{
-@@ -1760,6 +1946,8 @@ static bool fbcon_scroll(struct vc_data
+@@ -1762,6 +1948,8 @@ static bool fbcon_scroll(struct vc_data
case SM_UP:
if (count > vc->vc_rows) /* Maximum realistic size */
count = vc->vc_rows;
@@ -296,7 +296,7 @@
switch (fb_scrollmode(p)) {
case SCROLL_MOVE:
fbcon_redraw_blit(vc, info, p, t, b - t - count,
-@@ -2078,6 +2266,14 @@ static int fbcon_switch(struct vc_data *
+@@ -2076,6 +2264,14 @@ static int fbcon_switch(struct vc_data *
info = fbcon_info_from_console(vc->vc_num);
ops = info->fbcon_par;
@@ -311,8 +311,8 @@
if (logo_shown >= 0) {
struct vc_data *conp2 = vc_cons[logo_shown].d;
-@@ -2409,6 +2605,9 @@ static int fbcon_do_set_font(struct vc_d
- int resize;
+@@ -2406,6 +2602,9 @@ static int fbcon_do_set_font(struct vc_d
+ int resize, ret, old_userfont, old_width, old_height, old_charcount;
char *old_data = NULL;
+ if (con_is_visible(vc) && softback_lines)
@@ -321,16 +321,16 @@
resize = (w != vc->vc_font.width) || (h != vc->vc_font.height);
if (p->userfont)
old_data = vc->vc_font.data;
-@@ -2431,6 +2630,8 @@ static int fbcon_do_set_font(struct vc_d
- cols /= w;
- rows /= h;
- vc_resize(vc, cols, rows);
+@@ -2436,6 +2635,8 @@ static int fbcon_do_set_font(struct vc_d
+ ret = vc_resize(vc, cols, rows);
+ if (ret)
+ goto err_out;
+ if (con_is_visible(vc) && softback_buf)
+ fbcon_update_softback(vc);
} else if (con_is_visible(vc)
&& vc->vc_mode == KD_TEXT) {
fbcon_clear_margins(vc, 0);
-@@ -2585,7 +2786,19 @@ static void fbcon_set_palette(struct vc_
+@@ -2605,7 +2806,19 @@ static void fbcon_set_palette(struct vc_
static u16 *fbcon_screen_pos(const struct vc_data *vc, int offset)
{
@@ -351,7 +351,7 @@
}
static unsigned long fbcon_getxy(struct vc_data *vc, unsigned long pos,
-@@ -2599,7 +2812,22 @@ static unsigned long fbcon_getxy(struct
+@@ -2619,7 +2832,22 @@ static unsigned long fbcon_getxy(struct
x = offset % vc->vc_cols;
y = offset / vc->vc_cols;
@@ -374,7 +374,7 @@
} else {
/* Should not happen */
x = y = 0;
-@@ -2627,11 +2855,106 @@ static void fbcon_invert_region(struct v
+@@ -2647,11 +2875,106 @@ static void fbcon_invert_region(struct v
a = ((a) & 0x88ff) | (((a) & 0x7000) >> 4) |
(((a) & 0x0700) << 4);
scr_writew(a, p++);
@@ -481,7 +481,7 @@
return 0;
}
-@@ -2695,6 +3018,8 @@ static void fbcon_modechanged(struct fb_
+@@ -2715,6 +3038,8 @@ static void fbcon_modechanged(struct fb_
fbcon_set_palette(vc, color_table);
update_screen(vc);
@@ -490,7 +490,7 @@
}
}
-@@ -3157,6 +3482,7 @@ static const struct consw fb_con = {
+@@ -3177,6 +3502,7 @@ static const struct consw fb_con = {
.con_font_get = fbcon_get_font,
.con_font_default = fbcon_set_def_font,
.con_set_palette = fbcon_set_palette,
diff --git a/PKGBUILD b/PKGBUILD
index e1f8b402ac97..984b43a2e93a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgbase=linux-acs-manjaro
pkgname=('linux-acs-manjaro' 'linux-acs-manjaro-headers')
_kernelname=-ACS-MANJARO
_basekernel=5.19
-pkgver=5.19.5
+pkgver=5.19.6
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -50,8 +50,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.x
# ACS override patch
'0999-acs.gitpatch')
sha256sums=('ff240c579b9ee1affc318917de07394fc1c3bb49dac25ec1287370c2e15005a8'
- 'ea4f4be61b0635d8b2cb58c373b670e78250dac9d0f2432222052789974c09d7'
- 'de7de1f5dd66d6539c22421f5addfb61549f7560e65e4a26b1589c9431e7f608'
+ '529ef98eb4463c48e276240de679c3dd37093a61cd7b55ae3fe4ba052045f844'
+ 'b85e50683dbee63cf1ac3526985f9ccb11034f5ad0b4bbf1546be157f59a7dd5'
'05f04019d4a2ee072238c32860fa80d673687d84d78ef436ae9332b6fb788467'
'c0a9c427b55bd1c13ccebbb503926c4ce30823fcec6d1a949fec981a4ec3a367'
'b8701a6316fb286b44adb703528462303f361d9c7af9667fb19553c4ac90816c'
@@ -59,7 +59,7 @@ sha256sums=('ff240c579b9ee1affc318917de07394fc1c3bb49dac25ec1287370c2e15005a8'
'e96f2ac9e9f880451875a3aecbc10268ee8268494a8c9dce49291426d7896253'
'2b11905b63b05b25807dd64757c779da74dd4c37e36d3f7a46485b1ee5a9d326'
'94a8538251ad148f1025cc3de446ce64f73dc32b01815426fb159c722e8fa5bc'
- '2e8a9c21fbd0f50cc450df7a2823ad670d0b3c2ffa0f613a729cb2caaf02cb9f'
+ '8e5c147591d14300a59ed8354a9d0746cf78650256558b45f964ca76eaed9a9f'
'57ce3e0ba6bf400d36358a9d30589905f6e51bc037d7165f5a2658b6bdc86793'
'a26b3abaec1cd5731bc8431fecb8b3eb0ba47c1992e614643320df14ff859556'
'8c1c880f2caa9c7ae43281a35410203887ea8eae750fe8d360d0c8bf80fcc6e0'
diff --git a/config b/config
index 5e536e5c3c95..1c58da61a632 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.19.5-1 Kernel Configuration
+# Linux/x86 5.19.6-1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.0"
CONFIG_CC_IS_GCC=y