summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Rogers2023-05-02 21:46:55 -0600
committerPatrick Rogers2023-05-02 21:46:55 -0600
commitff51f38ff5187c2ee5d71f5432843cae66109a15 (patch)
tree287c7862283904f8943e7190d72a309b0b89eb16
parent8d71ec3757637dd93cd912be25801843f375cf73 (diff)
downloadaur-ff51f38ff5187c2ee5d71f5432843cae66109a15.tar.gz
Update LAC to 09p14, fix .desktop file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c581de90dacb..70c334b3e750 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-air-combat
pkgdesc = Free open source combat flight simulator
- pkgver = 08p83
+ pkgver = 09p14
pkgrel = 1
url = https://askmisterwizard.com/2019/LinuxAirCombat/IntroducingLinuxAirCombat.htm
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = linux-air-combat
depends = mesa
optdepends = espeak: adds voice effects in-game
optdepends = mumble: team voice integration
- source = https://sourceforge.net/projects/linuxaircombat/files/Choose%20Your%20Platform/Most%20LINUX%20Desktops%20%28in%20the%20global%20usr%20filesystem%20for%20all%20users%29/Lac08p83.tar.gz
+ source = https://sourceforge.net/projects/linuxaircombat/files/Choose%20Your%20Platform/Most%20LINUX%20Desktops%20%28in%20the%20global%20usr%20filesystem%20for%20all%20users%29/Lac09p14.tar.gz
md5sums = SKIP
pkgname = linux-air-combat
diff --git a/PKGBUILD b/PKGBUILD
index cb0a311f091a..651af56646f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Patrick Rogers <patrick@thewebzone.net>
pkgname='linux-air-combat'
-pkgver=08p83
+pkgver=09p14
pkgrel=1
pkgdesc="Free open source combat flight simulator"
arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
@@ -53,6 +53,22 @@ package() {
cp bin/textures/* $pkgdir/${_resource_dir}/textures
chmod +r $pkgdir/${_resource_dir}/textures/*
- cp lac.desktop $pkgdir/usr/share/applications/
+ # Supplied .desktop file is broken
+ # cp lac.desktop $pkgdir/usr/share/applications/
+ # chmod +r $pkgdir/usr/share/applications/lac.desktop
+
+ # Write working .desktop file
+ echo "[Desktop Entry]
+Type=Application
+Name=Linux Air Combat
+GenericName=Flight Simulator
+Comment=Open source combat flight simulator
+Terminal=false
+Icon=/usr/share/lac/lac.png
+Exec=sh -c lac
+Keywords=lac;game;air;flight;combat;linux;plane;
+Categories=Game
+StartupNotify=true" > $pkgdir/usr/share/applications/lac.desktop
chmod +r $pkgdir/usr/share/applications/lac.desktop
+
}