summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGytis Raciukaitis2021-02-04 11:05:55 +0200
committerGytis Raciukaitis2021-02-04 11:05:55 +0200
commit9e9bbcf5bccf8f62317071c653be33f10e753273 (patch)
treefa3fe86a94bc067365e315dde1adc14159b9f0de
parent67922cb3230dd9debeaf6914327e6987453832c4 (diff)
downloadaur-9e9bbcf5bccf8f62317071c653be33f10e753273.tar.gz
fix: make sure that kernel images are found by sdboot correctly
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3739640b9ad6..a4367150bfbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@ pkgver=5.12.968912.044a48f420b9
_product="${pkgbase%-git}"
_kernel_rel=5.12
_branch=drm-next-${_kernel_rel}
+_base="${pkgbase//-/_}"
pkgrel=1
arch=(x86_64)
url='https://gitlab.freedesktop.org/drm/amd'
@@ -41,7 +42,7 @@ prepare() {
echo "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
- echo "${pkgbase#linux}" > localversion.20-pkgname
+ echo "${_base#linux}" > localversion.20-pkgname
local src
for src in "${source[@]}"; do
@@ -84,7 +85,7 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
- echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+ echo "$_base-{arch[1]}" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install