summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2018-07-21 01:21:50 +0300
committerYurii Kolesnykov2018-07-21 01:21:50 +0300
commit2ae6e807c5134ff325148144483821d444f31731 (patch)
treee9b222e35368fa2f26909cb2772f76ad1f68d48a
parent780f72a213d905a8c1c34ced6ede082bdd251e13 (diff)
downloadaur-2ae6e807c5134ff325148144483821d444f31731.tar.gz
port changes from linux-git
-rw-r--r--.SRCINFO10
-rw-r--r--90-linux.hook11
-rw-r--r--PKGBUILD32
3 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e32e20bfbf2..45fdb6a6fb5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,15 +15,15 @@ pkgbase = linux-amd-staging-drm-next-git
options = !strip
source = linux-amd-staging-drm-next-git::git://people.freedesktop.org/~agd5f/linux#branch=amd-staging-drm-next
source = config.x86_64
- source = 90-linux.hook
+ source = linux.install
source = linux-amd-staging-drm-next-git.preset
sha256sums = SKIP
sha256sums = 103da034999058c505479d129ad2446821c748a5cef7f065d5770c89a81f0e98
- sha256sums = 834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0
+ sha256sums = d590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
pkgname = linux-amd-staging-drm-next-git
- pkgdesc = The Linux kernel and modules (git version) with patches from AMD
+ pkgdesc = The Linux kernel and modules with AMDGPU DC patches
install = linux.install
depends = coreutils
depends = linux-firmware
@@ -34,10 +34,10 @@ pkgname = linux-amd-staging-drm-next-git
backup = etc/mkinitcpio.d/linux-amd-staging-drm-next-git.preset
pkgname = linux-amd-staging-drm-next-git-headers
- pkgdesc = Header files and scripts for building modules for Linux kernel (git version) with patches from AMD
+ pkgdesc = Header files and scripts for building modules for Linux kernel with AMDGPU DC patches
provides = linux-headers
pkgname = linux-amd-staging-drm-next-git-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux kernel (git version) with patches from AMD
+ pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux kernel with AMDGPU DC patches
provides = linux-docs
diff --git a/90-linux.hook b/90-linux.hook
deleted file mode 100644
index 9851151995bc..000000000000
--- a/90-linux.hook
+++ /dev/null
@@ -1,11 +0,0 @@
-[Trigger]
-Type = File
-Operation = Install
-Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
-Target = usr/lib/initcpio/*
-
-[Action]
-Description = Updating %PKGBASE% initcpios
-When = PostTransaction
-Exec = /usr/bin/mkinitcpio -p %PKGBASE%
diff --git a/PKGBUILD b/PKGBUILD
index 7c9c614dff86..acf6fbd5a8df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,16 @@
# Maintainer: Yurii Kolesnykov <yurikoles@gmail.com>
-# Contributor: Brad McCormack <bradmccormack100@gmail.com>
+# Contributor: Boohbah <boohbah at gmail.com>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
+# Contributor: Jonathan Chan <jyc@fastmail.fm>
+# Contributor: misc <tastky@gmail.com>
+# Contributor: NextHendrix <cjones12 at sheffield.ac.uk>
+# Contributor: Shun Terabayashi <shunonymous at gmail.com>
+# Contributor: Brad McCormack <bradmccormack100 at gmail.com>
pkgbase=linux-amd-staging-drm-next-git
pkgdesc='Linux kernel with AMDGPU DC patches'
-_srcname=${pkgbase}
+_srcname=$pkgbase
_kernel_rel=4.19
_branch=amd-staging-drm-next
_kernelname=${pkgbase#linux}
@@ -17,20 +22,19 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'libelf')
options=('!strip')
source=("${pkgbase}::git://people.freedesktop.org/~agd5f/linux#branch=${_branch}"
- # The main kernel config files
+ # the main kernel config files
'config.x86_64'
- # Pacman hook for initramfs regeneration
- '90-linux.hook'
- # Standard config files for mkinitcpio ramdisk
+ # standard config files for mkinitcpio ramdisk
+ 'linux.install'
"${pkgbase}.preset")
+
sha256sums=('SKIP'
'103da034999058c505479d129ad2446821c748a5cef7f065d5770c89a81f0e98'
- '834bd254b56ab71d73f59b3221f056c72f559553c04718e350ab2a3e2991afe0'
+ 'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
pkgver() {
- cd "${_srcname}" || exit
+ cd "${_srcname}"
- # git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/\.rc/rc/'
echo ${_kernel_rel}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
@@ -47,8 +51,6 @@ prepare() {
sed -i '2iexit 0' scripts/depmod.sh
# get kernel version
- sed -i 's|snprintf(buf, buflen, "INTERNAL ERROR: strerror_r(%d, %p, %zd)=%d", errnum, buf, buflen, err)|snprintf(buf, buflen, "INTERNAL ERROR: strerror_r(%d, [buf], %zd)=%d", errnum, buflen, err)|g' tools/lib/str_error_r.c
-
make prepare
# load configuration
@@ -68,7 +70,7 @@ build() {
}
_package() {
- pkgdesc="The Linux kernel and modules (git version) with patches from AMD"
+ pkgdesc="The Linux kernel and modules with AMDGPU DC patches"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
provides=('linux')
@@ -123,14 +125,14 @@ _package() {
mv "${pkgdir}/lib" "${pkgdir}/usr/"
# add vmlinux
- install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
+ install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
# add System.map
install -D -m644 System.map "${pkgdir}/boot/System.map-${_kernver}"
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for Linux kernel (git version) with patches from AMD"
+ pkgdesc="Header files and scripts for building modules for Linux kernel with AMDGPU DC patches"
provides=('linux-headers')
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
@@ -242,7 +244,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel (git version) with patches from AMD"
+ pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel with AMDGPU DC patches"
provides=('linux-docs')
cd "${_srcname}"