summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2023-01-14 09:35:35 +0300
committerYurii Kolesnykov2023-01-18 16:13:59 +0300
commit63b4849f74eb07c0e7ae46e11d03960ed2f48c1d (patch)
tree71cdff27f5967f2d40bbd2e133ceecea434ae932
parent602f10db96e4482e9065a1d7f70d333a473a0106 (diff)
downloadaur-63b4849f74eb07c0e7ae46e11d03960ed2f48c1d.tar.gz
sync with testing/linux
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
-rw-r--r--config3
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40c18b03cc22..4f839431514c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-staging-drm-next-git
- pkgdesc = Linux kernel with AMDGPU WIP patches
- pkgver = 6.0.r1125805.de9a71e391a9
+ pkgdesc = Linux kernel with WIP AMDGPU material
+ pkgver = 6.0.r1125978.901bf75db129
pkgrel = 1
url = https://gitlab.freedesktop.org/agd5f/linux
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = linux-amd-staging-drm-next-git
makedepends = perl
makedepends = tar
makedepends = xz
+ makedepends = gettext
makedepends = xmlto
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
@@ -23,10 +24,10 @@ pkgbase = linux-amd-staging-drm-next-git
source = linux-amd-staging-drm-next-git::git+https://gitlab.freedesktop.org/agd5f/linux.git#branch=amd-staging-drm-next
source = config
sha256sums = SKIP
- sha256sums = 0571ea17a2e38458096b679418197bbea8c414388f628d122517f3a1f3a31b3a
+ sha256sums = 1efa33aea067fa920880ef7fef3ec82f8d4cde21213eda34ac6534ca6879fca0
pkgname = linux-amd-staging-drm-next-git
- pkgdesc = The Linux kernel with AMDGPU WIP patches kernel and modules
+ pkgdesc = The Linux kernel with WIP AMDGPU material kernel and modules
depends = coreutils
depends = kmod
depends = initramfs
@@ -39,8 +40,8 @@ pkgname = linux-amd-staging-drm-next-git
replaces = wireguard-arch
pkgname = linux-amd-staging-drm-next-headers-git
- pkgdesc = Headers and scripts for building modules for the Linux kernel with AMDGPU WIP patches kernel
+ pkgdesc = Headers and scripts for building modules for the Linux kernel with WIP AMDGPU material kernel
depends = pahole
pkgname = linux-amd-staging-drm-next-docs-git
- pkgdesc = Documentation for the Linux kernel with AMDGPU WIP patches kernel
+ pkgdesc = Documentation for the Linux kernel with WIP AMDGPU material kernel
diff --git a/PKGBUILD b/PKGBUILD
index ea7756ed4cdb..a659fc1e4778 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Yurii Kolesykov <root@yurikoles.com>
-# based on testing/linux: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Based on testing/linux by Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-amd-staging-drm-next-git
-pkgver=6.0.r1125805.de9a71e391a9
+pkgver=6.0.r1125978.901bf75db129
pkgrel=1
-pkgdesc='Linux kernel with AMDGPU WIP patches'
+pkgdesc='Linux kernel with WIP AMDGPU material'
_product="${pkgbase%-git}"
_branch="${_product#linux-}"
url=https://gitlab.freedesktop.org/agd5f/linux
arch=(x86_64)
license=(GPL2)
makedepends=(
- bc libelf pahole cpio perl tar xz
+ bc libelf pahole cpio perl tar xz gettext
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
git
)
@@ -22,7 +22,7 @@ source=(
config # the main kernel config file
)
sha256sums=('SKIP'
- '0571ea17a2e38458096b679418197bbea8c414388f628d122517f3a1f3a31b3a')
+ '1efa33aea067fa920880ef7fef3ec82f8d4cde21213eda34ac6534ca6879fca0')
pkgver() {
cd $_srcname
diff --git a/config b/config
index ca0e505ed261..ceb2e1c494f6 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.1.0-arch1 Kernel Configuration
+# Linux/x86 6.1.6-arch1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.0"
CONFIG_CC_IS_GCC=y
@@ -206,6 +206,7 @@ CONFIG_ARCH_SUPPORTS_NUMA_BALANCING=y
CONFIG_ARCH_WANT_BATCHED_UNMAP_TLB_FLUSH=y
CONFIG_CC_HAS_INT128=y
CONFIG_CC_IMPLICIT_FALLTHROUGH="-Wimplicit-fallthrough=5"
+CONFIG_GCC11_NO_ARRAY_BOUNDS=y
CONFIG_GCC12_NO_ARRAY_BOUNDS=y
CONFIG_CC_NO_ARRAY_BOUNDS=y
CONFIG_ARCH_SUPPORTS_INT128=y