summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2017-11-17 20:04:25 +0200
committerYurii Kolesnykov2017-11-17 20:04:25 +0200
commita0fcbd2a17d600624c05781209038e8f0ab92533 (patch)
tree8f2c0fbcb27b20b832ad39ef44c18534b12615a1
parent067054d64297ed576e85585eaedbfed68aa2f000 (diff)
downloadaur-a0fcbd2a17d600624c05781209038e8f0ab92533.tar.gz
fix install script
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--linux.install8
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7540b3703560..a459acc0c237 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-amd-staging-drm-next-git
pkgdesc = Linux kernel with AMDGPU DC patches
pkgver = 4.13.708545.49e37ba07a3a
- pkgrel = 1
+ pkgrel = 2
url = https://cgit.freedesktop.org/~airlied/linux/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 05bef23bc303..5e875043e86a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _kernel_rel=4.13
_branch=drm-next-amd-dc-staging
_kernelname=${pkgbase#linux}
pkgver=4.13.708545.49e37ba07a3a
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://cgit.freedesktop.org/~airlied/linux/'
license=('GPL2')
diff --git a/linux.install b/linux.install
index ef42413835ac..9d80af98d590 100644
--- a/linux.install
+++ b/linux.install
@@ -9,7 +9,7 @@ post_install () {
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
+ mkinitcpio -p ${KERNEL_NAME}
}
post_upgrade() {
@@ -21,7 +21,7 @@ post_upgrade() {
echo ">>> Updating module dependencies. Please wait ..."
depmod ${KERNEL_VERSION}
echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
+ mkinitcpio -p ${KERNEL_NAME}
if [ $(vercmp $2 3.13) -lt 0 ]; then
echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
@@ -32,6 +32,6 @@ post_upgrade() {
post_remove() {
# also remove the compat symlinks
- rm -f boot/initramfs-linux${KERNEL_NAME}.img
- rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
+ rm -f boot/initramfs-${KERNEL_NAME}.img
+ rm -f boot/initramfs-${KERNEL_NAME}-fallback.img
}