summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEggz2024-02-01 09:01:03 +0100
committerEggz2024-02-01 09:01:03 +0100
commit784f8f7987ee68ff36f0bc3701b9e4d24213e8ba (patch)
tree4ff4b44981aa68e7848cab30b03896e9e09166a3
parent4fa9fb749facab9e1189ab5aa643ccd5baf2cb37 (diff)
downloadaur-784f8f7987ee68ff36f0bc3701b9e4d24213e8ba.tar.gz
Updated
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--config.x86_642
-rw-r--r--flushbyasid.patch45
4 files changed, 7 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a48e44e9e7b..adaa84069a0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-amd-znver3
- pkgver = 6.7.v.2
+ pkgver = 6.7.v.3
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -14,12 +14,12 @@ pkgbase = linux-amd-znver3
makedepends = lzop
makedepends = gcc>=9.1
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v6.7.2
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v6.7.3
source = config.x86_64
source = linux-amd-znver3.preset
source = https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/20230105/more-uarches-for-kernel-5.17+.patch
sha256sums = SKIP
- sha256sums = f6cc96c118bf443e31ad2d47ef904fb5a15a21e65ebf4de4003dc76c44c52d7b
+ sha256sums = fc5a818b5b6bf18d29f717b56f95b258dce9a12f8774cac801d324677b30cd19
sha256sums = 26828ab61a69fca7ecdbba4179311f7cc3c59e1f8c070bcc626c68065187222b
sha256sums = 81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe
diff --git a/PKGBUILD b/PKGBUILD
index abb359911be5..aa0b0a117ffa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgbase=linux-amd-znver3
_srcname=linux
-gitver=v6.7.2
+gitver=v6.7.3
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
-pkgver=6.7.v.2
+pkgver=6.7.v.3
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -23,7 +23,7 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
)
sha256sums=('SKIP'
#config.x86_64
- 'f6cc96c118bf443e31ad2d47ef904fb5a15a21e65ebf4de4003dc76c44c52d7b'
+ 'fc5a818b5b6bf18d29f717b56f95b258dce9a12f8774cac801d324677b30cd19'
#.preset file
'26828ab61a69fca7ecdbba4179311f7cc3c59e1f8c070bcc626c68065187222b'
#grayskypatch
diff --git a/config.x86_64 b/config.x86_64
index 294da2439bbb..b6dfcdfc09ff 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.7.2 Kernel Configuration
+# Linux/x86 6.7.3 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 13.2.1 20230801"
CONFIG_CC_IS_GCC=y
diff --git a/flushbyasid.patch b/flushbyasid.patch
deleted file mode 100644
index 9926cc5e4218..000000000000
--- a/flushbyasid.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/arch/x86/kvm/svm/nested.c b/arch/x86/kvm/svm/nested.c
-index 3fea8c47679e..60891b9ce25f 100644
---- a/arch/x86/kvm/svm/nested.c
-+++ b/arch/x86/kvm/svm/nested.c
-@@ -247,18 +247,6 @@ static bool nested_svm_check_bitmap_pa(struct kvm_vcpu *vcpu, u64 pa, u32 size)
- kvm_vcpu_is_legal_gpa(vcpu, addr + size - 1);
- }
-
--static bool nested_svm_check_tlb_ctl(struct kvm_vcpu *vcpu, u8 tlb_ctl)
--{
-- /* Nested FLUSHBYASID is not supported yet. */
-- switch(tlb_ctl) {
-- case TLB_CONTROL_DO_NOTHING:
-- case TLB_CONTROL_FLUSH_ALL_ASID:
-- return true;
-- default:
-- return false;
-- }
--}
--
- static bool __nested_vmcb_check_controls(struct kvm_vcpu *vcpu,
- struct vmcb_ctrl_area_cached *control)
- {
-@@ -278,9 +266,6 @@ static bool __nested_vmcb_check_controls(struct kvm_vcpu *vcpu,
- IOPM_SIZE)))
- return false;
-
-- if (CC(!nested_svm_check_tlb_ctl(vcpu, control->tlb_ctl)))
-- return false;
--
- if (CC((control->int_ctl & V_NMI_ENABLE_MASK) &&
- !vmcb12_is_intercept(control, INTERCEPT_NMI))) {
- return false;
-diff --git a/arch/x86/kvm/svm/svm.c b/arch/x86/kvm/svm/svm.c
-index 1785de7dc98b..9cf7eef161ff 100644
---- a/arch/x86/kvm/svm/svm.c
-+++ b/arch/x86/kvm/svm/svm.c
-@@ -5083,6 +5083,7 @@ static __init void svm_set_cpu_caps(void)
- if (nested) {
- kvm_cpu_cap_set(X86_FEATURE_SVM);
- kvm_cpu_cap_set(X86_FEATURE_VMCBCLEAN);
-+ kvm_cpu_cap_set(X86_FEATURE_FLUSHBYASID);
-
- if (nrips)
- kvm_cpu_cap_set(X86_FEATURE_NRIPS);