summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2019-11-30 09:50:49 +0800
committerChih-Hsuan Yen2019-11-30 09:50:49 +0800
commitd9bdd9590f430f889460fb453c7a153f7ad0e0db (patch)
tree1db700847a47cb2fefc8082a18be68d7e871f672
downloadaur-linux-apfs-git.tar.gz
new package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..925e0a517da9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = linux-apfs-git
+ pkgdesc = Experimental APFS kernel module (DKMS)
+ pkgver = r6.2a598f1
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/eafer/linux-apfs-oot
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = linux-headers
+ makedepends = xz
+ depends = linux
+ source = git+https://github.com/eafer/linux-apfs-oot
+ sha256sums = SKIP
+
+pkgname = linux-apfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18bc3513d6bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: ManU
+# Forked from aur/linux-can-dkms
+# Contributor: Kyle Manna <kyle(at)kylemanna(dot)com>
+
+pkgname=linux-apfs-git
+epoch=1
+pkgver=r6.2a598f1
+pkgrel=1
+pkgdesc="Experimental APFS kernel module (DKMS)"
+arch=('any')
+url="https://github.com/eafer/linux-apfs-oot"
+license=('GPL2')
+depends=('linux')
+makedepends=('git' 'linux-headers' 'xz')
+source=("git+https://github.com/eafer/linux-apfs-oot")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd linux-apfs-oot
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ _kernver=$(</usr/src/linux/version)
+
+ cd linux-apfs-oot
+ make KERNELRELEASE=$_kernver
+
+ xz apfs.ko
+}
+
+package() {
+ _kernver=$(</usr/src/linux/version)
+
+ cd linux-apfs-oot
+ install -Dm644 apfs.ko.xz -t "$pkgdir"/usr/lib/modules/$_kernver/extramodules
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+}