summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralzeih2019-06-24 21:14:45 +1200
committeralzeih2019-06-24 21:14:45 +1200
commit2e4d1c4676d8d91af716a11a20b0e0911e672af0 (patch)
tree6007e315393061641d6e1c27980e47b40e6dd3c9
parent6e9dbc3cb8196932ddd9536c9879590443af5dca (diff)
downloadaur-2e4d1c4676d8d91af716a11a20b0e0911e672af0.tar.gz
updpkg: linux-apparmor 5.0.8.arch1-1
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--config16
3 files changed, 22 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e55a5fd55e6..8a7ce0d9ae0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-apparmor
- pkgver = 5.0.7.arch1
+ pkgver = 5.0.8.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v5.0.7-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v5.0.8-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -10,10 +10,8 @@ pkgbase = linux-apparmor
makedepends = bc
makedepends = libelf
makedepends = git
- makedepends = python-sphinx
- makedepends = graphviz
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.0.7-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.0.8-arch1
source = config
source = config.fragment
source = 60-linux.hook
@@ -23,7 +21,7 @@ pkgbase = linux-apparmor
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = df2ce998b050c707950c555f7f6ec0efcb8498fca10b4bce45f681844c8aa0ab
+ sha256sums = fdb355884faa86a2f9725d09657c9c32573b0f1e8bb31416823d1198bcb2f80d
sha256sums = 728ea88383ce6c542e2969246036f454395d5412779ffb5299639610b82b21f1
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
diff --git a/PKGBUILD b/PKGBUILD
index 4a9edec50039..b06c52622a12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# Contributor: Thomas Baechler <thomas@archlinux.org>
# Maintainer: alzeih <alzeih@users.noreply.github.com>
pkgbase=linux-apparmor
#pkgbase=linux-custom # Build kernel with a different name
-_srcver=5.0.7-arch1
+_srcver=5.0.8-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
url="https://git.archlinux.org/linux.git/log/?h=v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
+makedepends=(xmlto kmod inetutils bc libelf git)
options=('!strip')
_srcname=archlinux-linux
source=(
@@ -28,7 +28,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'df2ce998b050c707950c555f7f6ec0efcb8498fca10b4bce45f681844c8aa0ab'
+ 'fdb355884faa86a2f9725d09657c9c32573b0f1e8bb31416823d1198bcb2f80d'
'728ea88383ce6c542e2969246036f454395d5412779ffb5299639610b82b21f1'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
@@ -65,7 +65,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -216,18 +216,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
diff --git a/config b/config
index a0224e5c84f9..d673f81117d6 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.0.0-arch1 Kernel Configuration
+# Linux/x86 5.0.7-arch1 Kernel Configuration
#
#
@@ -9271,8 +9271,16 @@ CONFIG_SECURITY_SELINUX_BOOTPARAM_VALUE=0
CONFIG_SECURITY_SELINUX_DEVELOP=y
CONFIG_SECURITY_SELINUX_AVC_STATS=y
CONFIG_SECURITY_SELINUX_CHECKREQPROT_VALUE=0
-# CONFIG_SECURITY_SMACK is not set
-# CONFIG_SECURITY_TOMOYO is not set
+CONFIG_SECURITY_SMACK=y
+CONFIG_SECURITY_SMACK_BRINGUP=y
+CONFIG_SECURITY_SMACK_NETFILTER=y
+CONFIG_SECURITY_SMACK_APPEND_SIGNALS=y
+CONFIG_SECURITY_TOMOYO=y
+CONFIG_SECURITY_TOMOYO_MAX_ACCEPT_ENTRY=2048
+CONFIG_SECURITY_TOMOYO_MAX_AUDIT_LOG=1024
+# CONFIG_SECURITY_TOMOYO_OMIT_USERSPACE_LOADER is not set
+CONFIG_SECURITY_TOMOYO_POLICY_LOADER="/sbin/tomoyo-init"
+CONFIG_SECURITY_TOMOYO_ACTIVATION_TRIGGER="/sbin/init"
CONFIG_SECURITY_APPARMOR=y
CONFIG_SECURITY_APPARMOR_BOOTPARAM_VALUE=0
CONFIG_SECURITY_APPARMOR_HASH=y
@@ -9286,6 +9294,8 @@ CONFIG_INTEGRITY_AUDIT=y
# CONFIG_IMA is not set
# CONFIG_EVM is not set
# CONFIG_DEFAULT_SECURITY_SELINUX is not set
+# CONFIG_DEFAULT_SECURITY_SMACK is not set
+# CONFIG_DEFAULT_SECURITY_TOMOYO is not set
# CONFIG_DEFAULT_SECURITY_APPARMOR is not set
CONFIG_DEFAULT_SECURITY_DAC=y
CONFIG_DEFAULT_SECURITY=""