summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2019-08-19 23:22:38 +1000
committerKyle De'Vir2019-08-19 23:22:38 +1000
commit2014aa0557c3732bb37058942005bb433c52554c (patch)
treec4ddf4e0214d6b38b81b2eab75d2db06633f899b
parentb2b7a4f18e8dc50eca52f5f6c8870c0065a75a92 (diff)
downloadaur-2014aa0557c3732bb37058942005bb433c52554c.tar.gz
Tidy up
-rwxr-xr-xPKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b431e484fe5d..b2a503d34d55 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -118,7 +118,7 @@ prepare() {
echo "-${pkgrel}" > localversion.10-pkgrel
echo "${_kernelname}" > localversion.20-pkgname
- msg2 "bcachefs 5.1.16 fix"
+ msg2 "Patching to make bcachefs work for 5.1.16 onwards..."
git am --3way "${srcdir}"/5.1.16-fix.patch
msg2 "Adding patches from Linux upstream kernel repository..."
@@ -129,8 +129,16 @@ prepare() {
git remote add arch_stable "https://git.archlinux.org/linux.git" || true
# git pull --no-edit arch_stable "v${_srcver_tag}"
git fetch arch_stable "v5.1.16-arch1"
+
+ # https://git.archlinux.org/linux.git/commit/?h=v5.1.16-arch1&id=fd0f4757ded3627edc883650941a26a21e435a7d
+ # add sysctl to disallow unprivileged CLONE_NEWUSER by default
git cherry-pick fd0f4757ded3627edc883650941a26a21e435a7d
+
+ # https://git.archlinux.org/linux.git/commit/?h=v5.1.16-arch1&id=7e6c7c0d56e1342b9ad5d8071736a5851d1ae1c7
+ # ZEN: Add CONFIG for unprivileged_userns_clone
git cherry-pick 7e6c7c0d56e1342b9ad5d8071736a5851d1ae1c7
+
+ msg2 "Fixing EXTRAVERSION..."
sed -i 's/EXTRAVERSION =/EXTRAVERSION = -arch1/g' "${srcdir}/${_reponame}/Makefile"
# https://github.com/graysky2/kernel_gcc_patch