summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Devir2019-10-08 06:29:01 +1000
committerKyle Devir2019-10-08 06:29:01 +1000
commit47783b6a38cf3efaabda23226c862223a6a28aeb (patch)
tree40b53cdede42bd45c1ac2d752a947f1197fe6af0
parent1867744982c5aa10e262c718bda02604bec0a407 (diff)
downloadaur-47783b6a38cf3efaabda23226c862223a6a28aeb.tar.gz
Trying out new versioning scheme for better commit tracking
-rwxr-xr-x.SRCINFO18
-rwxr-xr-xPKGBUILD9
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dc16fc910b9..e83377d7fe20 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bcachefs-git
- pkgver = 5.2.20.arch1
- pkgrel = 2
+ pkgver = 5.2.20.arch1.r844549.5bfe85789782
+ pkgrel = 1
url = https://github.com/koverstreet/bcachefs
arch = x86_64
license = GPL2
@@ -39,18 +39,18 @@ pkgname = linux-bcachefs-git
depends = bcachefs-tools-git
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
- provides = linux-bcachefs-git=5.2.20.arch1
+ provides = linux-bcachefs-git=5.2.20.arch1.r844549.5bfe85789782
backup = etc/mkinitcpio.d/linux-bcachefs-git.preset
pkgname = linux-bcachefs-git-headers
pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- depends = linux-bcachefs-git=5.2.20.arch1
- provides = linux-bcachefs-git-headers=5.2.20.arch1
- provides = linux-headers=5.2.20.arch1
+ depends = linux-bcachefs-git=5.2.20.arch1.r844549.5bfe85789782
+ provides = linux-bcachefs-git-headers=5.2.20.arch1.r844549.5bfe85789782
+ provides = linux-headers=5.2.20.arch1.r844549.5bfe85789782
pkgname = linux-bcachefs-git-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- depends = linux-bcachefs-git=5.2.20.arch1
- provides = linux-bcachefs-git-docs=5.2.20.arch1
- provides = linux-docs=5.2.20.arch1
+ depends = linux-bcachefs-git=5.2.20.arch1.r844549.5bfe85789782
+ provides = linux-bcachefs-git-docs=5.2.20.arch1.r844549.5bfe85789782
+ provides = linux-docs=5.2.20.arch1.r844549.5bfe85789782
diff --git a/PKGBUILD b/PKGBUILD
index 7c84ab23d8e0..dcf42c4841e2 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -62,8 +62,8 @@ _localmodcfg=
pkgbase=linux-bcachefs-git
_srcver_tag=5.2.20-arch1
-pkgver=${_srcver_tag//-/.}
-pkgrel=2
+pkgver=5.2.20.arch1.r844549.5bfe85789782
+pkgrel=1
arch=(x86_64)
url="https://github.com/koverstreet/bcachefs"
license=(GPL2)
@@ -112,6 +112,11 @@ sha512sums=('SKIP'
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
+pkgver() {
+ cd "$_reponame"
+ printf "%s.r%s.%s" "${_srcver_tag//-/.}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd $_reponame