summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2019-08-19 22:46:44 +1000
committerKyle De'Vir2019-08-19 22:46:44 +1000
commitb2b7a4f18e8dc50eca52f5f6c8870c0065a75a92 (patch)
tree5d38bfdb3a5e98f75e75e70b03c83dfc71fb0557
parent0d337301810363b3a10d15d932b1bf4d321184e2 (diff)
downloadaur-b2b7a4f18e8dc50eca52f5f6c8870c0065a75a92.tar.gz
5.1.21
-rwxr-xr-x.SRCINFO20
-rw-r--r--5.1.16-fix.patch25
-rwxr-xr-xPKGBUILD25
-rw-r--r--config4
4 files changed, 55 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0e4e76653dc..403b1e4d0f3a 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bcachefs-git
- pkgver = 5.1.15.arch1
+ pkgver = 5.1.21.arch1
pkgrel = 1
url = https://github.com/koverstreet/bcachefs
arch = x86_64
@@ -17,14 +17,16 @@ pkgbase = linux-bcachefs-git
source = 60-linux.hook
source = 90-linux.hook
source = linux.preset
+ source = 5.1.16-fix.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = f78db94e15ed4a5abca28238d2a315dcf13ff20e04694497275208b4aad18b1ded8b715bad546c623b0138747e6de4c070c28b5d3cc383bdd8b5959afc58294b
+ sha512sums = ed5be61c001e4dec518226843c5074a82a9699f733e5718ed48401d4519d0d53b75fe2e89f298f26177645cf9efb90438cc350d30677e68c44ab6e773983fb54
sha512sums = 7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a
sha512sums = 2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7
sha512sums = 2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf
+ sha512sums = 70159dd2463f8dc937ac05ebf3679cf8f09f5337a95f4b98cb11878d65633926581d6e484a6ab86b8ed0b375ef835fd1c2f569bf508b424983d351fc6fff1ff8
pkgname = linux-bcachefs-git
pkgdesc = The Linux-bcachefs-git kernel and modules ~ featuring Kent Overstreet's bcachefs filesystem
@@ -35,18 +37,18 @@ pkgname = linux-bcachefs-git
depends = mkinitcpio
depends = bcachefs-tools-git
optdepends = crda: to set the correct wireless channels of your country
- provides = linux-bcachefs-git=5.1.15.arch1
+ provides = linux-bcachefs-git=5.1.21.arch1
backup = etc/mkinitcpio.d/linux-bcachefs-git.preset
pkgname = linux-bcachefs-git-headers
pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- depends = linux-bcachefs-git=5.1.15.arch1
- provides = linux-bcachefs-git-headers=5.1.15.arch1
- provides = linux-headers=5.1.15.arch1
+ depends = linux-bcachefs-git=5.1.21.arch1
+ provides = linux-bcachefs-git-headers=5.1.21.arch1
+ provides = linux-headers=5.1.21.arch1
pkgname = linux-bcachefs-git-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- depends = linux-bcachefs-git=5.1.15.arch1
- provides = linux-bcachefs-git-docs=5.1.15.arch1
- provides = linux-docs=5.1.15.arch1
+ depends = linux-bcachefs-git=5.1.21.arch1
+ provides = linux-bcachefs-git-docs=5.1.21.arch1
+ provides = linux-docs=5.1.21.arch1
diff --git a/5.1.16-fix.patch b/5.1.16-fix.patch
new file mode 100644
index 000000000000..edc68eab9450
--- /dev/null
+++ b/5.1.16-fix.patch
@@ -0,0 +1,25 @@
+From 2d6a2017e0e3e7d66c98eb2dcf8fb049f5973241 Mon Sep 17 00:00:00 2001
+From: Kyle De'Vir <kyle.devir@mykolab.com>
+Date: Mon, 19 Aug 2019 20:05:28 +1000
+Subject: [PATCH] 5.1.16 fix
+
+---
+ fs/inode.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fs/inode.c b/fs/inode.c
+index cc44f345e09c..4892d43a6233 100644
+--- a/fs/inode.c
++++ b/fs/inode.c
+@@ -349,7 +349,7 @@ EXPORT_SYMBOL(inc_nlink);
+
+ static void __address_space_init_once(struct address_space *mapping)
+ {
+- xa_init_flags(&mapping->i_pages, XA_FLAGS_LOCK_IRQ);
++ xa_init_flags(&mapping->i_pages, XA_FLAGS_LOCK_IRQ | XA_FLAGS_ACCOUNT);
+ pagecache_lock_init(&mapping->add_lock);
+ init_rwsem(&mapping->i_mmap_rwsem);
+ INIT_LIST_HEAD(&mapping->private_list);
+--
+2.22.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 6db5642c0219..b431e484fe5d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,7 +61,7 @@ _subarch=
_localmodcfg=
pkgbase=linux-bcachefs-git
-_srcver_tag=5.1.15-arch1
+_srcver_tag=5.1.21-arch1
pkgver="${_srcver_tag//-/.}"
pkgrel=1
arch=(x86_64)
@@ -93,6 +93,7 @@ source=(
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
+ 5.1.16-fix.patch
)
validpgpkeys=(
"ABAF11C65A2970B130ABE3C479BE3E4300411886" # Linus Torvalds
@@ -100,10 +101,11 @@ validpgpkeys=(
)
sha512sums=('SKIP'
'SKIP'
- 'f78db94e15ed4a5abca28238d2a315dcf13ff20e04694497275208b4aad18b1ded8b715bad546c623b0138747e6de4c070c28b5d3cc383bdd8b5959afc58294b'
+ 'ed5be61c001e4dec518226843c5074a82a9699f733e5718ed48401d4519d0d53b75fe2e89f298f26177645cf9efb90438cc350d30677e68c44ab6e773983fb54'
'7ad5be75ee422dda3b80edd2eb614d8a9181e2c8228cd68b3881e2fb95953bf2dea6cbe7900ce1013c9de89b2802574b7b24869fc5d7a95d3cc3112c4d27063a'
'2718b58dbbb15063bacb2bde6489e5b3c59afac4c0e0435b97fe720d42c711b6bcba926f67a8687878bd51373c9cf3adb1915a11666d79ccb220bf36e0788ab7'
- '2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf')
+ '2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf'
+ '70159dd2463f8dc937ac05ebf3679cf8f09f5337a95f4b98cb11878d65633926581d6e484a6ab86b8ed0b375ef835fd1c2f569bf508b424983d351fc6fff1ff8')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -116,13 +118,20 @@ prepare() {
echo "-${pkgrel}" > localversion.10-pkgrel
echo "${_kernelname}" > localversion.20-pkgname
+ msg2 "bcachefs 5.1.16 fix"
+ git am --3way "${srcdir}"/5.1.16-fix.patch
+
+ msg2 "Adding patches from Linux upstream kernel repository..."
+ git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
+ git pull --no-edit -s recursive -X ours upstream_stable v"${_srcver_tag//-arch*/}"
+
msg2 "Adding patches from Arch Linux kernel repository..."
git remote add arch_stable "https://git.archlinux.org/linux.git" || true
- git pull --no-edit arch_stable "v${_srcver_tag}"
-
- # msg2 "Adding patches from Linux upstream kernel repository..."
- # git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
- # git pull --no-edit upstream_stable v"${_srcver_tag//-arch*/}"
+ # git pull --no-edit arch_stable "v${_srcver_tag}"
+ git fetch arch_stable "v5.1.16-arch1"
+ git cherry-pick fd0f4757ded3627edc883650941a26a21e435a7d
+ git cherry-pick 7e6c7c0d56e1342b9ad5d8071736a5851d1ae1c7
+ sed -i 's/EXTRAVERSION =/EXTRAVERSION = -arch1/g' "${srcdir}/${_reponame}/Makefile"
# https://github.com/graysky2/kernel_gcc_patch
msg2 "Patching to enabled additional gcc CPU optimizatons..."
diff --git a/config b/config
index 5e8e503fd584..96dd724e7f0d 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.1.15-arch1 Kernel Configuration
+# Linux/x86 5.1.21-arch1 Kernel Configuration
#
#
@@ -3202,7 +3202,7 @@ CONFIG_LED_TRIGGER_PHY=y
CONFIG_SFP=m
CONFIG_AMD_PHY=m
CONFIG_AQUANTIA_PHY=m
-CONFIG_ASIX_PHY=m
+CONFIG_AX88796B_PHY=m
CONFIG_AT803X_PHY=m
CONFIG_BCM7XXX_PHY=m
CONFIG_BCM87XX_PHY=m