summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2021-03-08 10:46:05 +1000
committerKyle De'Vir2021-03-08 10:46:05 +1000
commitb2e6a21b2bc4a8ab30715d588b40391cd7e1b0df (patch)
tree472335af23abecd8ef2d4d1eec8ae05a023b8f57
parent131d7ddf7f4ae1a9080865832704f183dce164a4 (diff)
downloadaur-b2e6a21b2bc4a8ab30715d588b40391cd7e1b0df.tar.gz
5.10.21.arch1
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD38
-rwxr-xr-xarch_patches.patch189
-rw-r--r--config5
4 files changed, 220 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5543d9d0938a..cf6719102cc9 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bcachefs-git
pkgdesc = Linux
- pkgver = v5.10.16.arch1.r969246.e2b8120595b8
+ pkgver = v5.10.21.arch1.r969261.4062aabf8d0e
pkgrel = 1
url = https://github.com/koverstreet/bcachefs
arch = x86_64
@@ -23,11 +23,13 @@ pkgbase = linux-bcachefs-git
source = linux-bcachefs::git+https://github.com/koverstreet/bcachefs#branch=master
source = git+https://github.com/graysky2/kernel_gcc_patch
source = config
+ source = arch_patches.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 93c88efcb310d99bbbbb4f47dfa8892e0021ababafd9b56d55f4fd8c8249f68f286ca4fca3ac090ca5b7695cd20f88cf630503631dcd345d8d1822723e843048
+ sha512sums = 046bf14cdb70d1290a9dd6d125d4499447e88147764fad2dd0a3c10253e56f1632f030f7893a59a7a0f86ce025b3be4bf68c2d2410ac2ca344b6b63b4be5c21c
+ sha512sums = 05ec92046b9b48802b8c3afa550574a46893c90aeb552dca49445d1ef94dbb2a2f39d3d919c65d41f95859cea8bb641e042b20720a1a527cd067965dff84aea7
pkgname = linux-bcachefs-git
pkgdesc = The Linux kernel and modules ~ featuring Kent Overstreet's bcachefs filesystem
@@ -44,6 +46,7 @@ pkgname = linux-bcachefs-git
pkgname = linux-bcachefs-git-headers
pkgdesc = Headers and scripts for building modules for the Linux kernel ~ featuring Kent Overstreet's bcachefs filesystem
+ depends = pahole
pkgname = linux-bcachefs-git-docs
pkgdesc = Documentation for the Linux kernel ~ featuring Kent Overstreet's bcachefs filesystem
diff --git a/PKGBUILD b/PKGBUILD
index 55c477c831d9..6908a4aa3904 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,8 +59,8 @@ _subarch=
_localmodcfg=
pkgbase=linux-bcachefs-git
-pkgver=v5.10.16.arch1.r969246.e2b8120595b8
-_srcver_tag=v5.10.16.arch1
+pkgver=v5.10.21.arch1.r969261.4062aabf8d0e
+_srcver_tag=v5.10.21.arch1
pkgrel=1
pkgdesc="Linux"
url="https://github.com/koverstreet/bcachefs"
@@ -97,6 +97,7 @@ source=(
"${_reponame}::git+${_repo_url}#branch=master"
"git+${_repo_url_gcc_patch}"
config # kernel config file
+ arch_patches.patch
)
validpgpkeys=(
"ABAF11C65A2970B130ABE3C479BE3E4300411886" # Linus Torvalds
@@ -104,7 +105,8 @@ validpgpkeys=(
)
sha512sums=('SKIP'
'SKIP'
- '93c88efcb310d99bbbbb4f47dfa8892e0021ababafd9b56d55f4fd8c8249f68f286ca4fca3ac090ca5b7695cd20f88cf630503631dcd345d8d1822723e843048')
+ '046bf14cdb70d1290a9dd6d125d4499447e88147764fad2dd0a3c10253e56f1632f030f7893a59a7a0f86ce025b3be4bf68c2d2410ac2ca344b6b63b4be5c21c'
+ '05ec92046b9b48802b8c3afa550574a46893c90aeb552dca49445d1ef94dbb2a2f39d3d919c65d41f95859cea8bb641e042b20720a1a527cd067965dff84aea7')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -118,20 +120,25 @@ prepare() {
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- msg2 "Fetch and merge stable tag from Arch vanilla kernel repository..."
- git remote add arch_stable "https://git.archlinux.org/linux.git" || true
- git fetch arch_stable "${_srcver_tag%.*}-${_srcver_tag##*.}"
- git merge --no-edit --no-commit FETCH_HEAD
-
- #msg2 "Fetch and merge tag ${_srcver_tag//.arch*/} from Linux stable upstream repository..."
- #git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
- #git fetch upstream_stable ${_srcver_tag//.arch*/}
+ #msg2 "Fetch and merge stable tag from Arch vanilla kernel repository..."
+ #git remote add arch_stable "https://git.archlinux.org/linux.git" || true
+ #git fetch arch_stable "${_srcver_tag_arch%.*}-${_srcver_tag_arch##*.}"
#git merge --no-edit --no-commit FETCH_HEAD
-
- # https://github.com/graysky2/kernel_gcc_patch
- msg2 "Patching with Graysky's additional gcc CPU optimizatons..."
- patch -Np1 -i "$srcdir/$_reponame_gcc_patch/$_gcc_patch_name"
+ msg2 "Fetch and merge tag ${_srcver_tag//.arch*/} from Linux stable upstream repository..."
+ git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
+ git fetch upstream_stable ${_srcver_tag//.arch*/}
+ git merge --no-edit --no-commit FETCH_HEAD
+
+ PatchesArray=(
+ $_reponame_gcc_patch/$_gcc_patch_name
+ arch_patches.patch
+ )
+ for MyPatch in "${PatchesArray[@]}"
+ do
+ msg2 "Applying patch $MyPatch..."
+ patch -Np1 -i "$srcdir/$MyPatch"
+ done
msg2 "Setting config..."
cp ../config .config
@@ -219,6 +226,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel $_pkgdesc_extra"
+ depends=(pahole)
cd $_reponame
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
diff --git a/arch_patches.patch b/arch_patches.patch
new file mode 100755
index 000000000000..bbf189f2c2ba
--- /dev/null
+++ b/arch_patches.patch
@@ -0,0 +1,189 @@
+From f615330c6169a5fe5750706f1db7cbdd520f9534 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Mon, 16 Sep 2019 04:53:20 +0200
+Subject: ZEN: Add sysctl and CONFIG to disallow unprivileged CLONE_NEWUSER
+
+Our default behavior continues to match the vanilla kernel.
+---
+ include/linux/user_namespace.h | 4 ++++
+ init/Kconfig | 16 ++++++++++++++++
+ kernel/fork.c | 14 ++++++++++++++
+ kernel/sysctl.c | 12 ++++++++++++
+ kernel/user_namespace.c | 7 +++++++
+ 5 files changed, 53 insertions(+)
+
+diff --git a/include/linux/user_namespace.h b/include/linux/user_namespace.h
+index 6ef1c7109fc4..2140091b0b8d 100644
+--- a/include/linux/user_namespace.h
++++ b/include/linux/user_namespace.h
+@@ -106,6 +106,8 @@ void dec_ucount(struct ucounts *ucounts, enum ucount_type type);
+
+ #ifdef CONFIG_USER_NS
+
++extern int unprivileged_userns_clone;
++
+ static inline struct user_namespace *get_user_ns(struct user_namespace *ns)
+ {
+ if (ns)
+@@ -139,6 +141,8 @@ extern bool current_in_userns(const struct user_namespace *target_ns);
+ struct ns_common *ns_get_owner(struct ns_common *ns);
+ #else
+
++#define unprivileged_userns_clone 0
++
+ static inline struct user_namespace *get_user_ns(struct user_namespace *ns)
+ {
+ return &init_user_ns;
+diff --git a/init/Kconfig b/init/Kconfig
+index 0872a5a2e759..a40d8afeb1bb 100644
+--- a/init/Kconfig
++++ b/init/Kconfig
+@@ -1173,6 +1173,22 @@ config USER_NS
+
+ If unsure, say N.
+
++config USER_NS_UNPRIVILEGED
++ bool "Allow unprivileged users to create namespaces"
++ default y
++ depends on USER_NS
++ help
++ When disabled, unprivileged users will not be able to create
++ new namespaces. Allowing users to create their own namespaces
++ has been part of several recent local privilege escalation
++ exploits, so if you need user namespaces but are
++ paranoid^Wsecurity-conscious you want to disable this.
++
++ This setting can be overridden at runtime via the
++ kernel.unprivileged_userns_clone sysctl.
++
++ If unsure, say Y.
++
+ config PID_NS
+ bool "PID Namespaces"
+ default y
+diff --git a/kernel/fork.c b/kernel/fork.c
+index c675fdbd3dce..9266039e28e4 100644
+--- a/kernel/fork.c
++++ b/kernel/fork.c
+@@ -97,6 +97,10 @@
+ #include <linux/scs.h>
+ #include <linux/io_uring.h>
+
++#ifdef CONFIG_USER_NS
++#include <linux/user_namespace.h>
++#endif
++
+ #include <asm/pgalloc.h>
+ #include <linux/uaccess.h>
+ #include <asm/mmu_context.h>
+@@ -1863,6 +1867,10 @@ static __latent_entropy struct task_struct *copy_process(
+ if ((clone_flags & (CLONE_NEWUSER|CLONE_FS)) == (CLONE_NEWUSER|CLONE_FS))
+ return ERR_PTR(-EINVAL);
+
++ if ((clone_flags & CLONE_NEWUSER) && !unprivileged_userns_clone)
++ if (!capable(CAP_SYS_ADMIN))
++ return ERR_PTR(-EPERM);
++
+ /*
+ * Thread groups must share signals as well, and detached threads
+ * can only be started up within the thread group.
+@@ -2928,6 +2936,12 @@ int ksys_unshare(unsigned long unshare_flags)
+ if (unshare_flags & CLONE_NEWNS)
+ unshare_flags |= CLONE_FS;
+
++ if ((unshare_flags & CLONE_NEWUSER) && !unprivileged_userns_clone) {
++ err = -EPERM;
++ if (!capable(CAP_SYS_ADMIN))
++ goto bad_unshare_out;
++ }
++
+ err = check_unshare_flags(unshare_flags);
+ if (err)
+ goto bad_unshare_out;
+diff --git a/kernel/sysctl.c b/kernel/sysctl.c
+index afad085960b8..a94828fb31c2 100644
+--- a/kernel/sysctl.c
++++ b/kernel/sysctl.c
+@@ -103,6 +103,9 @@
+ #ifdef CONFIG_LOCKUP_DETECTOR
+ #include <linux/nmi.h>
+ #endif
++#ifdef CONFIG_USER_NS
++#include <linux/user_namespace.h>
++#endif
+
+ #if defined(CONFIG_SYSCTL)
+
+@@ -1902,6 +1905,15 @@ static struct ctl_table kern_table[] = {
+ .proc_handler = proc_dointvec,
+ },
+ #endif
++#ifdef CONFIG_USER_NS
++ {
++ .procname = "unprivileged_userns_clone",
++ .data = &unprivileged_userns_clone,
++ .maxlen = sizeof(int),
++ .mode = 0644,
++ .proc_handler = proc_dointvec,
++ },
++#endif
+ #ifdef CONFIG_PROC_SYSCTL
+ {
+ .procname = "tainted",
+diff --git a/kernel/user_namespace.c b/kernel/user_namespace.c
+index e703d5d9cbe8..5758274feaee 100644
+--- a/kernel/user_namespace.c
++++ b/kernel/user_namespace.c
+@@ -21,6 +21,13 @@
+ #include <linux/bsearch.h>
+ #include <linux/sort.h>
+
++/* sysctl */
++#ifdef CONFIG_USER_NS_UNPRIVILEGED
++int unprivileged_userns_clone = 1;
++#else
++int unprivileged_userns_clone;
++#endif
++
+ static struct kmem_cache *user_ns_cachep __read_mostly;
+ static DEFINE_MUTEX(userns_state_mutex);
+
+--
+cgit v1.2.3-1-gf6bb5
+
+From 3df6111e2ffaf7a57dd245a9df1997f773840b74 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Felix=20H=C3=A4dicke?= <felixhaedicke@web.de>
+Date: Thu, 19 Nov 2020 09:22:32 +0100
+Subject: HID: quirks: Add Apple Magic Trackpad 2 to hid_have_special_driver
+ list
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The Apple Magic Trackpad 2 is handled by the magicmouse driver. And
+there were severe stability issues when both drivers (hid-generic and
+hid-magicmouse) were loaded for this device.
+
+Fixes: https://bugzilla.kernel.org/show_bug.cgi?id=210241
+
+Signed-off-by: Felix Hädicke <felixhaedicke@web.de>
+---
+ drivers/hid/hid-quirks.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/drivers/hid/hid-quirks.c b/drivers/hid/hid-quirks.c
+index bf7ecab5d9e5..142e9dae2837 100644
+--- a/drivers/hid/hid-quirks.c
++++ b/drivers/hid/hid-quirks.c
+@@ -478,6 +478,8 @@ static const struct hid_device_id hid_have_special_driver[] = {
+ #if IS_ENABLED(CONFIG_HID_MAGICMOUSE)
+ { HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGICMOUSE) },
+ { HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGICTRACKPAD) },
++ { HID_BLUETOOTH_DEVICE(BT_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGICTRACKPAD2) },
++ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGICTRACKPAD2) },
+ #endif
+ #if IS_ENABLED(CONFIG_HID_MAYFLASH)
+ { HID_USB_DEVICE(USB_VENDOR_ID_DRAGONRISE, USB_DEVICE_ID_DRAGONRISE_PS3) },
+--
+cgit v1.2.3-1-gf6bb5
+
diff --git a/config b/config
index d0f6adc9a8fa..39c2008508a5 100644
--- a/config
+++ b/config
@@ -1,11 +1,11 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.10.16-arch1 Kernel Configuration
+# Linux/x86 5.10.21 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 10.2.0"
CONFIG_CC_IS_GCC=y
CONFIG_GCC_VERSION=100200
-CONFIG_LD_VERSION=235010000
+CONFIG_LD_VERSION=236010000
CONFIG_CLANG_VERSION=0
CONFIG_LLD_VERSION=0
CONFIG_CC_CAN_LINK=y
@@ -262,6 +262,7 @@ CONFIG_BPF_PRELOAD=y
CONFIG_BPF_PRELOAD_UMD=m
CONFIG_USERFAULTFD=y
CONFIG_ARCH_HAS_MEMBARRIER_SYNC_CORE=y
+CONFIG_KCMP=y
CONFIG_RSEQ=y
# CONFIG_EMBEDDED is not set
CONFIG_HAVE_PERF_EVENTS=y