summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Devir2019-10-08 18:25:20 +1000
committerKyle Devir2019-10-08 18:25:20 +1000
commitb8d9a5632f993301314d6324b44a28fde327a67c (patch)
tree0ab574b8b980ceafffdd8c639775b2fee571e624
parent47783b6a38cf3efaabda23226c862223a6a28aeb (diff)
downloadaur-b8d9a5632f993301314d6324b44a28fde327a67c.tar.gz
Temporary fix for https://github.com/koverstreet/bcachefs/issues/74
-rwxr-xr-x.SRCINFO16
-rwxr-xr-xPKGBUILD13
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e83377d7fe20..99dcd7304588 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bcachefs-git
- pkgver = 5.2.20.arch1.r844549.5bfe85789782
+ pkgver = 5.2.20.arch1.r844550.2df3501f6873
pkgrel = 1
url = https://github.com/koverstreet/bcachefs
arch = x86_64
@@ -39,18 +39,18 @@ pkgname = linux-bcachefs-git
depends = bcachefs-tools-git
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
- provides = linux-bcachefs-git=5.2.20.arch1.r844549.5bfe85789782
+ provides = linux-bcachefs-git=5.2.20.arch1.r844550.2df3501f6873
backup = etc/mkinitcpio.d/linux-bcachefs-git.preset
pkgname = linux-bcachefs-git-headers
pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- depends = linux-bcachefs-git=5.2.20.arch1.r844549.5bfe85789782
- provides = linux-bcachefs-git-headers=5.2.20.arch1.r844549.5bfe85789782
- provides = linux-headers=5.2.20.arch1.r844549.5bfe85789782
+ depends = linux-bcachefs-git=5.2.20.arch1.r844550.2df3501f6873
+ provides = linux-bcachefs-git-headers=5.2.20.arch1.r844550.2df3501f6873
+ provides = linux-headers=5.2.20.arch1.r844550.2df3501f6873
pkgname = linux-bcachefs-git-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- depends = linux-bcachefs-git=5.2.20.arch1.r844549.5bfe85789782
- provides = linux-bcachefs-git-docs=5.2.20.arch1.r844549.5bfe85789782
- provides = linux-docs=5.2.20.arch1.r844549.5bfe85789782
+ depends = linux-bcachefs-git=5.2.20.arch1.r844550.2df3501f6873
+ provides = linux-bcachefs-git-docs=5.2.20.arch1.r844550.2df3501f6873
+ provides = linux-docs=5.2.20.arch1.r844550.2df3501f6873
diff --git a/PKGBUILD b/PKGBUILD
index dcf42c4841e2..50b958b3e39c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -62,7 +62,7 @@ _localmodcfg=
pkgbase=linux-bcachefs-git
_srcver_tag=5.2.20-arch1
-pkgver=5.2.20.arch1.r844549.5bfe85789782
+pkgver=5.2.20.arch1.r844550.2df3501f6873
pkgrel=1
arch=(x86_64)
url="https://github.com/koverstreet/bcachefs"
@@ -130,19 +130,24 @@ prepare() {
# git pull --no-edit -s recursive -X ours upstream_stable v${_srcver_tag//-arch*/}
git pull --no-edit upstream_stable v${_srcver_tag//-arch*/}
+ # https://github.com/koverstreet/bcachefs/issues/74
+ git revert --no-edit c785529bebceeaf38db8ebf9b50ff3a173fb18c6
+ # https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.2.1&id=c785529bebceeaf38db8ebf9b50ff3a173fb18c6
+ # block: fix .bi_size overflow
+
msg2 "Adding patches from Arch Linux kernel repository..."
git remote add arch_stable "https://git.archlinux.org/linux.git" || true
# git pull --no-edit arch_stable "v$_srcver_tag"
git fetch arch_stable v5.2.14-arch2
+ git cherry-pick 7097880bd7857294d2b91084a35d2211cef7dd8b
# https://git.archlinux.org/linux.git/commit/?h=v5.1.16-arch1&id=fd0f4757ded3627edc883650941a26a21e435a7d
# add sysctl to disallow unprivileged CLONE_NEWUSER by default
- git cherry-pick 7097880bd7857294d2b91084a35d2211cef7dd8b
+ git cherry-pick de96c660ed1f470fed317e987444634cb6287d57
# https://git.archlinux.org/linux.git/commit/?h=v5.1.16-arch1&id=7e6c7c0d56e1342b9ad5d8071736a5851d1ae1c7
# ZEN: Add CONFIG for unprivileged_userns_clone
- git cherry-pick de96c660ed1f470fed317e987444634cb6287d57
-
+
msg2 "Fixing EXTRAVERSION..."
sed -i 's/EXTRAVERSION =/EXTRAVERSION = -arch1/g' "$srcdir/$_reponame/Makefile"