summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Devir2019-10-04 16:21:43 +1000
committerKyle Devir2019-10-04 16:21:43 +1000
commitc86bc51ce6d48cfee6528f4576675ac4ce73f76e (patch)
tree07855ff5fd7eafdb444d3af9aa20a6d999db963a
parent4980d275efa7c5d3070cd077afeee9e98032fb18 (diff)
downloadaur-c86bc51ce6d48cfee6528f4576675ac4ce73f76e.tar.gz
Track vanilla Arch kernel PKGBUILD
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40d49c803c76..f47a2958cba5 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bcachefs-git
pkgver = 5.2.18.arch1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/koverstreet/bcachefs
arch = x86_64
license = GPL2
@@ -34,11 +34,11 @@ pkgname = linux-bcachefs-git
pkgdesc = The Linux-bcachefs-git kernel and modules ~ featuring Kent Overstreet's bcachefs filesystem
install = linux.install
depends = coreutils
- depends = linux-firmware
depends = kmod
- depends = mkinitcpio
+ depends = initramfs
depends = bcachefs-tools-git
optdepends = crda: to set the correct wireless channels of your country
+ optdepends = linux-firmware: firmware images needed for some devices
provides = linux-bcachefs-git=5.2.18.arch1
backup = etc/mkinitcpio.d/linux-bcachefs-git.preset
diff --git a/PKGBUILD b/PKGBUILD
index c67fa50abdd5..7a4e731fffe5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,7 +63,7 @@ _localmodcfg=
pkgbase=linux-bcachefs-git
_srcver_tag=5.2.18-arch1
pkgver=${_srcver_tag//-/.}
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://github.com/koverstreet/bcachefs"
license=(GPL2)
@@ -187,12 +187,14 @@ _package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules $_pkgdesc_extra"
depends=(
coreutils
- linux-firmware
kmod
- mkinitcpio
+ initramfs
bcachefs-tools-git
)
- optdepends=("crda: to set the correct wireless channels of your country")
+ optdepends=(
+ "crda: to set the correct wireless channels of your country"
+ "linux-firmware: firmware images needed for some devices"
+ )
provides=("$pkgbase=$pkgver")
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -208,6 +210,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install