summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2019-08-10 12:57:33 +1000
committerKyle De'Vir2019-08-10 12:57:33 +1000
commitdae78e4b22bde34fe856f8b05ede61154c763188 (patch)
tree70cb6f43caece03c65b4f8004f19badfd618fb07
parent2871fc4b90e22168d701e279dfc4aad7295d5599 (diff)
downloadaur-dae78e4b22bde34fe856f8b05ede61154c763188.tar.gz
Stuff
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD174
2 files changed, 87 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12150d2de3c4..c25df11c491f 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = linux-bcachefs-git
makedepends = libelf
makedepends = git
options = !strip
- source = git+https://github.com/koverstreet/bcachefs
+ source = git+https://github.com/koverstreet/bcachefs#branch=master
source = git+https://github.com/graysky2/kernel_gcc_patch
source = config
source = 60-linux.hook
diff --git a/PKGBUILD b/PKGBUILD
index e7ec6758500b..c8bdf0b115b4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -73,10 +73,9 @@ makedepends=(
libelf
git
)
-options=('!strip')
+options=("!strip")
_reponame="bcachefs"
-
_repo_url="https://github.com/koverstreet/${_reponame}"
_reponame_gcc_patch="kernel_gcc_patch"
@@ -86,7 +85,7 @@ _gcc_patch_name="enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+
_pkgdesc_extra="~ featuring Kent Overstreet's bcachefs filesystem"
source=(
- "git+${_repo_url}"
+ "git+${_repo_url}#branch=master"
"git+${_repo_url_gcc_patch}"
config # the main kernel config file
60-linux.hook # pacman hook for depmod
@@ -94,8 +93,8 @@ source=(
linux.preset # standard config files for mkinitcpio ramdisk
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ "ABAF11C65A2970B130ABE3C479BE3E4300411886" # Linus Torvalds
+ "647F28654894E3BD457199BE38DBBDC86092693E" # Greg Kroah-Hartman
)
sha512sums=('SKIP'
'SKIP'
@@ -112,33 +111,33 @@ prepare() {
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "$_kernelname" > localversion.20-pkgname
+ echo "-${pkgrel}" > localversion.10-pkgrel
+ echo "${_kernelname}" > localversion.20-pkgname
msg2 "Adding patches from Arch Linux kernel repository..."
- git remote add arch_stable https://git.archlinux.org/linux.git || true
+ git remote add arch_stable "https://git.archlinux.org/linux.git" || true
git pull --no-edit arch_stable "v${_srcver_tag}"
# msg2 "Adding patches from Linux upstream kernel repository..."
- # git remote add upstream_stable https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git || true
+ # git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
# git pull --no-edit upstream_stable v"${_srcver_tag//-arch*/}"
# https://github.com/graysky2/kernel_gcc_patch
msg2 "Patching to enabled additional gcc CPU optimizatons..."
- patch -Np1 -i "$srcdir/${_reponame_gcc_patch}/${_gcc_patch_name}"
+ patch -Np1 -i "${srcdir}/${_reponame_gcc_patch}/${_gcc_patch_name}"
msg2 "Setting config..."
cp ../config .config
- if [ -n "$_subarch" ]; then
- yes "$_subarch" | make oldconfig
+ if [ -n "${_subarch}" ]; then
+ yes "${_subarch}" | make oldconfig
else
make prepare
fi
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
- if [ -n "$_localmodcfg" ]; then
+ if [ -n "${_localmodcfg}" ]; then
msg "If you have modprobed-db installed, running it in recall mode now"
if [ -e /usr/bin/modprobed-db ]; then
[[ -x /usr/bin/sudo ]] || {
@@ -149,13 +148,13 @@ prepare() {
fi
fi
- # do not run `make olddefconfig` as it sets default options
+ # do not run "make olddefconfig" as it sets default options
yes "" | make config >/dev/null
make -s kernelrelease > ../version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ msg2 "Prepared %s version %s" "${pkgbase}" "$(<../version)"
- [[ -z "$_makenconfig" ]] || make nconfig
+ [[ -z "${_makenconfig}" ]] || make nconfig
# save configuration for later reuse
cat .config > "${startdir}/config.last"
@@ -163,7 +162,6 @@ prepare() {
build() {
cd ${_reponame}
-
make bzImage modules
}
@@ -176,56 +174,56 @@ _package() {
mkinitcpio
bcachefs-tools-git
)
- optdepends=('crda: to set the correct wireless channels of your country')
- backup=("etc/mkinitcpio.d/$pkgbase.preset")
+ optdepends=("crda: to set the correct wireless channels of your country")
+ backup=("etc/mkinitcpio.d/${pkgbase}.preset")
install=linux.install
local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="${pkgdir}/usr/lib/modules/${kernver}"
- cd ${_reponame}
+ cd ${_reponame}
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
- install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "${modulesdir}/vmlinuz"
+ install -Dm644 "${modulesdir}/vmlinuz" "${pkgdir}/boot/vmlinuz-${pkgbase}"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
# a place for external modules,
# with version file for building modules and running depmod from hook
- local extramodules="extramodules$_kernelname"
- local extradir="$pkgdir/usr/lib/modules/$extramodules"
- install -Dt "$extradir" -m644 ../version
- ln -sr "$extradir" "$modulesdir/extramodules"
+ local extramodules="extramodules${_kernelname}"
+ local extradir="${pkgdir}/usr/lib/modules/${extramodules}"
+ install -Dt "${extradir}" -m644 ../version
+ ln -sr "${extradir}" "${modulesdir}/extramodules"
# remove build and source links
- rm "$modulesdir"/{source,build}
+ rm "${modulesdir}"/{source,build}
msg2 "Installing hooks..."
# sed expression for following substitutions
local subst="
- s|%PKGBASE%|$pkgbase|g
- s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extramodules|g
+ s|%PKGBASE%|${pkgbase}|g
+ s|%KERNVER%|${kernver}|g
+ s|%EXTRAMODULES%|${extramodules}|g
"
# hack to allow specifying an initially nonexisting install file
- sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
- true && install=$install.pkg
+ sed "${subst}" "${startdir}/${install}" > "${startdir}/${install}.pkg"
+ true && install=${install}.pkg
# fill in mkinitcpio preset and pacman hooks
- sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
- "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
- sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/60-$pkgbase.hook"
- sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/90-$pkgbase.hook"
+ sed "${subst}" ../linux.preset | install -Dm644 /dev/stdin \
+ "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
+ sed "${subst}" ../60-linux.hook | install -Dm644 /dev/stdin \
+ "${pkgdir}/usr/share/libalpm/hooks/60-${pkgbase}.hook"
+ sed "${subst}" ../90-linux.hook | install -Dm644 /dev/stdin \
+ "${pkgdir}/usr/share/libalpm/hooks/90-${pkgbase}.hook"
msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
+ chmod -Rc u=rwX,go=rX "${pkgdir}"
}
_package-headers() {
@@ -235,82 +233,82 @@ _package-headers() {
"linux-headers=${pkgver}"
)
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+ local builddir="${pkgdir}/usr/lib/modules/$(<version)/build"
cd ${_reponame}
msg2 "Installing build files..."
- install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
- install -Dt "$builddir/kernel" -m644 kernel/Makefile
- install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
- cp -t "$builddir" -a scripts
+ install -Dt "${builddir}" -m644 Makefile .config Module.symvers System.map vmlinux
+ install -Dt "${builddir}/kernel" -m644 kernel/Makefile
+ install -Dt "${builddir}/arch/x86" -m644 arch/x86/Makefile
+ cp -t "${builddir}" -a scripts
# add objtool for external module building and enabled VALIDATION_STACK option
- install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+ install -Dt "${builddir}/tools/objtool" tools/objtool/objtool
# add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ mkdir -p "${builddir}"/{fs/xfs,mm}
# ???
- mkdir "$builddir/.tmp_versions"
+ mkdir "${builddir}/.tmp_versions"
msg2 "Installing headers..."
- cp -t "$builddir" -a include
- cp -t "$builddir/arch/x86" -a arch/x86/include
- install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
+ cp -t "${builddir}" -a include
+ cp -t "${builddir}/arch/x86" -a arch/x86/include
+ install -Dt "${builddir}/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
- install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
- install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
+ install -Dt "${builddir}/drivers/md" -m644 drivers/md/*.h
+ install -Dt "${builddir}/net/mac80211" -m644 net/mac80211/*.h
# http://bugs.archlinux.org/task/13146
- install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+ install -Dt "${builddir}/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
# http://bugs.archlinux.org/task/20402
- install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
- install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
- install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+ install -Dt "${builddir}/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "${builddir}/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "${builddir}/drivers/media/tuners" -m644 drivers/media/tuners/*.h
msg2 "Installing KConfig files..."
- find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
+ find . -name "Kconfig*" -exec install -Dm644 {} "${builddir}/{}" \;
msg2 "Removing unneeded architectures..."
local arch
- for arch in "$builddir"/arch/*/; do
- [[ $arch = */x86/ ]] && continue
- echo "Removing $(basename "$arch")"
- rm -r "$arch"
+ for arch in "${builddir}"/arch/*/; do
+ [[ ${arch} = */x86/ ]] && continue
+ echo "Removing $(basename "${arch}")"
+ rm -r "${arch}"
done
msg2 "Removing documentation..."
- rm -r "$builddir/Documentation"
+ rm -r "${builddir}/Documentation"
msg2 "Removing broken symlinks..."
- find -L "$builddir" -type l -printf 'Removing %P\n' -delete
+ find -L "${builddir}" -type l -printf "Removing %P\n" -delete
msg2 "Removing loose objects..."
- find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
+ find "${builddir}" -type f -name "*.o" -printf "Removing %P\n" -delete
msg2 "Stripping build tools..."
local file
- while read -rd '' file; do
- case "$(file -bi "$file")" in
+ while read -rd "" file; do
+ case "$(file -bi "${file}")" in
application/x-sharedlib\;*) # Libraries (.so)
- strip -v $STRIP_SHARED "$file" ;;
+ strip -v $STRIP_SHARED "${file}" ;;
application/x-archive\;*) # Libraries (.a)
- strip -v $STRIP_STATIC "$file" ;;
+ strip -v $STRIP_STATIC "${file}" ;;
application/x-executable\;*) # Binaries
- strip -v $STRIP_BINARIES "$file" ;;
+ strip -v $STRIP_BINARIES "${file}" ;;
application/x-pie-executable\;*) # Relocatable binaries
- strip -v $STRIP_SHARED "$file" ;;
+ strip -v $STRIP_SHARED "${file}" ;;
esac
- done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ done < <(find "${builddir}" -type f -perm -u+x ! -name vmlinux -print0)
msg2 "Adding symlink..."
- mkdir -p "$pkgdir/usr/src"
- ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+ mkdir -p "${pkgdir}/usr/src"
+ ln -sr "${builddir}" "${pkgdir}/usr/src/${pkgbase}-${pkgver}"
msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
+ chmod -Rc u=rwX,go=rX "${pkgdir}"
}
_package-docs() {
@@ -320,31 +318,31 @@ _package-docs() {
"linux-docs=${pkgver}"
)
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+ local builddir="${pkgdir}/usr/lib/modules/$(<version)/build"
cd ${_reponame}
msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
+ mkdir -p "${builddir}"
+ cp -t "${builddir}" -a Documentation
msg2 "Adding symlink..."
- mkdir -p "$pkgdir/usr/share/doc"
- ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+ mkdir -p "${pkgdir}/usr/share/doc"
+ ln -sr "${builddir}/Documentation" "${pkgdir}/usr/share/doc/${pkgbase}"
msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
+ chmod -Rc u=rwX,go=rX "${pkgdir}"
}
pkgname=(
- "$pkgbase"
- "$pkgbase-headers"
- "$pkgbase-docs"
+ "${pkgbase}"
+ "${pkgbase}-headers"
+ "${pkgbase}-docs"
)
for _p in "${pkgname[@]}"; do
- eval "package_$_p() {
- $(declare -f "_package${_p#$pkgbase}")
- _package${_p#$pkgbase}
+ eval "package_${_p}() {
+ $(declare -f "_package${_p#${pkgbase}}")
+ _package${_p#${pkgbase}}
}"
done