summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2020-06-08 01:18:48 +1000
committerKyle De'Vir2020-06-08 01:18:48 +1000
commitf501ba02bae62be60d911ec29a4a91f25b2a99ae (patch)
tree74ef620822d2155324144f918ad4fe7212c4a19c
parentdd17c52cc4843ce2552d4866e69da340ff9ad493 (diff)
downloadaur-f501ba02bae62be60d911ec29a4a91f25b2a99ae.tar.gz
5.6.17.arch1
-rwxr-xr-x.SRCINFO1
-rwxr-xr-xPKGBUILD10
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36bb648b2bee..447db5696b8e 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = linux-bcachefs-git
makedepends = bc
makedepends = kmod
makedepends = libelf
+ makedepends = pahole
makedepends = xmlto
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
diff --git a/PKGBUILD b/PKGBUILD
index b842e75cc288..b5c79a4e2f46 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -62,7 +62,7 @@ pkgbase=linux-bcachefs-git
pkgver=v5.6.16.arch1.r903063.c9b4a210f946
pkgrel=1
pkgdesc="Linux"
-_srcver_tag=v5.6.16.arch1
+_srcver_tag=v5.6.17.arch1
url="https://github.com/koverstreet/bcachefs"
arch=(x86_64)
license=(GPL2)
@@ -70,6 +70,7 @@ makedepends=(
bc
kmod
libelf
+ pahole
xmlto
python-sphinx
python-sphinx_rtd_theme
@@ -121,7 +122,7 @@ prepare() {
# git remote add arch_stable "https://git.archlinux.org/linux.git" || true
# git pull --no-edit --no-commit arch_stable "${_srcver_tag%.*}-${_srcver_tag##*.}"
- msg2 "Pull tag from Linux stable upstream repository..."
+ msg2 "Fetch and merge tag ${_srcver_tag//.arch*/} from Linux stable upstream repository..."
git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
git fetch upstream_stable ${_srcver_tag//.arch*/}
git merge --no-edit --no-commit FETCH_HEAD
@@ -215,7 +216,7 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -290,6 +291,9 @@ _package-headers() {
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"