summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2015-09-18 18:09:57 +0200
committersirlucjan2015-09-18 18:09:57 +0200
commit52b023ea66b36d0383d29365e8100b422156f5a0 (patch)
tree26d454c52a17991272eaa19ed8bed97064131ad0
parent8a9447486ac33e81dabc45a6f40891995ac167a2 (diff)
downloadaur-52b023ea66b36d0383d29365e8100b422156f5a0.tar.gz
Update
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77a83f70a200..c72faf339561 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,9 @@ _makexconfig=
# Tweak kernel options prior to a build via gconfig
_makegconfig=
+# Running with a 1000 HZ tick rate
+_1k_HZ_ticks=
+
# NUMA is optimized for multi-socket motherboards.
# A single multi-core CPU actually runs slower with NUMA enabled.
# See, https://bugs.archlinux.org/task/31187
@@ -107,8 +110,14 @@ prepare() {
else
cat "${srcdir}/config" > ./.config
fi
-
-
+
+ ### Optionally set tickrate to 1000
+ if [ -n "$_1k_HZ_ticks" ]; then
+ msg "Setting tick rate to 1k..."
+ sed -i -e 's/^CONFIG_HZ_300=y/# CONFIG_HZ_300 is not set/' \
+ -i -e 's/^# CONFIG_HZ_1000 is not set/CONFIG_HZ_1000=y/' \
+ -i -e 's/^CONFIG_HZ=300/CONFIG_HZ=1000/' .config
+ fi
### Optionally use running kernel's config
# code originally by nous; http://aur.archlinux.org/packages.php?ID=40191