summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2017-04-01 20:22:11 +0200
committersirlucjan2017-04-01 20:22:11 +0200
commit6ca3fcfecd5f394eab88cbd943f77525fc672911 (patch)
tree240cf874ef5aaca07bf5b8a587d4fd563ced2abe
parent6a4afade7898f4ba7dd73a0c84bf6ae9f113d7f5 (diff)
downloadaur-6ca3fcfecd5f394eab88cbd943f77525fc672911.tar.gz
Update BFQ to v8r9
-rw-r--r--.SRCINFO6
-rw-r--r--0005-BFQ-update-to-v8r9.patch (renamed from 0005-BFQ-bugfix.patch)38
-rw-r--r--PKGBUILD6
3 files changed, 43 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9002eb99517e..f34e3214efe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bfq
pkgver = 4.10.8
- pkgrel = 1
+ pkgrel = 2
url = http://algo.ing.unimo.it
arch = i686
arch = x86_64
@@ -22,7 +22,7 @@ pkgbase = linux-bfq
source = config.x86_64
source = 90-linux.hook
source = linux.preset
- source = 0005-BFQ-bugfix.patch
+ source = 0005-BFQ-update-to-v8r9.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha512sums = c3690125a8402df638095bd98a613fcf1a257b81de7611c84711d315cd11e2634ab4636302b3742aedf1e3ba9ce0fea53fe8c7d48e37865d8ee5db3565220d90
@@ -38,7 +38,7 @@ pkgbase = linux-bfq
sha512sums = 6afb164bc7a38fea08a49c70690afafb209d1245588e1ecf57998926f5b43fe85d39a1ab1a133900b82bc1d3d97538330bf5c646b62e782653d69b6139d72200
sha512sums = d6faa67f3ef40052152254ae43fee031365d0b1524aa0718b659eb75afc21a3f79ea8d62d66ea311a800109bed545bc8f79e8752319cd378eef2cbd3a09aba22
sha512sums = 2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf
- sha512sums = 2fbe9ddf40a64f9b80ab3b4868e358ea678b4122742884b7c484041a913757627d1c6b0ee6e2ef46fe90d82e7e29e6332d3b6155d56355d274fdf551f8a8ef70
+ sha512sums = ee41c3d94f16ad34077a84a1bdb49789e5d7979c75abb46970707929627542f7c78e35ae93833b45030ea03ec4ee52f21e410dad37fa967d02d1aeb72f0b5cd8
pkgname = linux-bfq
pkgdesc = Linux Kernel and modules with the BFQ scheduler.
diff --git a/0005-BFQ-bugfix.patch b/0005-BFQ-update-to-v8r9.patch
index 68be7f5fe705..7fb1f70f0f58 100644
--- a/0005-BFQ-bugfix.patch
+++ b/0005-BFQ-update-to-v8r9.patch
@@ -1,7 +1,7 @@
From 2da7edbb8f54b447c0b7dfa029ee4df580a6030e Mon Sep 17 00:00:00 2001
From: Paolo Valente <paolo.valente@linaro.org>
Date: Thu, 16 Mar 2017 14:36:41 +0100
-Subject: [PATCH] BUGIFX: remove use of bfq queues after free
+Subject: [PATCH 1/2] BUGIFX: remove use of bfq queues after free
bfq queues occasionally happened to be used after being freed, because
they were accessed after some invocations of bfq_put_queue that could
@@ -339,3 +339,39 @@ index 2e9dc59..70aac56 100644
}
/*
+
+From 8d4b2ded945bdb75fc5c197d95089ebfe5fa24e7 Mon Sep 17 00:00:00 2001
+From: Paolo Valente <paolo.valente@linaro.org>
+Date: Tue, 21 Mar 2017 09:56:39 -0400
+Subject: [PATCH 2/2] BFQ-v8r9
+
+Signed-off-by: Paolo Valente <paolo.valente@linaro.org>
+---
+ block/bfq-iosched.c | 2 +-
+ block/bfq.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/block/bfq-iosched.c b/block/bfq-iosched.c
+index f00761b..1e46d68 100644
+--- a/block/bfq-iosched.c
++++ b/block/bfq-iosched.c
+@@ -5252,7 +5252,7 @@ static struct blkcg_policy blkcg_policy_bfq = {
+ static int __init bfq_init(void)
+ {
+ int ret;
+- char msg[60] = "BFQ I/O-scheduler: v8r8";
++ char msg[60] = "BFQ I/O-scheduler: v8r9";
+
+ #ifdef CONFIG_BFQ_GROUP_IOSCHED
+ ret = blkcg_policy_register(&blkcg_policy_bfq);
+diff --git a/block/bfq.h b/block/bfq.h
+index f433cfe..6faed4f 100644
+--- a/block/bfq.h
++++ b/block/bfq.h
+@@ -1,5 +1,5 @@
+ /*
+- * BFQ v8r8 for 4.10.0: data structures and common functions prototypes.
++ * BFQ v8r9 for 4.10.0: data structures and common functions prototypes.
+ *
+ * Based on ideas and code from CFQ:
+ * Copyright (C) 2003 Jens Axboe <axboe@kernel.dk>
diff --git a/PKGBUILD b/PKGBUILD
index 2b1b37093e7f..275e01555bf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,7 +52,7 @@ pkgbase=linux-bfq
# pkgname=('linux-bfq' 'linux-bfq-headers' 'linux-bfq-docs')
_srcname=linux-4.10
pkgver=4.10.8
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://algo.ing.unimo.it"
license=('GPL2')
@@ -80,7 +80,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux.preset'
# patches from https://github.com/linusw/linux-bfq/commits/bfq-v8
- '0005-BFQ-bugfix.patch')
+ '0005-BFQ-update-to-v8r9.patch')
_kernelname=${pkgbase#linux}
@@ -436,7 +436,7 @@ sha512sums=('c3690125a8402df638095bd98a613fcf1a257b81de7611c84711d315cd11e2634ab
'6afb164bc7a38fea08a49c70690afafb209d1245588e1ecf57998926f5b43fe85d39a1ab1a133900b82bc1d3d97538330bf5c646b62e782653d69b6139d72200'
'd6faa67f3ef40052152254ae43fee031365d0b1524aa0718b659eb75afc21a3f79ea8d62d66ea311a800109bed545bc8f79e8752319cd378eef2cbd3a09aba22'
'2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf'
- '2fbe9ddf40a64f9b80ab3b4868e358ea678b4122742884b7c484041a913757627d1c6b0ee6e2ef46fe90d82e7e29e6332d3b6155d56355d274fdf551f8a8ef70')
+ 'ee41c3d94f16ad34077a84a1bdb49789e5d7979c75abb46970707929627542f7c78e35ae93833b45030ea03ec4ee52f21e410dad37fa967d02d1aeb72f0b5cd8')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds