summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-10-04 13:39:15 +0200
committerPiotr Gorski2019-10-04 13:39:15 +0200
commit8ef1608377cfd916f032f176f725aef558de7b71 (patch)
tree67ebf38d745a48026066a5fcd9883ee2afbacb8c
parentafb3e58b1a783e0004fd3d5991325cecf45da561 (diff)
downloadaur-8ef1608377cfd916f032f176f725aef558de7b71.tar.gz
Sync with Arch
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39de1f507775..6d05ab09a308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bfq
pkgver = 5.3.2
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/sirlucjan/bfq-mq-lucjan
arch = x86_64
license = GPL2
@@ -47,10 +47,10 @@ pkgname = linux-bfq
pkgdesc = The Linux-bfq kernel and modules with the BFQ-dev
install = linux.install
depends = coreutils
- depends = linux-firmware
- depends = mkinitcpio>=0.7
+ depends = kmod
+ depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
- optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
+ optdepends = linux-firmware: firmware images needed for some devices
backup = etc/mkinitcpio.d/linux-bfq.preset
pkgname = linux-bfq-headers
diff --git a/PKGBUILD b/PKGBUILD
index 711166527ac5..c774286360b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,7 +51,7 @@ _major=5.3
_minor=2
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
-pkgrel=4
+pkgrel=5
arch=('x86_64')
url="https://github.com/sirlucjan/bfq-mq-lucjan"
license=('GPL2')
@@ -199,8 +199,9 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the BFQ-dev"
- depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
- optdepends=('crda: to set the correct wireless channels of your country' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -215,6 +216,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install