summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2018-01-17 16:18:42 +0100
committersirlucjan2018-01-17 16:18:42 +0100
commit0aafe372fd84333ce5e7769d81bb209418f92c56 (patch)
tree4f7bd6f9794d5782ef1d006a51fd02a30ecca850
parent814da3cd89d7fea45a3f08609f02a8c102dc8117 (diff)
downloadaur-0aafe372fd84333ce5e7769d81bb209418f92c56.tar.gz
Fixes: don't assume sync-check.sh is executable
-rw-r--r--.SRCINFO4
-rw-r--r--0005-tools-objtool-makefile-don-t-assume-sync-check.sh-is-executable.patch36
-rw-r--r--PKGBUILD15
3 files changed, 48 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdcc2c05e126..8f69b15b92fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bfq-mq
pkgver = 4.14.14
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Algodev-github/bfq-mq/
arch = x86_64
license = GPL2
@@ -34,6 +34,7 @@ pkgbase = linux-bfq-mq
source = 0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
source = 0003-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
source = 0004-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ source = 0005-tools-objtool-makefile-don-t-assume-sync-check.sh-is-executable.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7
@@ -60,6 +61,7 @@ pkgbase = linux-bfq-mq
sha256sums = f723c341df165e1a6280fdbab013b5f4256c429c4de7330f1f162feccf1fb3d7
sha256sums = ec69fb66b2e4baff93ba371c38ff9e7527208203b2b3ab7eea182c274e1201c6
sha256sums = 4b92975a3a961593590c990c0ab731d6ec9ddce30be440dd05f5f31695b97a78
+ sha256sums = 11bbe5a18c86926824b142aa7c3df4bbd05371ed28b8b8e2ec0e505f8589d063
pkgname = linux-bfq-mq
pkgdesc = The Linux-bfq-mq kernel and modules with the BFQ-MQ scheduler
diff --git a/0005-tools-objtool-makefile-don-t-assume-sync-check.sh-is-executable.patch b/0005-tools-objtool-makefile-don-t-assume-sync-check.sh-is-executable.patch
new file mode 100644
index 000000000000..313daf40ebb9
--- /dev/null
+++ b/0005-tools-objtool-makefile-don-t-assume-sync-check.sh-is-executable.patch
@@ -0,0 +1,36 @@
+From 0f908ccbeca99ddf0ad60afa710e72aded4a5ea7 Mon Sep 17 00:00:00 2001
+From: Andrew Morton <akpm@linux-foundation.org>
+Date: Fri, 12 Jan 2018 16:53:17 -0800
+Subject: tools/objtool/Makefile: don't assume sync-check.sh is executable
+
+From: Andrew Morton <akpm@linux-foundation.org>
+
+commit 0f908ccbeca99ddf0ad60afa710e72aded4a5ea7 upstream.
+
+patch(1) loses the x bit. So if a user follows our patching
+instructions in Documentation/admin-guide/README.rst, their kernel will
+not compile.
+
+Fixes: 3bd51c5a371de ("objtool: Move kernel headers/code sync check to a script")
+Reported-by: Nicolas Bock <nicolasbock@gentoo.org>
+Reported-by Joakim Tjernlund <Joakim.Tjernlund@infinera.com>
+Cc: Ingo Molnar <mingo@kernel.org>
+Cc: Josh Poimboeuf <jpoimboe@redhat.com>
+Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
+Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
+Cc: Holger Hoffstätte <holger@applied-asynchrony.com>
+Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+
+---
+ tools/objtool/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/tools/objtool/Makefile
++++ b/tools/objtool/Makefile
+@@ -46,7 +46,7 @@ $(OBJTOOL_IN): fixdep FORCE
+ @$(MAKE) $(build)=objtool
+
+ $(OBJTOOL): $(LIBSUBCMD) $(OBJTOOL_IN)
+- @./sync-check.sh
++ @$(CONFIG_SHELL) ./sync-check.sh
+ $(QUIET_LINK)$(CC) $(OBJTOOL_IN) $(LDFLAGS) -o $@
diff --git a/PKGBUILD b/PKGBUILD
index 06f5fb11bd7b..da991339a8de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -69,7 +69,7 @@ pkgbase=linux-bfq-mq
pkgver=4.14.14
_srcpatch="${pkgver##*\.*\.}"
_srcname="linux-${pkgver%%\.${_srcpatch}}"
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
@@ -133,7 +133,8 @@ source=(# mainline kernel patches
'0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
'0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch'
'0003-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch'
- '0004-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch')
+ '0004-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch'
+ '0005-tools-objtool-makefile-don-t-assume-sync-check.sh-is-executable.patch')
sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
'SKIP'
@@ -158,7 +159,8 @@ sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
'767af9b833ff51e57738356c7895ccfa8d4a8e386759f34ffe92573f2331e5c0'
'f723c341df165e1a6280fdbab013b5f4256c429c4de7330f1f162feccf1fb3d7'
'ec69fb66b2e4baff93ba371c38ff9e7527208203b2b3ab7eea182c274e1201c6'
- '4b92975a3a961593590c990c0ab731d6ec9ddce30be440dd05f5f31695b97a78')
+ '4b92975a3a961593590c990c0ab731d6ec9ddce30be440dd05f5f31695b97a78'
+ '11bbe5a18c86926824b142aa7c3df4bbd05371ed28b8b8e2ec0e505f8589d063')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -189,6 +191,10 @@ prepare() {
msg "Fix #56711"
patch -Np1 -i ../0004-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ ### Fix https://www.spinics.net/lists/stable/msg207374.html
+ msg "Fix execvp: ./sync-check.sh error"
+ patch -Np1 -i ../0005-tools-objtool-makefile-don-t-assume-sync-check.sh-is-executable.patch
+
### Patch source with BFQ-SQ-MQ
msg "Fix patching with 20180109"
patch -Np1 -i ../0009-bfq-sq-mq-fix-patching-error-with-20180109.patch
@@ -224,9 +230,6 @@ prepare() {
### Patch source to enable more gcc CPU optimizatons via the make nconfig
msg "Patch source with gcc patch to enable more cpus types"
patch -Np1 -i ../${_gcc_patch}
-
- # Fix https://www.spinics.net/lists/stable/msg207374.html
- chmod +x tools/objtool/sync-check.sh
# Clean tree and copy ARCH config over
make mrproper