summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-28 00:18:15 +0100
committerPiotr Gorski2018-11-28 00:18:15 +0100
commit5ff458133a40e4f943bb727355e463d86b58b61a (patch)
tree70d730f0e1a5a3e0d55b6ce4e0dd4d473cf3e836
parent9d21f02985066f08867f83afafe6dbb94e3abf3d (diff)
downloadaur-5ff458133a40e4f943bb727355e463d86b58b61a.tar.gz
Make lib/modules/*/vmlinuz a copy instead of a link
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--90-linux.hook2
-rw-r--r--99-linux.hook2
-rw-r--r--PKGBUILD19
-rw-r--r--linux.install1
5 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8d286f57a51..3c24f3cab345 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bfq-mq
pkgver = 4.19.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Algodev-github/bfq-mq/
arch = x86_64
license = GPL2
@@ -30,8 +30,8 @@ pkgbase = linux-bfq-mq
sha256sums = eb3cb1a9e487c54346b798b57f5b505f8a85fd1bc839d8f00b2925e6a7d74531
sha256sums = 1baeb84a779bde01ebf748fc7a86a3643df264a3edf22eac333e880877ab40fc
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
- sha256sums = 5f6ba52aaa528c4fa4b1dc097e8930fad0470d7ac489afcb13313f289ca32184
+ sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
+ sha256sums = 9a8584660c399a6f0c62fc47572ea3f801c08aac50caab2557ce094119ba4195
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
sha256sums = 37c115ad797afc7e47615dc56c6416932b6645e16da097ddcfa401df41a31248
diff --git a/90-linux.hook b/90-linux.hook
index be0d886539f4..fca45abe1a62 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,7 +2,7 @@
Type = File
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/99-linux.hook b/99-linux.hook
index 036f6bf2534a..138b911b6794 100644
--- a/99-linux.hook
+++ b/99-linux.hook
@@ -1,7 +1,7 @@
[Trigger]
Type = File
Operation = Remove
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
[Action]
Description = Remove %PKGBASE% initramfs files...
diff --git a/PKGBUILD b/PKGBUILD
index 2d75bf3495c2..887f9100e3f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -65,7 +65,7 @@ _major=4.19
pkgver=4.19.5
_srcpatch="${pkgver}"
_srcname="linux-${pkgver}"
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
@@ -108,8 +108,8 @@ sha256sums=('8c839ec29cce7eb0e8ef7eaa10d1eb9d84d2be2521e352fb4f9414e76856ef75'
'eb3cb1a9e487c54346b798b57f5b505f8a85fd1bc839d8f00b2925e6a7d74531'
'1baeb84a779bde01ebf748fc7a86a3643df264a3edf22eac333e880877ab40fc'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
- '5f6ba52aaa528c4fa4b1dc097e8930fad0470d7ac489afcb13313f289ca32184'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
+ '9a8584660c399a6f0c62fc47572ea3f801c08aac50caab2557ce094119ba4195'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'37c115ad797afc7e47615dc56c6416932b6645e16da097ddcfa401df41a31248')
validpgpkeys=(
@@ -266,22 +266,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/linux.install b/linux.install
index 95860e414f7e..f7bdeb92e69e 100644
--- a/linux.install
+++ b/linux.install
@@ -4,3 +4,4 @@ post_upgrade() {
fi
}
+# vim:set ft=sh ts=8 sts=2 sw=2 et: