summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-08-17 21:37:38 +0200
committerPiotr Gorski2018-08-17 21:37:38 +0200
commit8897b1481e82d86cd71cba862f16b5d45d3452c5 (patch)
tree1442769ce6dd01668661858f34d45c3692e22679
parent4f70376ab0c9198f97df372bb88233093674d6a2 (diff)
downloadaur-8897b1481e82d86cd71cba862f16b5d45d3452c5.tar.gz
Bump to 4.18.2-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD7
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 142acf99a254..d941c9ef7408 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bfq-mq
- pkgver = 4.18.1
+ pkgver = 4.18.2
pkgrel = 1
url = https://github.com/Algodev-github/bfq-mq/
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = linux-bfq-mq
makedepends = bc
makedepends = libelf
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.18.1.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.18.1.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.18.2.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.18.2.tar.sign
source = https://raw.githubusercontent.com/graysky2/kernel_gcc_patch/master/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/4.18/bfq-sq-mq/4.18-bfq-sq-mq-v8r12-2K180816.patch
source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/4.18/0100-Check-presence-on-tree-of-every-entity-after-every-a.patch
@@ -22,7 +22,7 @@ pkgbase = linux-bfq-mq
source = 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
source = 0002-Increase-timeout-in-lspcon_wait_mode.patch
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 725fadc6e9d5a1ad6d7269bb75b256bccac5372927995ad0408c059d110cfa42
+ sha256sums = d56082dd9d895c32ab5d898096abb3e7f5525bb0a603e5c3be9f83921484eda5
sha256sums = SKIP
sha256sums = 9f7177679c8d3f8d699ef0566a51349d828436dba04603bc2223f98c60d2d178
sha256sums = c054840ef3df56d5b3ce574c5bf158b10a41bab4a1edc48a50b5b97c2f12b751
@@ -44,19 +44,19 @@ pkgname = linux-bfq-mq
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
- provides = linux-bfq-mq=4.18.1
- provides = linux=4.18.1
+ provides = linux-bfq-mq=4.18.2
+ provides = linux=4.18.2
backup = etc/mkinitcpio.d/linux-bfq-mq.preset
pkgname = linux-bfq-mq-headers
pkgdesc = Header files and scripts for building modules for Linux-bfq-mq kernel
- depends = linux-bfq-mq=4.18.1
- provides = linux-bfq-mq-headers=4.18.1
- provides = linux-headers=4.18.1
+ depends = linux-bfq-mq=4.18.2
+ provides = linux-bfq-mq-headers=4.18.2
+ provides = linux-headers=4.18.2
pkgname = linux-bfq-mq-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bfq-mq kernel
- depends = linux-bfq-mq=4.18.1
- provides = linux-bfq-mq-docs=4.18.1
- provides = linux-docs=4.18.1
+ depends = linux-bfq-mq=4.18.2
+ provides = linux-bfq-mq-docs=4.18.2
+ provides = linux-docs=4.18.2
diff --git a/PKGBUILD b/PKGBUILD
index c5ce8579a63c..9bbb4f2d1fb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,7 +60,7 @@ _1k_HZ_ticks=
pkgbase=linux-bfq-mq
#pkgbase=linux-custom # Build kernel with a different name
_major=4.18
-pkgver=4.18.1
+pkgver=4.18.2
_srcpatch="${pkgver}"
_srcname="linux-${pkgver}"
pkgrel=1
@@ -100,7 +100,7 @@ source=(# mainline kernel patches
'0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
'0002-Increase-timeout-in-lspcon_wait_mode.patch')
-sha256sums=('725fadc6e9d5a1ad6d7269bb75b256bccac5372927995ad0408c059d110cfa42'
+sha256sums=('d56082dd9d895c32ab5d898096abb3e7f5525bb0a603e5c3be9f83921484eda5'
'SKIP'
'9f7177679c8d3f8d699ef0566a51349d828436dba04603bc2223f98c60d2d178'
'c054840ef3df56d5b3ce574c5bf158b10a41bab4a1edc48a50b5b97c2f12b751'
@@ -276,7 +276,8 @@ _package() {
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
- make INSTALL_MOD_PATH="$pkgdir/usr" DEPMOD=/doesnt/exist modules_install
+ # make INSTALL_MOD_PATH="$pkgdir/usr" DEPMOD=/doesnt/exist modules_install
+ make INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
# a place for external modules,
# with version file for building modules and running depmod from hook