summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-08-17 23:22:17 +0200
committerPiotr Gorski2018-08-17 23:22:17 +0200
commitb47b3a055d9f71d898c99c9ca555f20bd63086ac (patch)
treebf787f7e729e3f0df9c3d3544e7e68cd4b95d51f
parent3c6c17eafa576fbf9bf4653293977ba1a3ccf043 (diff)
downloadaur-b47b3a055d9f71d898c99c9ca555f20bd63086ac.tar.gz
Drop depmod hack
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3df378e7ec5..72da6703ea0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -276,8 +276,7 @@ _package() {
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
- # make INSTALL_MOD_PATH="$pkgdir/usr" DEPMOD=/doesnt/exist modules_install
- make INSTALL_MOD_PATH="${pkgdir}/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
# a place for external modules,
# with version file for building modules and running depmod from hook
@@ -289,9 +288,6 @@ _package() {
# remove build and source links
rm "$modulesdir"/{source,build}
- msg2 "Running depmod..."
- depmod -b "$pkgdir/usr" -E Module.symvers -e "$kernver"
-
msg2 "Installing hooks..."
# sed expression for following substitutions