summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-04-13 16:06:10 +0200
committerPiotr Gorski2019-04-13 16:06:10 +0200
commitdc76edbdc40aa18f39baaf6330e4200a9ac9b0c2 (patch)
tree0580750ee60e16f5b166e58b1b84a54aeb138798
parentfb0ee5e2fbb619ab8ed3b984d5755e56620ff48f (diff)
downloadaur-dc76edbdc40aa18f39baaf6330e4200a9ac9b0c2.tar.gz
Revert FS#59688 - Install HTML docs
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 4 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45c91d9cdf61..06e278f7d891 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bfq-mq
pkgver = 4.20.17
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Algodev-github/bfq-mq/
arch = x86_64
license = GPL2
@@ -8,8 +8,6 @@ pkgbase = linux-bfq-mq
makedepends = inetutils
makedepends = bc
makedepends = libelf
- makedepends = python-sphinx
- makedepends = graphviz
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.20.17.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.20.17.tar.sign
diff --git a/PKGBUILD b/PKGBUILD
index e3fdaf1d82c3..e94ab3c71f04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,11 +63,11 @@ _major=4.20
pkgver=4.20.17
_srcpatch="${pkgver}"
_srcname="linux-${pkgver}"
-pkgrel=4
+pkgrel=5
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
-makedepends=('kmod' 'inetutils' 'bc' 'libelf' 'python-sphinx' 'graphviz')
+makedepends=('kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
_bfqpath="https://gitlab.com/tom81094/custom-patches/raw/master/bfq-mq"
_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_major}"
@@ -254,7 +254,7 @@ prepare() {
build() {
cd ${_srcname}
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -415,15 +415,6 @@ _package-docs() {
msg2 "Removing doctrees..."
rm -r "$builddir/Documentation/output/.doctrees"
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"