summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-07-28 19:46:03 +0200
committerPiotr Gorski2018-07-28 19:46:03 +0200
commite4276dea3c200ed0b7d85a088ea866749a92ba77 (patch)
tree469f7efaa06a5229e02b033aadab5a022d6cf3ef
parent3caaf3d470b7fd66095300de82f4b3bdf6a6040e (diff)
downloadaur-e4276dea3c200ed0b7d85a088ea866749a92ba77.tar.gz
Bump to 4.17.11-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 522687e28ea2..09fef0c1e64a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bfq-mq
- pkgver = 4.17.10
+ pkgver = 4.17.11
pkgrel = 1
url = https://github.com/Algodev-github/bfq-mq/
arch = x86_64
@@ -10,10 +10,8 @@ pkgbase = linux-bfq-mq
makedepends = bc
makedepends = libelf
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.17.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.17.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.17.10.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.17.10.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.17.11.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.17.11.tar.sign
source = kernel_gcc_patch-20180509.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/20180509.tar.gz
source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/4.17/bfq-sq-mq/4.17-bfq-sq-mq-v8r12-2K180625.patch
source = https://gitlab.com/sirlucjan/kernel-patches/raw/master/4.17/0100-Check-presence-on-tree-of-every-entity-after-every-a.patch
@@ -26,11 +24,8 @@ pkgbase = linux-bfq-mq
source = 0002-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
source = 0003-ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch
source = 0004-mac80211-disable-BHs-preemption-in-ieee80211_tx_cont.patch
- validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13
- sha256sums = SKIP
- sha256sums = 41ad005296c7a1b5245a87881f666b3f4d7aa05a6b9409454b2e473d473c4cee
+ sha256sums = db1e84ed4f213b43d50f3373627b2ffcdb3b65f3430f746a38f801554ef3728c
sha256sums = SKIP
sha256sums = 226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d
sha256sums = 7fa085ae8c7839fe22257bdebfcd1dfb1e60c40e61157972c349634c122ed086
@@ -54,19 +49,19 @@ pkgname = linux-bfq-mq
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
- provides = linux-bfq-mq=4.17.10
- provides = linux=4.17.10
+ provides = linux-bfq-mq=4.17.11
+ provides = linux=4.17.11
backup = etc/mkinitcpio.d/linux-bfq-mq.preset
pkgname = linux-bfq-mq-headers
pkgdesc = Header files and scripts for building modules for Linux-bfq-mq kernel
- depends = linux-bfq-mq=4.17.10
- provides = linux-bfq-mq-headers=4.17.10
- provides = linux-headers=4.17.10
+ depends = linux-bfq-mq=4.17.11
+ provides = linux-bfq-mq-headers=4.17.11
+ provides = linux-headers=4.17.11
pkgname = linux-bfq-mq-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bfq-mq kernel
- depends = linux-bfq-mq=4.17.10
- provides = linux-bfq-mq-docs=4.17.10
- provides = linux-docs=4.17.10
+ depends = linux-bfq-mq=4.17.11
+ provides = linux-bfq-mq-docs=4.17.11
+ provides = linux-docs=4.17.11
diff --git a/PKGBUILD b/PKGBUILD
index b8f88d0c395b..cd76786c072d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -62,9 +62,10 @@ _1k_HZ_ticks=
pkgbase=linux-bfq-mq
#pkgbase=linux-custom # Build kernel with a different name
-pkgver=4.17.10
-_srcpatch="${pkgver##*\.*\.}"
-_srcname="linux-${pkgver%%\.${_srcpatch}}"
+_major=4.17
+pkgver=4.17.11
+_srcpatch="${pkgver}"
+_srcname="linux-${pkgver}"
pkgrel=1
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
@@ -81,13 +82,11 @@ _gcc_patch="enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patc
_bfq_sq_mq_path="bfq-sq-mq"
_bfq_sq_mq_ver='v8r12'
_bfq_sq_mq_rel='2K180625'
-_bfq_sq_mq_patch="${pkgver%%\.${_srcpatch}}-bfq-sq-mq-${_bfq_sq_mq_ver}-${_bfq_sq_mq_rel}.patch"
+_bfq_sq_mq_patch="${_major}-bfq-sq-mq-${_bfq_sq_mq_ver}-${_bfq_sq_mq_rel}.patch"
source=(# mainline kernel patches
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.sign"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
- "https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.sign"
# gcc cpu optimizatons from graysky and ck
"${_gcc_name}-${_gcc_rel}.tar.gz::${_gcc_path}/${_gcc_rel}.tar.gz"
# bfq-mq patch
@@ -108,9 +107,7 @@ source=(# mainline kernel patches
'0003-ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch'
'0004-mac80211-disable-BHs-preemption-in-ieee80211_tx_cont.patch')
-sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
- 'SKIP'
- '41ad005296c7a1b5245a87881f666b3f4d7aa05a6b9409454b2e473d473c4cee'
+sha256sums=('db1e84ed4f213b43d50f3373627b2ffcdb3b65f3430f746a38f801554ef3728c'
'SKIP'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'7fa085ae8c7839fe22257bdebfcd1dfb1e60c40e61157972c349634c122ed086'
@@ -125,7 +122,6 @@ sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
'bc50c605bd0e1fa7437c21ddef728b83b6de3322b988e14713032993dfa1fc69'
'66284102261c4ed53db050e9045c8672ba0e5171884b46e58f6cd417774d8578')
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
@@ -134,10 +130,6 @@ _kernelname=${pkgbase#linux}
prepare() {
cd ${_srcname}
-
- ### Add upstream patch
- msg "Add upstream patch"
- patch -p1 -i ../patch-${pkgver}
### Disable USER_NS for non-root users by default
msg "Disable USER_NS for non-root users by default"