summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-28 00:20:15 +0100
committerPiotr Gorski2018-11-28 00:20:15 +0100
commit07404c86e29761034aad78a662de57123ac334e3 (patch)
tree7855c4939d567d2218e99a0ec0de26382e534b38
parent7f51b1bec1b1fbdfe86059e19d0d88ade7da5869 (diff)
downloadaur-07404c86e29761034aad78a662de57123ac334e3.tar.gz
Make lib/modules/*/vmlinuz a copy instead of a link
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--90-linux.hook2
-rw-r--r--99-linux.hook2
-rw-r--r--PKGBUILD17
-rw-r--r--linux.install1
5 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae5326143f95..bac509b69b98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,8 +25,8 @@ pkgbase = linux-bfq-mq-git
sha256sums = eb3cb1a9e487c54346b798b57f5b505f8a85fd1bc839d8f00b2925e6a7d74531
sha256sums = 353fad0d0363c32c343dde215de4a22c38fbc748df70560b98c2f2c2e98b3c1c
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
- sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
- sha256sums = 5f6ba52aaa528c4fa4b1dc097e8930fad0470d7ac489afcb13313f289ca32184
+ sha256sums = c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636
+ sha256sums = 9a8584660c399a6f0c62fc47572ea3f801c08aac50caab2557ce094119ba4195
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
pkgname = linux-bfq-mq-git
diff --git a/90-linux.hook b/90-linux.hook
index be0d886539f4..fca45abe1a62 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,7 +2,7 @@
Type = File
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/99-linux.hook b/99-linux.hook
index 036f6bf2534a..138b911b6794 100644
--- a/99-linux.hook
+++ b/99-linux.hook
@@ -1,7 +1,7 @@
[Trigger]
Type = File
Operation = Remove
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
[Action]
Description = Remove %PKGBASE% initramfs files...
diff --git a/PKGBUILD b/PKGBUILD
index fbab2ce520ff..9ff9f20e8093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -96,8 +96,8 @@ sha256sums=('SKIP'
'eb3cb1a9e487c54346b798b57f5b505f8a85fd1bc839d8f00b2925e6a7d74531'
'353fad0d0363c32c343dde215de4a22c38fbc748df70560b98c2f2c2e98b3c1c'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
- '5f6ba52aaa528c4fa4b1dc097e8930fad0470d7ac489afcb13313f289ca32184'
+ 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
+ '9a8584660c399a6f0c62fc47572ea3f801c08aac50caab2557ce094119ba4195'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
_kernelname=${pkgbase#linux}
@@ -257,22 +257,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/linux.install b/linux.install
index 95860e414f7e..f7bdeb92e69e 100644
--- a/linux.install
+++ b/linux.install
@@ -4,3 +4,4 @@ post_upgrade() {
fi
}
+# vim:set ft=sh ts=8 sts=2 sw=2 et: