summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-04-13 16:08:12 +0200
committerPiotr Gorski2019-04-13 16:08:12 +0200
commit189ea813b2651a7856cda48536b2461ac8c4a957 (patch)
treef3545ab1cf27ffd3e1b93003798298221b731ef3
parentdc16968fe72c2e771397c2df1e8c0ce82fec12f1 (diff)
downloadaur-189ea813b2651a7856cda48536b2461ac8c4a957.tar.gz
Revert FS#59688 - Install HTML docs
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 5 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 087c64e71971..c9e07a290034 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bfq-mq-git
pkgver = 4.18.0.g8687d94c3344
- pkgrel = 1
+ pkgrel = 2
url = http://www.kernel.org/
arch = x86_64
license = GPL2
@@ -9,8 +9,6 @@ pkgbase = linux-bfq-mq-git
makedepends = bc
makedepends = git
makedepends = libelf
- makedepends = python-sphinx
- makedepends = graphviz
options = !strip
source = git+https://github.com/Algodev-github/bfq-mq
source = https://raw.githubusercontent.com/graysky2/kernel_gcc_patch/master/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
diff --git a/PKGBUILD b/PKGBUILD
index c1ff04d93922..7e6e1c6cf20b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,11 +61,11 @@ _mq_enable=
pkgbase=linux-bfq-mq-git
_srcname=bfq-mq
pkgver=4.18.0.g8687d94c3344
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://www.kernel.org/"
license=('GPL2')
-makedepends=('kmod' 'inetutils' 'bc' 'git' 'libelf' 'python-sphinx' 'graphviz')
+makedepends=('kmod' 'inetutils' 'bc' 'git' 'libelf')
options=('!strip')
_bfqpath="https://gitlab.com/tom81094/custom-patches/raw/master/bfq-mq"
_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/4.17"
@@ -244,9 +244,9 @@ prepare() {
build() {
cd ${_srcname}
- make bzImage modules htmldocs
+ make bzImage modules
}
-
+
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the BFQ-MQ scheduler"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
@@ -405,18 +405,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"