summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-22 20:45:37 +0100
committerPiotr Gorski2018-11-22 20:45:37 +0100
commit8deb2e129eee935cf9192884c6ea8c76184130df (patch)
tree0e0dfa4b855e0383de086bd1cbac1a26ea8c541f
parent6c002ad95128edfaa71242b636020bc550026766 (diff)
downloadaur-8deb2e129eee935cf9192884c6ea8c76184130df.tar.gz
Add vmlinuz symlink for systemd
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 262a55c8f367..699cd7d1948c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -261,12 +261,17 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
- make INSTALL_MOD_PATH="$pkgdir/usr" DEPMOD=/doesnt/exist modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
# a place for external modules,
# with version file for building modules and running depmod from hook