summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-12-02 18:49:07 +0100
committerPiotr Gorski2018-12-02 18:49:07 +0100
commita7a1080327dc3dd310acb7b375d7aa28a402ab10 (patch)
tree36ac7098befd445b5387d1ab4daebaab3b7015bd
parent06e5a729e0edd9305b744dd7f5b3022ac10dad0b (diff)
downloadaur-a7a1080327dc3dd310acb7b375d7aa28a402ab10.tar.gz
Improve localmodcfg
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0d786a7903e..9e6480478322 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,9 +29,7 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
-# begin making the pkg unless you're running modprobed-db (AUR) and building
-# this with makepkg as the user who is keeping the database.
+# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -230,11 +228,12 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
- msg2 "Running Steven Rostedt's make localmodconfig now"
+ msg2 "If you have modprobed-db installed, running it in recall mode now"
+ if [ -e /usr/bin/modprobed-db ]; then
+ [[ -x /usr/bin/sudo ]] || {
+ echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
+ exit 1; }
+ sudo /usr/bin/modprobed-db recall
make localmodconfig
fi
fi