summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFigue2017-01-08 16:10:41 +0100
committerFigue2017-01-08 16:10:41 +0100
commitb8a7a9ab70d766adb51faac2209632250fbaa329 (patch)
tree87e50b2ea009ca62eb413d68414a8edda6918f13
parent2502888b731245d3cb7f18696d5529634e95248e (diff)
downloadaur-b8a7a9ab70d766adb51faac2209632250fbaa329.tar.gz
Update bfq to v8r7
-rw-r--r--.SRCINFO8
-rw-r--r--0005-BFQ-Fix.patch33
-rw-r--r--0006-BFQ-Fix.patch24
-rw-r--r--PKGBUILD9
4 files changed, 7 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd355cfdd757..402b1b056800 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bld
pkgver = 4.8.16
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rmullick/linux
arch = i686
arch = x86_64
@@ -28,8 +28,7 @@ pkgbase = linux-bld
source = http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.8.0-v8r4/0002-block-introduce-the-BFQ-v7r11-I-O-sched-to-be-ported.patch
source = http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.8.0-v8r4/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-v7r11-to-.patch
source = http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.8.0-v8r4/0004-Turn-BFQ-v7r11-into-BFQ-v8r4-for-4.8.0.patch
- source = 0005-BFQ-Fix.patch
- source = 0006-BFQ-Fix.patch
+ source = https://raw.githubusercontent.com/sirlucjan/aur/master/linux-bfq/0005-BFQ-update-to-v8r7.patch
source = https://raw.githubusercontent.com/rmullick/bld-patches/master/BLD-4.8.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
@@ -49,8 +48,7 @@ pkgbase = linux-bld
sha256sums = c8d17a7893d5780fd0c90311470160dcc842b81621b30671150e2e3224be86d2
sha256sums = e47ea5b1c2f20cfade4e6a85bff1320dac84ac638e48ef4eec7285fe9e1e1def
sha256sums = c3c96e304aef378f0cc6e1fb18eeabe176e6ba918d13060c105f3d8cabc85f59
- sha256sums = bc3177e6026a7363d6190e8b7446005aec38801292602344131ad4e3e67813cb
- sha256sums = e2eae358c5417b3ab33abdaf965fb997c615cdbd2cbe7a750526c040374da006
+ sha256sums = cf440c1156a6d4ff8060dd4393297c8ffc5417f1f7cd21007370b8e94a4790c0
sha256sums = 16a5d04bbd76d2dc79473b83af434aa54a72f41f0677823c0381762f75ccb33c
pkgname = linux-bld
diff --git a/0005-BFQ-Fix.patch b/0005-BFQ-Fix.patch
deleted file mode 100644
index ad66ca69a2ba..000000000000
--- a/0005-BFQ-Fix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 69f18bb587a4805b2b18bb4ba91dced87a8fda06 Mon Sep 17 00:00:00 2001
-From: Paolo Valente <paolo.valente@linaro.org>
-Date: Sat, 22 Oct 2016 15:26:33 +0200
-Subject: [PATCH 86/86] BUGFIX: Replace max wrongly used for modulo numbers
-
-Signed-off-by: Paolo Valente <paolo.valente@linaro.org>
----
- block/bfq-iosched.c | 10 +++++++---
- 1 file changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/block/bfq-iosched.c b/block/bfq-iosched.c
-index eef6ff4..c161ff0 100644
---- a/block/bfq-iosched.c
-+++ b/block/bfq-iosched.c
-@@ -2179,9 +2179,13 @@ static void __bfq_set_in_service_queue(struct bfq_data *bfqd,
- * not only expires, but also remains with no
- * request.
- */
-- bfqq->last_wr_start_finish += jiffies -
-- max_t(unsigned long, bfqq->last_wr_start_finish,
-- bfqq->budget_timeout);
-+ if (time_after(bfqq->budget_timeout,
-+ bfqq->last_wr_start_finish))
-+ bfqq->last_wr_start_finish +=
-+ jiffies - bfqq->budget_timeout;
-+ else
-+ bfqq->last_wr_start_finish = jiffies;
-+
- if (time_is_after_jiffies(bfqq->last_wr_start_finish)) {
- pr_crit(
- "BFQ WARNING:last %lu budget %lu jiffies %lu",
-Contact GitHub API Training Shop Blog About
-
diff --git a/0006-BFQ-Fix.patch b/0006-BFQ-Fix.patch
deleted file mode 100644
index fa361f2778e5..000000000000
--- a/0006-BFQ-Fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 69f18bb587a4805b2b18bb4ba91dced87a8fda06 Mon Sep 17 00:00:00 2001
-From: Paolo Valente <paolo.valente@linaro.org>
-Date: Sat, 22 Oct 2016 15:26:33 +0200
-Subject: [PATCH 86/86] BUGFIX: Remove wrong conversion in use of bfq_fifo_expirebug
-
-Signed-off-by: Paolo Valente <paolo.valente@linaro.org>
----
- block/bfq-iosched.c | 3 +--
- 1 file changed, 1 insertions(+), 2 deletions(-)
-
-diff --git a/block/bfq-iosched.c b/block/bfq-iosched.c
-index eef6ff4..c161ff0 100644
---- a/block/bfq-iosched.c
-+++ b/block/bfq-iosched.c
-@@ -4268,8 +4268,7 @@
-
- bfq_add_request(rq);
-
-- rq->fifo_time = ktime_get_ns() +
-- jiffies_to_nsecs(bfqd->bfq_fifo_expire[rq_is_sync(rq)]);
-+ rq->fifo_time = ktime_get_ns() + bfqd->bfq_fifo_expire[rq_is_sync(rq)];
- list_add_tail(&rq->queuelist, &bfqq->fifo);
-
- bfq_rq_enqueued(bfqd, bfqq, rq);
diff --git a/PKGBUILD b/PKGBUILD
index 62648dd3610e..677f2996bf94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _kernelname=-bld
pkgver=4.8.16
_srcname=linux-4.8
_pkgver2=${_srcname#*-}.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="https://github.com/rmullick/linux"
license=('GPL2')
@@ -38,8 +38,8 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"${_bfqpath}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${_bfqversion_old}-to-.patch"
"${_bfqpath}/0004-Turn-BFQ-${_bfqversion_old}-into-BFQ-${_bfqversion}-for-${_pkgver2}.patch"
# patches from https://github.com/linusw/linux-bfq/commits/bfq-v8
- '0005-BFQ-Fix.patch'
- '0006-BFQ-Fix.patch'
+ "https://raw.githubusercontent.com/sirlucjan/aur/master/linux-bfq/0005-BFQ-update-to-v8r7.patch"
+ # main BLD patch
"https://raw.githubusercontent.com/rmullick/bld-patches/master/${_BLDpatch}"
)
@@ -59,8 +59,7 @@ sha256sums=('3e9150065f193d3d94bcf46a1fe9f033c7ef7122ab71d75a7fb5a2f0c9a7e11a'
'c8d17a7893d5780fd0c90311470160dcc842b81621b30671150e2e3224be86d2'
'e47ea5b1c2f20cfade4e6a85bff1320dac84ac638e48ef4eec7285fe9e1e1def'
'c3c96e304aef378f0cc6e1fb18eeabe176e6ba918d13060c105f3d8cabc85f59'
- 'bc3177e6026a7363d6190e8b7446005aec38801292602344131ad4e3e67813cb'
- 'e2eae358c5417b3ab33abdaf965fb997c615cdbd2cbe7a750526c040374da006'
+ 'cf440c1156a6d4ff8060dd4393297c8ffc5417f1f7cd21007370b8e94a4790c0'
'16a5d04bbd76d2dc79473b83af434aa54a72f41f0677823c0381762f75ccb33c')
validpgpkeys=(