summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Leclerc2023-08-22 11:25:52 +0000
committerCharles Leclerc2023-08-22 11:25:52 +0000
commit165f3f0961afda8506cde2c9b5f67e8df6e19888 (patch)
treec2bcf4deb84aedfeecf29fffbda7321064dea979
parent8ca06f0ecfdbaca5b20cc24f4689764f25d6b5de (diff)
downloadaur-165f3f0961afda8506cde2c9b5f67e8df6e19888.tar.gz
Updated build script
-rwxr-xr-xupdate.sh11
1 files changed, 7 insertions, 4 deletions
diff --git a/update.sh b/update.sh
index a73b02bd7782..d761a9e1c114 100755
--- a/update.sh
+++ b/update.sh
@@ -48,7 +48,10 @@ if [ "${initial}x" = "x" ] ; then
cp {config,PKGBUILD} ..
cd ..
- sed -i -e 's/^pkgbase=.*/pkgbase=linux-bnx2x-2.5g/' \
+ sed -i -e 's/# Maintainer/# Contributor/' \
+ -e '1s/^/# Maintainer: Charles Leclerc <charles@la-mouette.net>\n/' \
+ -e 's/^pkgbase=.*/pkgbase=linux-bnx2x-2.5g/' \
+ -e '/pkgdesc=/s/"$/ with 2.5G patch for bnx2x module"/' \
-e '/\s*# htmldocs/,/^)/{/^)/!d;}' \
-e '/^source=/{N;s/$/\n "bnx2x_warpcore+8727_2_5g_sgmii_arch.patch"/}' \
-e "/^b2sums=/{s/$/\n '94fd2e2fa31da0ce9d04e639b0fafc37128ad2f01f8ee38708c7128fdc1568e491aca9a8296316b0736f134dc7697b573e8203018d92c1e9b6ff40648501607a'/}" \
@@ -69,10 +72,10 @@ else
time (makepkg --skippgpcheck -CcLm | tee $s_dir/build.log)
fi
-mkdir -p repo
+mkdir -p ../repo
for p in *.pkg.tar.zst; do
- mv $p repo
- repo-add -q -R repo/bnx2x-2.5g.db.tar.zst repo/$p
+ mv $p ../repo
+ repo-add -q -R ../repo/bnx2x-2.5g.db.tar.zst ../repo/$p
done
if [ "${initial}x" = "x" ] ; then