summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Leclerc2022-11-21 21:36:03 +0000
committerCharles Leclerc2022-11-21 21:36:03 +0000
commit4a055883a71d87bfa52a8fedc524a7c5ef932ca8 (patch)
treefcff710cd10825f028f731afd3c69110187c103e
parentd2dc3abee549247772b03faa66f2457ff7dc159c (diff)
downloadaur-4a055883a71d87bfa52a8fedc524a7c5ef932ca8.tar.gz
Released 6.0.9.arch1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdate.sh62
3 files changed, 50 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89b06d1f49a6..dbddea21216e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = linux-bnx2x-2.5g
pkgdesc = Linux
- pkgver = 6.0.8.arch1
+ pkgver = 6.0.9.arch1
pkgrel = 1
- url = https://github.com/archlinux/linux/commits/v6.0.8-arch1
+ url = https://github.com/archlinux/linux/commits/v6.0.9-arch1
arch = x86_64
license = GPL2
makedepends = bc
@@ -14,7 +14,7 @@ pkgbase = linux-bnx2x-2.5g
makedepends = xz
makedepends = git
options = !strip
- source = archlinux-linux::git+https://github.com/archlinux/linux?signed#tag=v6.0.8-arch1
+ source = archlinux-linux::git+https://github.com/archlinux/linux?signed#tag=v6.0.9-arch1
source = bnx2x_warpcore+8727_2_5g_sgmii_arch.patch
source = config
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
diff --git a/PKGBUILD b/PKGBUILD
index 0713dffde67c..0bf5a4aa971f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-bnx2x-2.5g
-pkgver=6.0.8.arch1
+pkgver=6.0.9.arch1
pkgrel=1
pkgdesc='Linux'
_srctag=v${pkgver%.*}-${pkgver##*.}
@@ -154,7 +154,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
diff --git a/update.sh b/update.sh
index 4e698c48f79a..dd1793b33d6e 100755
--- a/update.sh
+++ b/update.sh
@@ -2,53 +2,81 @@
set -eo pipefail
+usage() { echo -e "Usage: $0 [-f] [-c]\n -i : inital build\n -c : run in cron mode" 1>&2; exit 1; }
+
+cron=
+initial=
+
+while getopts ":ic" o; do
+ case $o in
+ i)
+ initial=y
+ ;;
+ c)
+ cron=y
+ ;;
+ *)
+ usage
+ ;;
+ esac
+done
+
s_dir="$( cd -- "$( dirname -- "${BASH_SOURCE[0]}" )" &> /dev/null && pwd )"
cd $s_dir
l_ver=`grep ^pkgver= PKGBUILD | cut -d= -f2`
if [ ! -d arch-package ] ; then
- git clone --single-branch --branch packages/linux https://github.com/archlinux/svntogit-packages.git arch-package
+ git clone -q --single-branch --branch packages/linux https://github.com/archlinux/svntogit-packages.git arch-package
cd arch-package
else
cd arch-package
git checkout -q packages/linux
git pull -q
fi
+
c_ver=`grep ^pkgver= repos/core-x86_64/PKGBUILD | cut -d= -f2`
n_ver=`echo -e "$c_ver\n$l_ver" | sort -rV | head -n 1`
-if [ $n_ver = $l_ver ] ; then
+if [ $n_ver = $l_ver -a "${initial}x" = "x" ] ; then
exit
fi
-echo "New version available: $c_ver (last build is $l_ver)"
+if [ "${initial}x" = "x" ] ; then
+ echo "New version available: $c_ver (last build is $l_ver)"
+ cp repos/core-x86_64/{config,PKGBUILD} ..
+ cd ..
-cp repos/core-x86_64/{config,PKGBUILD} ..
-cd ..
+ sed -i -e "s/^pkgbase=.*/pkgbase=linux-bnx2x-2.5g/" PKGBUILD
+ sed -i -e '/^makedepends=/{N;n;d}' PKGBUILD
+ sed -i -e '/^source=/{N;s/$/\n "bnx2x_warpcore+8727_2_5g_sgmii_arch.patch"/}' PKGBUILD
+ sed -i -e "/^sha256sums=/{s/$/\\n 'd655669179109ae8e801a259c35dbe442ca67a49b9ceb6ca3ef0e56f48149a7d'/}" PKGBUILD
+ sed -i -e "s/^ make htmldocs all.*/ make all/" PKGBUILD
+ sed -i -e '/^_package-docs() {/,/^}/d' PKGBUILD
+ sed -i -e '/^pkgname=/s/ "$pkgbase-docs"//' PKGBUILD
+else
+ cd ..
+ echo "Building version $c_ver (initial)"
+fi
-sed -i -e "s/^pkgbase=.*/pkgbase=linux-bnx2x-2.5g/" PKGBUILD
-sed -i -e '/^makedepends=/{N;n;d}' PKGBUILD
-sed -i -e '/^source=/{N;s/$/\n "bnx2x_warpcore+8727_2_5g_sgmii_arch.patch"/}' PKGBUILD
-sed -i -e "/^sha256sums=/{s/$/\\n 'd655669179109ae8e801a259c35dbe442ca67a49b9ceb6ca3ef0e56f48149a7d'/}" PKGBUILD
-sed -i -e "s/^ make htmldocs all.*/ make all/" PKGBUILD
-sed -i -e '/^_package-docs() {/,/^}/d' PKGBUILD
-sed -i -e '/^pkgname=/s/ "$pkgbase-docs"//' PKGBUILD
echo "Building package"
-if [ "$1" = "--cron" ] ; then
+if [ "${cron}x" = "yx" ] ; then
time (makepkg --skippgpcheck -CcLm > $s_dir/build.log)
else
time (makepkg --skippgpcheck -CcLm | tee $s_dir/build.log)
fi
+mkdir -p repo
for p in *.pkg.tar.zst; do
mv $p repo
repo-add -q -R repo/bnx2x-2.5g.db.tar.zst repo/$p
done
-makepkg --printsrcinfo > .SRCINFO
-git add PKGBUILD config .SRCINFO
-git commit -m "Released $c_ver"
-git push -q
+if [ "${initial}x" = "x" ] ; then
+ makepkg --printsrcinfo > .SRCINFO
+ git add PKGBUILD config .SRCINFO
+ git commit -m "Released $c_ver"
+ git push -q
+fi