summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacksky32023-07-09 18:57:46 -0400
committerblacksky32023-07-09 18:57:46 -0400
commit52ea7d24b45ae23756f23b402adb909928d279c9 (patch)
tree976ef3ece19e5a88f5dda8492e44ec5ae361a001
parent5b4589701d325bf0fc7fd7bf785cfa7aa684acb8 (diff)
downloadaur-52ea7d24b45ae23756f23b402adb909928d279c9.tar.gz
.
-rw-r--r--PKGBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a1129e27d58..7e43a84d5f76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -119,7 +119,7 @@ prepare(){
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
+ msg "Applying patch $src..."
patch -Np1 < "../$src"
done
@@ -127,13 +127,20 @@ prepare(){
# Copy the config file first
# Copy "${srcdir}"/config to "${srcdir}"/linux-${_pkgver}/.config
- msg2 "Copy "${srcdir}"/config to "${srcdir}"/linux-$_pkgver/.config"
+ msg "Copy "${srcdir}"/config to "${srcdir}"/linux-$_pkgver/.config"
cp "${srcdir}"/config .config
sleep 2s
plain ""
+ msg "Enable BORE CPU scheduler"
+ scripts/config --enable CONFIG_SCHED_BORE
+
+ sleep 2s
+
+ plain ""
+
# # Remove gcc-plugin if gcc version = 13.0.0
# if [[ "$_gccversion" = "13.0.0" ]]; then
#
@@ -291,11 +298,6 @@ prepare(){
sleep 2s
- msg2 "Enable BORE CPU scheduler"
- scripts/config --enable CONFIG_SCHED_BORE
-
- sleep 2s
-
plain ""
msg "Supress depmod"
@@ -329,7 +331,7 @@ build(){
cd ${srcdir}/linux-$_pkgver
# make -j$(nproc) all
- msg2 "make -j$(nproc) all..."
+ msg "make -j$(nproc) all..."
make ARCH=${ARCH} ${BUILD_FLAGS[*]} -j$(nproc) all
}
@@ -346,7 +348,7 @@ _package(){
local kernver="$(<version)"
local modulesdir="${pkgdir}"/usr/lib/modules/${kernver}
- msg2 "Installing boot image..."
+ msg "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
#install -Dm644 arch/${ARCH}/boot/bzImage "$modulesdir/vmlinuz"
@@ -355,13 +357,13 @@ _package(){
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
- msg2 "Installing modules..."
+ msg "Installing modules..."
# ZSTD_CLEVEL=19
# Keep it not far away Arch use it in official repo, since we use sirlucjan xstd patch
make ARCH=${ARCH} ${BUILD_FLAGS[*]} INSTALL_MOD_PATH="${pkgdir}"/usr INSTALL_MOD_STRIP=1 -j$(nproc) modules_install
# remove build and source links
- msg2 "Remove build dir and source dir..."
+ msg "Remove build dir and source dir..."
rm -rf "$modulesdir"/{source,build}
}
@@ -373,7 +375,7 @@ _package-headers(){
local builddir="$pkgdir"/usr/lib/modules/"$(<version)"/build
- msg2 "Installing build files..."
+ msg "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map *localversion* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
@@ -387,7 +389,7 @@ _package-headers(){
install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
fi
- msg2 "Installing headers..."
+ msg "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
@@ -406,7 +408,7 @@ _package-headers(){
# https://bugs.archlinux.org/task/71392
install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
- msg2 "Installing KConfig files..."
+ msg "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
msg2 "Removing unneeded architectures..."
@@ -417,16 +419,16 @@ _package-headers(){
rm -r "$arch"
done
- msg2 "Removing documentation..."
+ msg "Removing documentation..."
rm -r "$builddir/Documentation"
- msg2 "Removing broken symlinks..."
+ msg "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
- msg2 "Removing loose objects..."
+ msg "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
- msg2 "Stripping build tools..."
+ msg "Stripping build tools..."
local file
while read -rd '' file; do
case "$(file -Sib "$file")" in
@@ -441,10 +443,10 @@ _package-headers(){
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- msg2 "Stripping vmlinux..."
+ msg "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
- msg2 "Adding symlink..."
+ msg "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}