summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Woudstra2023-06-24 09:15:11 +0200
committerEric Woudstra2023-06-24 09:16:07 +0200
commit3b2eea75962e1ecc5d79fd947021520e69b67baf (patch)
tree7fd3a03eb543e16daca75282303551efca86eda4
parentae386ee7278b5b5628773d30ee6bb1c113681e3e (diff)
downloadaur-3b2eea75962e1ecc5d79fd947021520e69b67baf.tar.gz
Fix HS400 and add DEBUGFS setting
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rwxr-xr-xbpir-flash2emmc4
3 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 137fdb404256..1c3b4d9f0ef2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bpir64-git
pkgver = 6.3.3.bpi
- pkgrel = 1
+ pkgrel = 2
url = http://www.kernel.org/
arch = aarch64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 1fefd6c959f7..42ec2abad7a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,18 @@
# Succesfull boot also depends on devictree-overlays from:
# https://github.com/ericwoud/buildR64arch
+# Optional settings:
+#_lto="true" # Uncomment this line to enable CLANG-LTO
+#_debugfs="true" # Uncomment this line to set CONFIG_DEBUG_FS=y
+
pkgbase=linux-bpir64-git
_srcname=linux
_gitroot="https://git.kernel.org/pub/scm/linux/kernel/git/stable/${_srcname}"
_gitbranch="linux-rolling-stable"
_kernelname=${pkgbase#linux}
_desc="AArch64 kernel for BPI-R64 and BPI-R3"
-#_lto="true" # Uncomment this line to enable CLANG-LTO
pkgver=6.3.3.bpi
-pkgrel=1
+pkgrel=2
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -67,6 +70,7 @@ prepare() {
# sed -i 's/mt6795-sony-xperia-m5/mt7986a-bananapi-bpi-r3/g' ./arch/arm64/boot/dts/mediatek/Makefile
cp -vf ${startdir}/defconfig ./arch/arm64/configs/bpir_defconfig
+ [[ "$_debugfs" == "true" ]] && echo -e "\nCONFIG_DEBUG_FS=y" >>./arch/arm64/configs/bpir_defconfig
make ${MAKEFLAGS} $_llvm bpir_defconfig
rm -vf ./arch/arm64/configs/bpir_defconfig
diff --git a/bpir-flash2emmc b/bpir-flash2emmc
index 3f63597d4812..ce9637155e35 100755
--- a/bpir-flash2emmc
+++ b/bpir-flash2emmc
@@ -29,8 +29,8 @@ cat <<EOT | tee /tmp/mmc0.dts
max-frequency = <200000000>;
cap-mmc-highspeed;
mmc-hs200-1_8v;
-// mmc-hs400-1_8v;
-// hs400-ds-delay = <0x14014>;
+ mmc-hs400-1_8v;
+ hs400-ds-delay = <0x14014>;
no-sd;
no-sdio;
status = "okay";