summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Woudstra2022-07-25 22:50:00 +0200
committerEric Woudstra2022-07-25 22:50:00 +0200
commit5a466079ee27405e964ab3e8ce5309f6fc37c045 (patch)
treeeb45014f21de78b3a79f1aa034bac418e2980f73
parent46d13799d63b9a7854dd66eaf700441e143864ff (diff)
downloadaur-5a466079ee27405e964ab3e8ce5309f6fc37c045.tar.gz
git pull --force
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--defconfig13
3 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96ae018a31b3..420ebfa91d7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bpir64-git
- pkgver = 5.18.13.bpi.r64.1
+ pkgver = 5.18.14.bpi.r64.1
pkgrel = 1
url = http://www.kernel.org/
arch = aarch64
@@ -31,7 +31,7 @@ pkgname = linux-bpir64-git
depends = kmod
depends = bpir64-atf-git
optdepends = mkinitcpio>=0.7
- provides = linux=5.18.13.bpi.r64.1
+ provides = linux=5.18.14.bpi.r64.1
provides = WIREGUARD-MODULE
conflicts = linux
replaces = linux-armv8
@@ -39,5 +39,5 @@ pkgname = linux-bpir64-git
pkgname = linux-bpir64-git-headers
pkgdesc = Header files and scripts for building modules for linux kernel - AArch64 kernel for BPIR64
- provides = linux-headers=5.18.13.bpi.r64.1
+ provides = linux-headers=5.18.14.bpi.r64.1
conflicts = linux-headers
diff --git a/PKGBUILD b/PKGBUILD
index 7b895b90cb9b..063f14f0b7f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _gitroot="https://git.kernel.org/pub/scm/linux/kernel/git/stable/${_srcname}"
_gitbranch="linux-rolling-stable"
_kernelname=${pkgbase#linux}
_desc="AArch64 kernel for BPIR64"
-pkgver=5.18.13.bpi.r64.1
+pkgver=5.18.14.bpi.r64.1
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
@@ -33,8 +33,7 @@ prepare() {
echo "LOCAL HEAD: $(git rev-parse HEAD)"
echo "REMOTE HEAD: $(git rev-parse @{u})"
if [ "$(git rev-parse HEAD)" != "$(git rev-parse @{u})" ]; then
- git reset --hard
- git fetch --depth 1 origin "${_gitbranch}:${_gitbranch}"
+ git pull --depth=1 --rebase=true --force origin "${_gitbranch}:${_gitbranch}"
git checkout "${_gitbranch}"
fi
echo
diff --git a/defconfig b/defconfig
index 33a874db5042..d9cfde1d39c2 100644
--- a/defconfig
+++ b/defconfig
@@ -605,6 +605,19 @@ CONFIG_USB_XHCI_MTK=y
# also be needed; see USB_STORAGE Help for more info
#
CONFIG_USB_STORAGE=y
+
+#
+# USB port drivers
+#
+CONFIG_USB_SERIAL=m
+CONFIG_USB_SERIAL_GENERIC=y
+CONFIG_USB_SERIAL_SIMPLE=m
+CONFIG_USB_SERIAL_CP210X=m
+CONFIG_USB_SERIAL_CYPRESS_M8=m
+CONFIG_USB_SERIAL_FTDI_SIO=m
+CONFIG_USB_SERIAL_IR=m
+CONFIG_USB_SERIAL_PL2303=m
+CONFIG_USB_SERIAL_DEBUG=m
CONFIG_MMC=y
#