summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Woudstra2023-08-12 09:08:10 +0200
committerEric Woudstra2023-08-12 09:08:10 +0200
commit6c123d9ad09e9db8fd17c3a03efe020e1d43b3a7 (patch)
treec32ba10f62813a2dcab8a93e7ca97bc2cbd9a71b
parenta03a652b01a89d5373aae56518bdeb86ccae53cc (diff)
downloadaur-6c123d9ad09e9db8fd17c3a03efe020e1d43b3a7.tar.gz
Add CONFIG_DEBUG_FS, net: rtl-usb as module
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--defconfig10
3 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f1c0ba6bfe0..d357dfbda23c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-bpir64-git
pkgver = 6.3.9.bpi
- pkgrel = 2
+ pkgrel = 3
url = http://www.kernel.org/
arch = aarch64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index fc56aeea7260..dab799e1e150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _gitroot="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux"
_kernelname=${pkgbase#linux}
_desc="AArch64 kernel for BPI-R64 and BPI-R3"
pkgver=6.3.9.bpi
-pkgrel=2
+pkgrel=3
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
diff --git a/defconfig b/defconfig
index 8de4710b6504..50b76876aff8 100644
--- a/defconfig
+++ b/defconfig
@@ -513,8 +513,8 @@ CONFIG_PPP_DEFLATE=m
CONFIG_PPP_FILTER=y
CONFIG_PPP_MPPE=m
CONFIG_PPPOE=m
-CONFIG_USB_RTL8150=y
-CONFIG_USB_RTL8152=y
+CONFIG_USB_RTL8150=m
+CONFIG_USB_RTL8152=m
CONFIG_USB_USBNET=m
CONFIG_USB_NET_CDC_MBIM=m
CONFIG_USB_ALI_M5632=y
@@ -1003,6 +1003,12 @@ CONFIG_STRIP_ASM_SYMS=y
# end of Compile-time checks and compiler options
#
+# Generic Kernel Debugging Instruments
+#
+CONFIG_DEBUG_FS=y
+# end of Generic Kernel Debugging Instruments
+
+#
# Debug Oops, Lockups and Hangs
#
CONFIG_PANIC_ON_OOPS=y